Every CVE Search/ Get API key

CVE-2019-9917

ZNC before 1.7.3-rc1 allows an existing remote user to cause a Denial of Service (crash) via...

6.5 MediumFix available

ZNC before 1.7.3-rc1 allows an existing remote user to cause a Denial of Service (crash) via invalid encoding.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

3.08%Down 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

ZNC before 1.7.3-rc1 allows an existing remote user to cause a Denial of Service (crash) via invalid encoding.

Record
CVE-2019-9917
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

ZNC before 1.7.3-rc1 allows an existing remote user to cause a Denial of Service (crash) via invalid encoding.

Record
CVE-2019-9917
Updated
2026-11-02
EUVDEUVD-2019-19272 No score

ZNC before 1.7.3-rc1 allows an existing remote user to cause a Denial of Service (crash) via invalid encoding.

Record
EUVD-2019-19272
Updated
2026-11-03
GitHub AdvisoriesGHSA-qwh2-7wpp-c8p6 6.5

ZNC before 1.7.3-rc1 allows an existing remote user to cause a Denial of Service (crash) via...

ZNC before 1.7.3-rc1 allows an existing remote user to cause a Denial of Service (crash) via invalid encoding.

Record
GHSA-qwh2-7wpp-c8p6
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVALPINE-CVE-2019-9917 6.5

ZNC before 1.7.3-rc1 allows an existing remote user to cause a Denial of Service (crash) via invalid encoding.

Record
ALPINE-CVE-2019-9917
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSV 6.5

ZNC before 1.7.3-rc1 allows an existing remote user to cause a Denial of Service (crash) via invalid encoding.

Record
CVE-2019-9917
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 7 moreShow less
OSVDEBIAN-CVE-2019-9917 6.5

ZNC before 1.7.3-rc1 allows an existing remote user to cause a Denial of Service (crash) via invalid encoding.

Record
DEBIAN-CVE-2019-9917
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-9917 6.5

ZNC before 1.7.3-rc1 allows an existing remote user to cause a Denial of Service (crash) via invalid encoding.

Record
UBUNTU-CVE-2019-9917
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2019-0262 No score

Updated znc packages fix security vulnerabilities

Jeriko One discovered two vulnerabilities in the ZNC IRC bouncer which could result in privilege escalation or denial of service (CVE-2018-14055, CVE-2018-14056).

Two vulnerabilities were discovered in the ZNC IRC bouncer which could result in remote code execution (CVE-2019-12816) or denial of service via invalid encoding (CVE-2019-9917).

Record
MGASA-2019-0262
Updated
2026-11-02
OSVopenSUSE-SU-2019:1166-1 No score

Security update for znc

This update for znc to version 1.7.2 fixes the following issue:

Security issue fixed:

  • CVE-2019-9917: Fixed an issue where due to invalid encoding znc was crashing (bsc#1130360).
Record
openSUSE-SU-2019:1166-1
Updated
2026-11-02
OSVopenSUSE-SU-2019:1775-1 No score

Security update for znc

This update for znc to version 1.7.4 fixes the following issues:

Security issues fixed:

  • CVE-2019-12816: Fixed a remote code execution in Modules.cpp (boo#1138572).
  • CVE-2019-9917: Fixed a denial of service on invalid encoding (boo#1130360).
Record
openSUSE-SU-2019:1775-1
Updated
2026-11-02
OSVopenSUSE-SU-2019:1859-1 No score

Security update for znc

This update for znc to version 1.7.4 fixes the following issues:

Security issues fixed:

  • CVE-2019-12816: Fixed a remote code execution in Modules.cpp (boo#1138572).
  • CVE-2019-9917: Fixed a denial of service on invalid encoding (boo#1130360).

This update was imported from the openSUSE:Leap:15.0:Update update project.

Record
openSUSE-SU-2019:1859-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11542-1 No score

znc-1.8.2-1.11 on GA media

These are all security issues fixed in the znc-1.8.2-1.11 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11542-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
znc
Alpine:v3.10
before 1.7.3-r0
1.7.3-r0
znc
Alpine:v3.11
before 1.7.3-r0
1.7.3-r0
znc
Alpine:v3.12
before 1.7.3-r0
1.7.3-r0
znc
Alpine:v3.13
before 1.7.3-r0
1.7.3-r0
znc
Alpine:v3.14
before 1.7.3-r0
1.7.3-r0
znc
Alpine:v3.15
before 1.7.3-r0
1.7.3-r0
znc
Alpine:v3.16
before 1.7.3-r0
1.7.3-r0
znc
Alpine:v3.17
before 1.7.3-r0
1.7.3-r0
znc
Alpine:v3.18
before 1.7.3-r0
1.7.3-r0
znc
Alpine:v3.19
before 1.7.3-r0
1.7.3-r0
Show 26 moreShow less
Affected packages
PackageAffectedFixed
znc
Alpine:v3.20
before 1.7.3-r0
1.7.3-r0
znc
Alpine:v3.21
before 1.7.3-r0
1.7.3-r0
znc
Alpine:v3.22
before 1.7.3-r0
1.7.3-r0
znc
Alpine:v3.23
before 1.7.3-r0
1.7.3-r0
znc
Alpine:v3.24
before 1.7.3-r0
1.7.3-r0
znc
Alpine:v3.7
before 1.7.1-r1
1.7.1-r1
znc
Alpine:v3.8
before 1.7.1-r1
1.7.1-r1
znc
Alpine:v3.9
before 1.7.1-r3
1.7.1-r3
znc
Debian:12
before 1.7.2-2
1.7.2-2
znc
Debian:13
before 1.7.2-2
1.7.2-2
znc
Debian:14
before 1.7.2-2
1.7.2-2
znc
Debian:9
From an advisory covering 2 CVEs
before 1.6.5-1+deb9u2, plus listed versions
1.6.5-11.6.5-1+deb9u1
1.6.5-1+deb9u2
znc
Mageia:6
From an advisory covering 4 CVEs
before 1.7.4-1.mga6
1.7.4-1.mga6
znc
Mageia:7
From an advisory covering 4 CVEs
before 1.7.4-1.mga7
1.7.4-1.mga7
znc
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
1.0-51.0-5build11.2-11.2-21.2-3
Show 4 moreShow less
1.2-3build11.2-3ubuntu0.11.2-3ubuntu0.1+esm11.2-3ubuntu0.1+esm3
None known
znc
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
1.6.1-11.6.1-1build11.6.1-21.6.2-11.6.2-2
Show 5 moreShow less
1.6.2-2build11.6.3-11.6.3-1ubuntu0.11.6.3-1ubuntu0.21.6.3-1ubuntu0.2+esm2
None known
znc
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
1.6.5-2build21.6.5-2build31.6.5-2build41.6.5-2build51.6.6-11.6.6-1ubuntu0.11.6.6-1ubuntu0.21.6.6-1ubuntu0.2+esm2
None known
znc
SUSE:Package Hub 12
before 1.7.2-bp150.2.3.1
1.7.2-bp150.2.3.1
znc
SUSE:Package Hub 12 SP2
before 1.7.2-bp150.2.3.1
1.7.2-bp150.2.3.1
znc
SUSE:Package Hub 15
before 1.7.2-bp150.2.3.1
1.7.2-bp150.2.3.1
znc
openSUSE:Leap 15.0
before 1.7.2-bp150.2.3.1
1.7.2-bp150.2.3.1
znc
SUSE:Package Hub 15
From an advisory covering 2 CVEs
before 1.7.4-bp150.2.6.1
1.7.4-bp150.2.6.1
znc
openSUSE:Leap 15.0
From an advisory covering 2 CVEs
before 1.7.4-bp150.2.6.1
1.7.4-bp150.2.6.1
znc
openSUSE:Leap 15.1
From an advisory covering 2 CVEs
before 1.7.4-bp150.2.6.1
1.7.4-bp150.2.6.1
znc
SUSE:Package Hub 15 SP1
From an advisory covering 2 CVEs
before 1.7.4-bp151.4.3.1
1.7.4-bp151.4.3.1
znc
openSUSE:Tumbleweed
From an advisory covering 5 CVEs
before 1.8.2-1.11
1.8.2-1.11

History

History
RecordedChangedSources
affected, facts
affectedOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-9917 is a medium vulnerability (CVSS 6.5) in Znc, published March 27, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.08%, the 87th percentile. Fixed in znc 1.7.3-r0.

References

Show 26 moreShow less
MoveEnter Open