Every CVE Search/ Get API key

CVE-2020-28928

In musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer...

5.5 MediumFix available

In musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer size and source character limit, as demonstrated by an invalid write access (buffer overflow).

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.65%Down 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

In musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer size and source character limit, as demonstrated by an invalid write access (buffer overflow).

Record
CVE-2020-28928
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

In musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer size and source character limit, as demonstrated by an invalid write access (buffer overflow).

Record
CVE-2020-28928
Updated
2026-11-02
EUVDEUVD-2020-21316 No score

In musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer size and source character limit, as demonstrated by an invalid write access (buffer overflow).

Record
EUVD-2020-21316
Updated
2026-11-03
GitHub AdvisoriesGHSA-7gwx-j9qc-6c6w No score

In musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer...

In musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer size and source character limit, as demonstrated by an invalid write access (buffer overflow).

Record
GHSA-7gwx-j9qc-6c6w
Weakness
CWE-787
Updated
2026-11-02
OSVALPINE-CVE-2020-28928 5.5

In musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer size and source character limit, as demonstrated by an invalid write access (buffer overflow).

Record
ALPINE-CVE-2020-28928
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVBELL-CVE-2020-28928 5.5

CVE-2020-28928 does not affect BellSoft software

Record
BELL-CVE-2020-28928
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSV 5.5

In musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer size and source character limit, as demonstrated by an invalid write access (buffer overflow).

Record
CVE-2020-28928
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-28928 5.5

In musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer size and source character limit, as demonstrated by an invalid write access (buffer overflow).

Record
DEBIAN-CVE-2020-28928
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-28928 5.5

In musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer size and source character limit, as demonstrated by an invalid write access (buffer overflow).

Record
UBUNTU-CVE-2020-28928
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-5990-1 No score

musl vulnerabilities

It was discovered that musl did not handle certain i386 math functions properly. An attacker could use this vulnerability to cause a denial of service (crash) or possibly execute arbitrary code. This issue only affected Ubuntu 14.04 ESM, Ubuntu 16.04 ESM, and Ubuntu 18.04 LTS. (CVE-2019-14697)

It was discovered that musl did not handle wide-character conversion properly. A remote attacker could use this vulnerability to cause resource consumption (infinite loop), denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 14.04 ESM, Ubuntu 16.04 ESM, Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS. (CVE-2020-28928)

Record
USN-5990-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
musl
Alpine:v3.10
before 1.1.22-r4
1.1.22-r4
musl
Alpine:v3.11
before 1.1.24-r3
1.1.24-r3
musl
Alpine:v3.12
before 1.1.24-r10
1.1.24-r10
musl
Alpine:v3.13
before 1.2.2_pre2-r0
1.2.2_pre2-r0
musl
Alpine:v3.14
before 1.2.2_pre2-r0
1.2.2_pre2-r0
musl
Alpine:v3.15
before 1.2.2_pre2-r0
1.2.2_pre2-r0
musl
Alpine:v3.16
before 1.2.2_pre2-r0
1.2.2_pre2-r0
musl
Alpine:v3.17
before 1.2.2_pre2-r0
1.2.2_pre2-r0
musl
Alpine:v3.18
before 1.2.2_pre2-r0
1.2.2_pre2-r0
musl
Alpine:v3.19
before 1.2.2_pre2-r0
1.2.2_pre2-r0
Show 18 moreShow less
Affected packages
PackageAffectedFixed
musl
Alpine:v3.20
before 1.2.2_pre2-r0
1.2.2_pre2-r0
musl
Alpine:v3.21
before 1.2.2_pre2-r0
1.2.2_pre2-r0
musl
Alpine:v3.22
before 1.2.2_pre2-r0
1.2.2_pre2-r0
musl
Alpine:v3.23
before 1.2.2_pre2-r0
1.2.2_pre2-r0
musl
Alpine:v3.24
before 1.2.2_pre2-r0
1.2.2_pre2-r0
musl
Alpine:v3.9
before 1.1.20-r6
1.1.20-r6
musl
Debian:12
before 1.2.2-1
1.2.2-1
musl
Debian:13
before 1.2.2-1
1.2.2-1
musl
Debian:14
before 1.2.2-1
1.2.2-1
musl
Debian:9
before 1.1.16-3+deb9u1, plus listed versions
1.1.16-3
1.1.16-3+deb9u1
musl
Ubuntu:Pro:14.04:LTS
before 0.9.15-1ubuntu0.1~esm2, plus listed versions
0.9.14-20.9.14-2ubuntu10.9.15-10.9.15-1ubuntu0.1~esm1
0.9.15-1ubuntu0.1~esm2
musl
Ubuntu:Pro:16.04:LTS
before 1.1.9-1ubuntu0.1~esm3, plus listed versions
1.1.9-11.1.9-1ubuntu0.1~esm2
1.1.9-1ubuntu0.1~esm3
musl
Ubuntu:Pro:18.04:LTS
before 1.1.19-1ubuntu0.1~esm1, plus listed versions
1.1.16-31.1.18-11.1.19-1
1.1.19-1ubuntu0.1~esm1
musl
Ubuntu:Pro:20.04:LTS
before 1.1.24-1ubuntu0.1~esm1, plus listed versions
1.1.23-2build11.1.24-1
1.1.24-1ubuntu0.1~esm1
musl
Ubuntu:Pro:14.04:LTS
From an advisory covering 2 CVEs
before 0.9.15-1ubuntu0.1~esm2, plus listed versions
0.9.14-20.9.14-2ubuntu10.9.15-10.9.15-1ubuntu0.1~esm1
0.9.15-1ubuntu0.1~esm2
musl
Ubuntu:Pro:16.04:LTS
From an advisory covering 2 CVEs
before 1.1.9-1ubuntu0.1~esm3, plus listed versions
1.1.9-11.1.9-1ubuntu0.1~esm2
1.1.9-1ubuntu0.1~esm3
musl
Ubuntu:Pro:18.04:LTS
From an advisory covering 2 CVEs
before 1.1.19-1ubuntu0.1~esm1, plus listed versions
1.1.16-31.1.18-11.1.19-1
1.1.19-1ubuntu0.1~esm1
musl
Ubuntu:Pro:20.04:LTS
From an advisory covering 2 CVEs
before 1.1.24-1ubuntu0.1~esm1, plus listed versions
1.1.23-2build11.1.24-1
1.1.24-1ubuntu0.1~esm1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-28928 is a medium vulnerability (CVSS 5.5) in Musl-libc Musl, published November 24, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.65%, the 51st percentile. Fixed in musl 1.1.22-r4.

References

Show 18 moreShow less
MoveEnter Open