Every CVE Search/ Get API key

CVE-2021-3935

When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can...

8.1 HighFix available

When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.12%Up 0.5 points since Nov 23, 2021
90%50%10%1%

What each source reports

NVD Score used 8.1

When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.

Record
CVE-2021-3935
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
5.1 MediumAV:N/AC:H/Au:N/C:P/I:P/A:P
Weakness
CWE-89, CWE-295
Updated
2026-11-02
CVE List No score

When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.

Record
CVE-2021-3935
Weakness
CWE-89
Updated
2026-11-02
EUVDEUVD-2021-27149 No score

When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.

Record
EUVD-2021-27149
Updated
2026-11-02
GitHub AdvisoriesGHSA-jh4v-gqwq-hfrr 8.1

When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can...

When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.

Record
GHSA-jh4v-gqwq-hfrr
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-89, CWE-295
Updated
2026-11-02
OSVALPINE-CVE-2021-3935 8.1

When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.

Record
ALPINE-CVE-2021-3935
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 8.1

When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.

Record
CVE-2021-3935
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-3935 8.1

When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.

Record
DEBIAN-CVE-2021-3935
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-3935 8.1

When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.

Record
UBUNTU-CVE-2021-3935
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBIT-pgbouncer-2021-3935 No score

When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.

Record
BIT-pgbouncer-2021-3935
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pgbouncer
Alpine:v3.18
before 1.16.1-r0
1.16.1-r0
pgbouncer
Alpine:v3.19
before 1.16.1-r0
1.16.1-r0
pgbouncer
Alpine:v3.20
before 1.16.1-r0
1.16.1-r0
pgbouncer
Alpine:v3.21
before 1.16.1-r0
1.16.1-r0
pgbouncer
Alpine:v3.22
before 1.16.1-r0
1.16.1-r0
pgbouncer
Alpine:v3.23
before 1.16.1-r0
1.16.1-r0
pgbouncer
Alpine:v3.24
before 1.16.1-r0
1.16.1-r0
pgbouncer
Bitnami
before 1.16.1
1.16.1
pgbouncer
Debian:12
before 1.16.1-1
1.16.1-1
pgbouncer
Debian:13
before 1.16.1-1
1.16.1-1
Show 7 moreShow less
Affected packages
PackageAffectedFixed
pgbouncer
Debian:14
before 1.16.1-1
1.16.1-1
pgbouncer
Debian:9
before 1.7.2-2+deb9u1, plus listed versions
1.7.2-2
1.7.2-2+deb9u1
pgbouncer
Debian:11
From an advisory covering 2 CVEs
before 1.15.0-1+deb11u1, plus listed versions
1.15.0-1
1.15.0-1+deb11u1
pgbouncer
Ubuntu:16.04:LTS
All versions, plus listed versions
1.5.5-11.6.1-11.7-1
None known
pgbouncer
Ubuntu:18.04:LTS
All versions, plus listed versions
1.7.2-3build11.7.2-65-g2b8e6cf-11.8.1-11.8.1-1build1
None known
pgbouncer
Ubuntu:20.04:LTS
All versions, plus listed versions
1.10.0-11.10.0-1build11.11.0-11.12.0-21.12.0-3
None known
pgbouncer
Ubuntu:22.04:LTS
All versions, plus listed versions
1.15.0-11.16.1-1ubuntu1
None known

History

History
RecordedChangedSources
affected, facts
affected, aliases, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-3935 is a high vulnerability (CVSS 8.1) in Pgbouncer, published November 22, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.12%, the 66th percentile. Fixed in pgbouncer 1.16.1-r0.

References

Show 9 moreShow less
MoveEnter Open