CVE-2024-42458
server.c in Neat VNC (aka neatvnc) before 0.8.1 does not properly validate the security type.
server.c in Neat VNC (aka neatvnc) before 0.8.1 does not properly validate the security type, a related issue to CVE-2006-2369.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
server.c in Neat VNC (aka neatvnc) before 0.8.1 does not properly validate the security type, a related issue to CVE-2006-2369.
- Record
CVE-2024-42458- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List
9.8
server.c in Neat VNC (aka neatvnc) before 0.8.1 does not properly validate the security type, a related issue to CVE-2006-2369.
- Record
CVE-2024-42458- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
EUVDEUVD-2024-39628
9.8
server.c in Neat VNC (aka neatvnc) before 0.8.1 does not properly validate the security type, a related issue to CVE-2006-2369.
- Record
EUVD-2024-39628- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jxwh-98r5-mx84
9.8
server.c in Neat VNC (aka neatvnc) before 0.8.1 does not properly validate the security type.
server.c in Neat VNC (aka neatvnc) before 0.8.1 does not properly validate the security type.
- Record
GHSA-jxwh-98r5-mx84- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVALPINE-CVE-2024-42458
9.8
server.c in Neat VNC (aka neatvnc) before 0.8.1 does not properly validate the security type, a related issue to CVE-2006-2369.
- Record
ALPINE-CVE-2024-42458- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSV
9.8
server.c in Neat VNC (aka neatvnc) before 0.8.1 does not properly validate the security type, a related issue to CVE-2006-2369.
- Record
CVE-2024-42458- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-42458
9.8
server.c in Neat VNC (aka neatvnc) before 0.8.1 does not properly validate the security type, a related issue to CVE-2006-2369.
- Record
DEBIAN-CVE-2024-42458- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-42458
9.8
server.c in Neat VNC (aka neatvnc) before 0.8.1 does not properly validate the security type, a related issue to CVE-2006-2369.
- Record
UBUNTU-CVE-2024-42458- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:14238-1 No score
libneatvnc0-0.8.1-1.1 on GA media
These are all security issues fixed in the libneatvnc0-0.8.1-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:14238-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
neatvncAlpine:v3.20 |
before 0.8.1-r0 | 0.8.1-r0 |
neatvncAlpine:v3.21 |
before 0.8.1-r0 | 0.8.1-r0 |
neatvncAlpine:v3.22 |
before 0.8.1-r0 | 0.8.1-r0 |
neatvncAlpine:v3.23 |
before 0.8.1-r0 | 0.8.1-r0 |
neatvncAlpine:v3.24 |
before 0.8.1-r0 | 0.8.1-r0 |
neatvncDebian:12 |
All versions, plus listed versions 0.5.4+dfsg-10.5.4+dfsg-2~exp10.6.0+dfsg-10.6.0+dfsg-20.6.0+dfsg-3 Show 12 moreShow less0.6.0+dfsg-40.7.0+dfsg-10.7.0+dfsg-1~exp10.7.1+dfsg-10.7.1+dfsg-20.8.0+dfsg-10.8.0+dfsg-20.8.0+dfsg-30.9.1+dfsg-10.9.1+dfsg-1.11.0.0+dfsg-1~exp11.0.1+dfsg-1 |
None known |
neatvncDebian:13 |
before 0.8.0+dfsg-2 | 0.8.0+dfsg-2 |
neatvncDebian:14 |
before 0.8.0+dfsg-2 | 0.8.0+dfsg-2 |
neatvncUbuntu:22.04:LTS |
All versions, plus listed versions 0.4.0+dfsg-2 |
None known |
neatvncUbuntu:24.04:LTS |
All versions, plus listed versions 0.6.0+dfsg-4build10.7.0+dfsg-10.7.1+dfsg-10.7.1+dfsg-20.7.1+dfsg-2build20.7.1+dfsg-2build3 |
None known |
neatvncopenSUSE:Tumbleweed |
before 0.8.1-1.1 | 0.8.1-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, references | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-42458 is a critical vulnerability (CVSS 9.8) in Any1 Neatvnc, published August 2, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.83%, the 57th percentile. Fixed in neatvnc 0.8.1-r0.
References
github.com/any1/neatvnc/commit/cc71650a69abc2573a0d96d082409d2468802d47
github.com/any1/neatvnc/compare/v0.8.0...v0.8.1
github.com/any1/neatvnc/releases/tag/v0.8.1
openwall.com/lists/oss-security/2024/08/02/1
openwall.com/lists/oss-security/2024/08/02/7
openwall.com/lists/oss-security/2024/08/02/10
Show 8 moreShow less
nvd.nist.gov/vuln/detail/CVE-2024-42458
github.com/advisories/GHSA-jxwh-98r5-mx84
security.alpinelinux.org/vuln/CVE-2024-42458
github.com/CVEProject/cvelistV5/tree/main/cves/2024/42xxx/CVE-2024-42458.json
security-tracker.debian.org/tracker/CVE-2024-42458
ubuntu.com/security/CVE-2024-42458
cve.org/CVERecord?id=CVE-2024-42458
suse.com/security/cve/CVE-2024-42458