Every CVE Search/ Get API key

CVE-2026-44073

seteuid failure ignored in auth modules

4.0 MediumFix available

Authentication modules in Netatalk 1.5.0 through 4.4.2 fail to check the return value of seteuid(), which may allow a remote authenticated attacker to retain elevated privileges under error conditions.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.28%Up 0.2 points since May 21, 2026
90%50%10%1%

What each source reports

CVE List Score used 4.0

seteuid failure ignored in auth modules

Authentication modules in Netatalk 1.5.0 through 4.4.2 fail to check the return value of seteuid(), which may allow a remote authenticated attacker to retain elevated privileges under error conditions.

Record
CVE-2026-44073
CVSS 3.1
4.0 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-273
Updated
2026-11-02
EUVDEUVD-2026-31220 4.0

Authentication modules in Netatalk 1.5.0 through 4.4.2 fail to check the return value of seteuid(), which may allow a remote authenticated attacker to retain elevated privileges under error conditions.

Record
EUVD-2026-31220
CVSS 3.1
4.0 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-pc7p-8fgv-4x9c 5.0

Authentication modules in Netatalk 1.5.0 through 4.4.2 fail to check the return value of seteuid(...

Authentication modules in Netatalk 1.5.0 through 4.4.2 fail to check the return value of seteuid(), which may allow a remote authenticated attacker to retain elevated privileges under error conditions.

Record
GHSA-pc7p-8fgv-4x9c
CVSS 3.1
5.0 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-273
Updated
2026-11-02
NVD 5.0

Authentication modules in Netatalk 1.5.0 through 4.4.2 fail to check the return value of seteuid(), which may allow a remote authenticated attacker to retain elevated privileges under error conditions.

Record
CVE-2026-44073
CVSS 3.1
5.0 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-273
Updated
2026-11-02
OSVALPINE-CVE-2026-44073 5.0

Authentication modules in Netatalk 1.5.0 through 4.4.2 fail to check the return value of seteuid(), which may allow a remote authenticated attacker to retain elevated privileges under error conditions.

Record
ALPINE-CVE-2026-44073
CVSS 3.1
5.0 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-03
OSVDEBIAN-CVE-2026-44073 5.0

Authentication modules in Netatalk 1.5.0 through 4.4.2 fail to check the return value of seteuid(), which may allow a remote authenticated attacker to retain elevated privileges under error conditions.

Record
DEBIAN-CVE-2026-44073
CVSS 3.1
5.0 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
OSVUBUNTU-CVE-2026-44073 5.0

Authentication modules in Netatalk 1.5.0 through 4.4.2 fail to check the return value of seteuid(), which may allow a remote authenticated attacker to retain elevated privileges under error conditions.

Record
UBUNTU-CVE-2026-44073
CVSS 3.1
5.0 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
netatalk
Alpine:v3.24
before 4.5.0-r0
4.5.0-r0
netatalk
Debian:13
All versions, plus listed versions
4.2.3~ds-14.2.3~ds-1+deb13u14.2.3~ds-1+deb13u24.2.3~ds-24.2.3~ds-2.1
Show 7 moreShow less
4.4.1~ds-14.4.2~ds-14.4.3~ds-14.5.0~ds-14.5.0~ds-24.5.0~ds-34.5.1~ds-1
None known
netatalk
Debian:14
before 4.5.0~ds-1, plus listed versions
4.2.3~ds-14.2.3~ds-24.2.3~ds-2.14.4.1~ds-14.4.2~ds-14.4.3~ds-1
4.5.0~ds-1
netatalk
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
2.2.2-1ubuntu12.2.2-1ubuntu22.2.2-1ubuntu2.22.2.2-1ubuntu2.2+esm12.2.2-1ubuntu2.2+esm22.2.2-1ubuntu2.2+esm32.2.2-1ubuntu2.2+esm4
None known
netatalk
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.2.5-12.2.5-1ubuntu0.22.2.5-1ubuntu0.2+esm12.2.5-1ubuntu0.2+esm22.2.5-1ubuntu0.2+esm32.2.5-1ubuntu0.2+esm4
None known
netatalk
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
2.2.6-12.2.6-1ubuntu0.18.04.22.2.6-1ubuntu0.18.04.2+esm12.2.6-1ubuntu0.18.04.2+esm22.2.6-1ubuntu0.18.04.2+esm32.2.6-1ubuntu0.18.04.2+esm4
None known
netatalk
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
3.1.12~ds-33.1.12~ds-43.1.12~ds-4ubuntu0.20.04.13.1.12~ds-4ubuntu0.20.04.33.1.12~ds-4ubuntu0.20.04.3+esm13.1.12~ds-4ubuntu0.20.04.43.1.12~ds-4ubuntu0.20.04.4+esm13.1.12~ds-4ubuntu0.20.04.4+esm2
None known
netatalk
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
3.1.12~ds-93.1.12~ds-9build13.1.12~ds-9ubuntu0.22.04.13.1.12~ds-9ubuntu0.22.04.33.1.12~ds-9ubuntu0.22.04.3+esm13.1.12~ds-9ubuntu0.22.04.43.1.12~ds-9ubuntu0.22.04.4+esm13.1.12~ds-9ubuntu0.22.04.4+esm2
None known
netatalk
Ubuntu:Pro:24.04:LTS
All versions, plus listed versions
3.1.15~ds-1ubuntu13.1.18~ds-13.1.18~ds-1build23.1.18~ds-1build43.1.18~ds-1ubuntu0.1~esm13.1.18~ds-1ubuntu0.1~esm23.1.18~ds-1ubuntu0.1~esm3
None known
netatalk
Ubuntu:25.10
All versions, plus listed versions
4.1.2~ds-44.2.1~ds-14.2.3~ds-1
None known
netatalk
Ubuntu:26.10
All versions, plus listed versions
4.2.3~ds-2.14.4.3~ds-14.5.0~ds-34.5.1~ds-1
None known
netatalk
Ubuntu:26.04:LTS
All versions, plus listed versions
4.2.3~ds-14.2.3~ds-24.2.3~ds-2.14.2.3~ds-2.1ubuntu0.14.2.3~ds-2.1ubuntu0.2
None known

History

History
RecordedChangedSources
affected, aliases, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-44073 is a medium vulnerability (CVSS 4.0) in Netatalk, published May 21, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.28%, the 20th percentile. Fixed in netatalk 4.5.0-r0.

References

MoveEnter Open