Every CVE Search/ Get API key

CVE-2026-6450

CRL critical extension bypass in ParseCRL_Extensions

1.0 LowFix available

A CRL critical extension bypass exists in ParseCRL_Extensions where critical extensions are not properly enforced, allowing a crafted CRL with an unhandled critical extension to be accepted. This only affects builds with CRL support enabled and where a crafted CRL had a trusted signature when parsed.

Attack profile

How easy it is to exploit

Attack vector
Adjacent network
Complexity
High
Privileges needed
High
User interaction
Passive

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

0.33%Up 0.2 points since Jun 26, 2026
90%50%10%1%

What each source reports

CVE List Score used 1.0

CRL critical extension bypass in ParseCRL_Extensions

A CRL critical extension bypass exists in ParseCRL_Extensions where critical extensions are not properly enforced, allowing a crafted CRL with an unhandled critical extension to be accepted. This only affects builds with CRL support enabled and where a crafted CRL had a trusted signature when parsed.

Record
CVE-2026-6450
CVSS 4.0
1.0 LowCVSS:4.0/AV:A/AC:H/AT:P/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Weakness
CWE-295
Updated
2026-11-02
EUVDEUVD-2026-39559 1.0

A CRL critical extension bypass exists in ParseCRL_Extensions where critical extensions are not properly enforced, allowing a crafted CRL with an unhandled critical extension to be accepted. This only affects builds with CRL support enabled and where a crafted CRL had a trusted signature when parsed.

Record
EUVD-2026-39559
CVSS 4.0
1.0 LowCVSS:4.0/AV:A/AC:H/AT:P/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-qpch-gjf6-c9gf 1.0

A CRL critical extension bypass exists in ParseCRL_Extensions where critical extensions are not...

A CRL critical extension bypass exists in ParseCRL_Extensions where critical extensions are not properly enforced, allowing a crafted CRL with an unhandled critical extension to be accepted. This only affects builds with CRL support enabled and where a crafted CRL had a trusted signature when parsed.

Record
GHSA-qpch-gjf6-c9gf
CVSS 4.0
1.0 LowCVSS:4.0/AV:A/AC:H/AT:P/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-295
Updated
2026-11-02
NVD 1.0

A CRL critical extension bypass exists in ParseCRL_Extensions where critical extensions are not properly enforced, allowing a crafted CRL with an unhandled critical extension to be accepted. This only affects builds with CRL support enabled and where a crafted CRL had a trusted signature when parsed.

Record
CVE-2026-6450
CVSS 4.0
1.0 LowCVSS:4.0/AV:A/AC:H/AT:P/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-295
Updated
2026-11-02
OSVALPINE-CVE-2026-6450 5.3

A CRL critical extension bypass exists in ParseCRL_Extensions where critical extensions are not properly enforced, allowing a crafted CRL with an unhandled critical extension to be accepted. This only affects builds with CRL support enabled and where a crafted CRL had a trusted signature when parsed.

Record
ALPINE-CVE-2026-6450
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-03
OSV 1.0

CRL critical extension bypass in ParseCRL_Extensions

A CRL critical extension bypass exists in ParseCRL_Extensions where critical extensions are not properly enforced, allowing a crafted CRL with an unhandled critical extension to be accepted. This only affects builds with CRL support enabled and where a crafted CRL had a trusted signature when parsed.

Record
CVE-2026-6450
CVSS 4.0
1.0 LowCVSS:4.0/AV:A/AC:H/AT:P/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Weakness
CWE-295
Updated
2026-11-02
OSVDEBIAN-CVE-2026-6450 5.3

A CRL critical extension bypass exists in ParseCRL_Extensions where critical extensions are not properly enforced, allowing a crafted CRL with an unhandled critical extension to be accepted. This only affects builds with CRL support enabled and where a crafted CRL had a trusted signature when parsed.

Record
DEBIAN-CVE-2026-6450
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVJLSEC-2026-751 1.0

A CRL critical extension bypass exists in `ParseCRL_Extensions` where critical extensions are not...

A CRL critical extension bypass exists in ParseCRL_Extensions where critical extensions are not properly enforced, allowing a crafted CRL with an unhandled critical extension to be accepted. This only affects builds with CRL support enabled and where a crafted CRL had a trusted signature when parsed.

Record
JLSEC-2026-751
CVSS 4.0
1.0 LowCVSS:4.0/AV:A/AC:H/AT:P/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2026-6450 1.0

A CRL critical extension bypass exists in ParseCRL_Extensions where critical extensions are not properly enforced, allowing a crafted CRL with an unhandled critical extension to be accepted. This only affects builds with CRL support enabled and where a crafted CRL had a trusted signature when parsed.

Record
UBUNTU-CVE-2026-6450
CVSS 4.0
1.0 LowCVSS:4.0/AV:A/AC:H/AT:P/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wolfssl
Alpine:v3.24
4.3.0 up to 5.9.2-r0
5.9.2-r0
wolfssl
Debian:12
before 5.5.4-2+deb12u3, plus listed versions
5.5.4-25.5.4-2+deb12u15.5.4-2+deb12u2
5.5.4-2+deb12u3
wolfssl
Debian:13
before 5.7.2-0.1+deb13u2, plus listed versions
5.7.2-0.15.7.2-0.1+deb13u1
5.7.2-0.1+deb13u2
wolfSSL_jll
Julia
before 5.9.2+0
5.9.2+0
wolfssl
Ubuntu:16.04:LTS
All versions, plus listed versions
3.4.8+dfsg-1
None known
wolfssl
Ubuntu:18.04:LTS
All versions, plus listed versions
3.10.2+dfsg-23.12.0+dfsg-13.12.2+dfsg-13.13.0+dfsg-1
None known
wolfssl
Ubuntu:20.04:LTS
All versions, plus listed versions
4.1.0+dfsg-24.2.0+dfsg-14.2.0+dfsg-24.2.0+dfsg-34.3.0+dfsg-2
None known
wolfssl
Ubuntu:22.04:LTS
All versions, plus listed versions
4.6.0-35.0.0-15.1.1-15.2.0-15.2.0-2
None known
wolfssl
Ubuntu:24.04:LTS
All versions, plus listed versions
5.5.4-25.5.4-2.15.6.4-25.6.6-1.25.6.6-1.35.6.6-1.3build1
None known
wolfssl
Ubuntu:25.10
All versions, plus listed versions
5.7.2-0.1
None known
wolfssl
Ubuntu:26.10
All versions, plus listed versions
5.9.1-0.15.9.2-1
None known
wolfssl
Ubuntu:26.04:LTS
All versions, plus listed versions
5.7.2-0.15.8.2-1.25.8.4-15.9.1-0.1
None known

History

History
RecordedChangedSources
affected, aliases, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-6450 is a low vulnerability (CVSS 1.0) in Wolfssl, published June 25, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 26th percentile. Fixed in wolfssl 5.9.2-r0.

References

Show 4 moreShow less
MoveEnter Open