Every CVE Search/ Get API key

CVE-2022-46663

In GNU Less before 609, crafted data can result in "less -R" not filtering ANSI escape sequences...

7.5 HighFix available

In GNU Less before 609, crafted data can result in "less -R" not filtering ANSI escape sequences sent to the terminal.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.41%Up 0.5 points since Feb 8, 2023
90%50%10%1%

What each source reports

NVD Score used 7.5

In GNU Less before 609, crafted data can result in "less -R" not filtering ANSI escape sequences sent to the terminal.

Record
CVE-2022-46663
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
CVE List 7.5

In GNU Less before 609, crafted data can result in "less -R" not filtering ANSI escape sequences sent to the terminal.

Record
CVE-2022-46663
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
EUVDEUVD-2022-49459 7.5

In GNU Less before 609, crafted data can result in "less -R" not filtering ANSI escape sequences sent to the terminal.

Record
EUVD-2022-49459
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-5xw7-xf7p-gm82 7.5

In GNU Less before 609, crafted data can result in "less -R" not filtering ANSI escape sequences...

In GNU Less before 609, crafted data can result in "less -R" not filtering ANSI escape sequences sent to the terminal.

Record
GHSA-5xw7-xf7p-gm82
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVAZL-13350 7.5

CVE-2022-46663 affecting package less for versions less than 590-2

In GNU Less before 609, crafted data can result in "less -R" not filtering ANSI escape sequences sent to the terminal.

Record
AZL-13350
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVBELL-CVE-2022-46663 7.5
Record
BELL-CVE-2022-46663
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 10 moreShow less
OSV 7.5

In GNU Less before 609, crafted data can result in "less -R" not filtering ANSI escape sequences sent to the terminal.

Record
CVE-2022-46663
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2022-46663 7.5

In GNU Less before 609, crafted data can result in "less -R" not filtering ANSI escape sequences sent to the terminal.

Record
DEBIAN-CVE-2022-46663
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVOESA-2023-1129 5.5

less security update

Less is a pager. A pager is a program that displays text files.Other pagers commonly in use are more and pg. Pagers are often used in command-line environments like the Unix shell and the MS-DOS command prompt to display files.Less is not an editor. You can't change the contents of the file you're viewing. Less is not a windowing system. It doesn't have fancy scroll bars or other GUI (graphical user interface) elements.

Security Fix(es):

In GNU Less before 609, crafted data can result in "less -R" not filtering ANSI escape sequences sent to the terminal.(CVE-2022-46663)

Record
OESA-2023-1129
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVRHSA-2023:3725 7.5

Red Hat Security Advisory: less security update

Record
RHSA-2023:3725
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVRLSA-2023:3725 7.5

Moderate: less security update

The "less" utility is a text file browser that resembles "more", but allows users to move backwards in the file as well as forwards. Since "less" does not read the entire input file at startup, it also starts more quickly than ordinary text editors.

Security Fix(es):

  • less: crafted data can result in "less -R" not filtering ANSI escape sequences sent to the terminal (CVE-2022-46663)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Record
RLSA-2023:3725
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2022-46663 7.5

In GNU Less before 609, crafted data can result in "less -R" not filtering ANSI escape sequences sent to the terminal.

Record
UBUNTU-CVE-2022-46663
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVALSA-2023:3725 No score

Moderate: less security update

The "less" utility is a text file browser that resembles "more", but allows users to move backwards in the file as well as forwards. Since "less" does not read the entire input file at startup, it also starts more quickly than ordinary text editors.

Security Fix(es):

  • less: crafted data can result in "less -R" not filtering ANSI escape sequences sent to the terminal (CVE-2022-46663)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Record
ALSA-2023:3725
Updated
2026-11-02
OSVopenSUSE-SU-2024:12671-1 No score

less-608-2.1 on GA media

These are all security issues fixed in the less-608-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12671-1
Updated
2026-11-02
OSVSUSE-SU-2023:0348-1 No score

Security update for less

This update for less fixes the following issues:

  • CVE-2022-46663: Fixed denial-of-service by printing specially crafted escape sequences to the terminal (bsc#1207815).
Record
SUSE-SU-2023:0348-1
Updated
2026-11-02
OSVUSN-5848-1 No score

less vulnerability

David Leadbeater discovered that less was not properly handling escape sequences when displaying raw control characters. A maliciously formed OSC 8 hyperlink could possibly be used by an attacker to cause a denial of service.

Record
USN-5848-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
less
AlmaLinux:9
before 590-2.el9_2
590-2.el9_2
less
Azure Linux:2
before 590-2
590-2
less
Alpaquita:23
608-r0 up to 608-r1
608-r1
less
Debian:12
before 590-1.2
590-1.2
less
Debian:13
before 590-1.2
590-1.2
less
Debian:14
before 590-1.2
590-1.2
less
openEuler:20.03-LTS-SP1
before 590-2.oe1
590-2.oe1
less
openEuler:20.03-LTS-SP3
before 590-2.oe1
590-2.oe1
less
openEuler:22.03-LTS
before 590-4.oe2203sp1
590-4.oe2203sp1
less
openEuler:22.03-LTS-SP1
before 590-4.oe2203sp1
590-4.oe2203sp1
Show 10 moreShow less
Affected packages
PackageAffectedFixed
less
Red Hat:enterprise_linux:9::baseos
before 0:590-2.el9_2
0:590-2.el9_2
less-debuginfo
Red Hat:enterprise_linux:9::baseos
before 0:590-2.el9_2
0:590-2.el9_2
less-debugsource
Red Hat:enterprise_linux:9::baseos
before 0:590-2.el9_2
0:590-2.el9_2
less
Rocky Linux:9
before 0:590-2.el9_2
0:590-2.el9_2
less
SUSE:Linux Enterprise Micro 5.3
before 590-150400.3.3.1
590-150400.3.3.1
less
SUSE:Linux Enterprise Module for Basesystem 15 SP4
before 590-150400.3.3.1
590-150400.3.3.1
less
openSUSE:Leap Micro 5.3
before 590-150400.3.3.1
590-150400.3.3.1
less
openSUSE:Leap 15.4
before 590-150400.3.3.1
590-150400.3.3.1
less
Ubuntu:22.04:LTS
before 590-1ubuntu0.22.04.1, plus listed versions
551-2551-2build1590-1590-1build1
590-1ubuntu0.22.04.1
less
openSUSE:Tumbleweed
before 608-2.1
608-2.1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-46663 is a high vulnerability (CVSS 7.5) in Gnu Less, published February 7, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.41%, the 72nd percentile. Fixed in less 590-2.el9_2.

References

Show 20 moreShow less
MoveEnter Open