Every CVE Search/ Get API key

CVE-2024-27913

ospf_te_parse_te in ospfd/ospf_te.c in FRRouting (FRR) through 9.1 allows remote attackers to...

6.5 MediumFix available

ospf_te_parse_te in ospfd/ospf_te.c in FRRouting (FRR) through 9.1 allows remote attackers to cause a denial of service (ospfd daemon crash) via a malformed OSPF LSA packet, because of an attempted access to a missing attribute field.

Attack profile

How easy it is to exploit

Attack vector
Adjacent network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.32%Up 0.3 points since Feb 28, 2024
90%50%10%1%

What each source reports

NVD Score used 6.5

ospf_te_parse_te in ospfd/ospf_te.c in FRRouting (FRR) through 9.1 allows remote attackers to cause a denial of service (ospfd daemon crash) via a malformed OSPF LSA packet, because of an attempted access to a missing attribute field.

Record
CVE-2024-27913
CVSS 3.1
6.5 MediumCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 3.1
6.2 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-909
Updated
2026-11-02
CVE List 6.2

ospf_te_parse_te in ospfd/ospf_te.c in FRRouting (FRR) through 9.1 allows remote attackers to cause a denial of service (ospfd daemon crash) via a malformed OSPF LSA packet, because of an attempted access to a missing attribute field.

Record
CVE-2024-27913
CVSS 3.1
6.2 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-909
Updated
2026-11-02
EUVDEUVD-2024-25104 6.2

ospf_te_parse_te in ospfd/ospf_te.c in FRRouting (FRR) through 9.1 allows remote attackers to cause a denial of service (ospfd daemon crash) via a malformed OSPF LSA packet, because of an attempted access to a missing attribute field.

Record
EUVD-2024-25104
CVSS 3.1
6.2 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-46v4-9j9w-fv79 6.5

ospf_te_parse_te in ospfd/ospf_te.c in FRRouting (FRR) through 9.1 allows remote attackers to...

ospf_te_parse_te in ospfd/ospf_te.c in FRRouting (FRR) through 9.1 allows remote attackers to cause a denial of service (ospfd daemon crash) via a malformed OSPF LSA packet, because of an attempted access to a missing attribute field.

Record
GHSA-46v4-9j9w-fv79
CVSS 3.1
6.5 MediumCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-909
Updated
2026-11-02
OSVAZL-35450 6.5

CVE-2024-27913 affecting package frr for versions less than 8.5.5-1

ospf_te_parse_te in ospfd/ospf_te.c in FRRouting (FRR) through 9.1 allows remote attackers to cause a denial of service (ospfd daemon crash) via a malformed OSPF LSA packet, because of an attempted access to a missing attribute field.

Record
AZL-35450
CVSS 3.1
6.5 MediumCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 6.2

ospf_te_parse_te in ospfd/ospf_te.c in FRRouting (FRR) through 9.1 allows remote attackers to cause a denial of service (ospfd daemon crash) via a malformed OSPF LSA packet, because of an attempted access to a missing attribute field.

Record
CVE-2024-27913
CVSS 3.1
6.2 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2024-27913 6.5

ospf_te_parse_te in ospfd/ospf_te.c in FRRouting (FRR) through 9.1 allows remote attackers to cause a denial of service (ospfd daemon crash) via a malformed OSPF LSA packet, because of an attempted access to a missing attribute field.

Record
DEBIAN-CVE-2024-27913
CVSS 3.1
6.5 MediumCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2024-27913 6.5

ospf_te_parse_te in ospfd/ospf_te.c in FRRouting (FRR) through 9.1 allows remote attackers to cause a denial of service (ospfd daemon crash) via a malformed OSPF LSA packet, because of an attempted access to a missing attribute field.

Record
UBUNTU-CVE-2024-27913
CVSS 3.1
6.5 MediumCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 3.1
6.2 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:13911-1 No score

frr-8.4-11.1 on GA media

These are all security issues fixed in the frr-8.4-11.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:13911-1
Updated
2026-11-02
OSVSUSE-SU-2024:1453-1 No score

Security update for frr

This update for frr fixes the following issues:

  • CVE-2024-27913: Fixed a denial of service issue via a malformed OSPF LSA packet (bsc#1220548).
  • CVE-2024-31948: Fixed denial of service due to malformed Prefix SID attribute in BGP Update packet (bsc#1222518).
Record
SUSE-SU-2024:1453-1
Updated
2026-11-02
OSVSUSE-SU-2024:4090-1 No score

Security update for frr

This update for frr fixes the following issues:

Update to frr 8.5.6 (jsc#PED-PED-11092) including fixes for:

  • CVE-2024-44070,CVE-2024-34088,CVE-2024-31951,CVE-2024-31950, CVE-2024-31948,CVE-2024-27913,CVE-2023-47235,CVE-2023-47234, CVE-2023-46753,CVE-2023-46752,CVE-2023-41909,CVE-2023-41360, CVE-2023-41358,CVE-2023-38802,CVE-2023-38407,CVE-2023-38406, CVE-2023-3748,CVE-2023-31490,CVE-2023-31489 and other bugfixes. See https://frrouting.org/release/8.5.6/ for details.

The most recent frr 8.x series provides several new features, improvements and bug fixes for various protocols and daemons, especially for PIM/PIMv6/BGP and VRF support.

See https://frrouting.org/release/8.5/ for details and links.

Record
SUSE-SU-2024:4090-1
Updated
2026-11-02
OSVUSN-6679-1 No score

frr vulnerability

It was discovered that FRR incorrectly handled certain malformed OSPF LSA packets. A remote attacker could possibly use this issue to cause FRR to crash, resulting in a denial of service.

Record
USN-6679-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
frr
Azure Linux:2
before 8.5.5-1
8.5.5-1
frr
Debian:12
before 8.4.4-1.1~deb12u2, plus listed versions
8.4.2-18.4.4-18.4.4-1.1~deb12u1
8.4.4-1.1~deb12u2
frr
Debian:13
before 9.1-0.1
9.1-0.1
frr
Debian:14
before 9.1-0.1
9.1-0.1
frr
SUSE:Linux Enterprise Module for Server Applications 15 SP5
From an advisory covering 2 CVEs
before 8.4-150500.4.20.1
8.4-150500.4.20.1
frr
openSUSE:Leap 15.5
From an advisory covering 2 CVEs
before 8.4-150500.4.20.1
8.4-150500.4.20.1
frr
SUSE:Linux Enterprise Module for Server Applications 15 SP5
From an advisory covering 19 CVEs
before 8.5.6-150500.4.30.1
8.5.6-150500.4.30.1
frr
SUSE:Linux Enterprise Module for Server Applications 15 SP6
From an advisory covering 19 CVEs
before 8.5.6-150500.4.30.1
8.5.6-150500.4.30.1
frr
openSUSE:Leap 15.5
From an advisory covering 19 CVEs
before 8.5.6-150500.4.30.1
8.5.6-150500.4.30.1
frr
openSUSE:Leap 15.6
From an advisory covering 19 CVEs
before 8.5.6-150500.4.30.1
8.5.6-150500.4.30.1
frr
Ubuntu:22.04:LTS
before 8.1-1ubuntu1.9, plus listed versions
7.5.1-1.18.1-18.1-1ubuntu18.1-1ubuntu1.18.1-1ubuntu1.2
Show 6 moreShow less
8.1-1ubuntu1.38.1-1ubuntu1.48.1-1ubuntu1.58.1-1ubuntu1.68.1-1ubuntu1.78.1-1ubuntu1.8
8.1-1ubuntu1.9
frr
Ubuntu:24.04:LTS
before 8.4.4-1.1ubuntu4, plus listed versions
8.4.4-1.1ubuntu18.4.4-1.1ubuntu3
8.4.4-1.1ubuntu4
frr
openSUSE:Tumbleweed
before 8.4-11.1
8.4-11.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-27913 is a medium vulnerability (CVSS 6.5) in Frrouting, published February 28, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.32%, the 25th percentile. Fixed in frr 8.5.5-1.

References

Show 25 moreShow less
MoveEnter Open