Every CVE Search/ Get API key

CVE-2016-7567

Buffer overflow in the SLPFoldWhiteSpace function in common/slp_compare.c in OpenSLP 2.0 allows...

9.8 CriticalPublic exploitFix available

Buffer overflow in the SLPFoldWhiteSpace function in common/slp_compare.c in OpenSLP 2.0 allows remote attackers to have unspecified impact via a crafted string.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

12.4%Up 2.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Buffer overflow in the SLPFoldWhiteSpace function in common/slp_compare.c in OpenSLP 2.0 allows remote attackers to have unspecified impact via a crafted string.

Record
CVE-2016-7567
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in the SLPFoldWhiteSpace function in common/slp_compare.c in OpenSLP 2.0 allows remote attackers to have unspecified impact via a crafted string.

Record
CVE-2016-7567
Updated
2026-11-02
EUVDEUVD-2016-8420 No score

Buffer overflow in the SLPFoldWhiteSpace function in common/slp_compare.c in OpenSLP 2.0 allows remote attackers to have unspecified impact via a crafted string.

Record
EUVD-2016-8420
Updated
2026-11-03
GitHub AdvisoriesGHSA-q4qm-j969-4v59 9.8

Buffer overflow in the SLPFoldWhiteSpace function in common/slp_compare.c in OpenSLP 2.0 allows...

Buffer overflow in the SLPFoldWhiteSpace function in common/slp_compare.c in OpenSLP 2.0 allows remote attackers to have unspecified impact via a crafted string.

Record
GHSA-q4qm-j969-4v59
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSVAZL-36967 9.8

CVE-2016-7567 affecting package openslp for versions less than 2.0.0-26

Buffer overflow in the SLPFoldWhiteSpace function in common/slp_compare.c in OpenSLP 2.0 allows remote attackers to have unspecified impact via a crafted string.

Record
AZL-36967
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVAZL-7320 9.8

CVE-2016-7567 affecting package openslp for versions less than 2.0.0-26

Buffer overflow in the SLPFoldWhiteSpace function in common/slp_compare.c in OpenSLP 2.0 allows remote attackers to have unspecified impact via a crafted string.

Record
AZL-7320
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVMGASA-2016-0348 No score

Updated openslp packages fix security vulnerability

A memory corruption bug was present in openslp due to lack of bounds checking in SLPFoldWhiteSpace() (CVE-2016-7567).

Record
MGASA-2016-0348
Updated
2026-11-02
OSVopenSUSE-SU-2024:10065-1 No score

openslp-2.0.0-8.1 on GA media

These are all security issues fixed in the openslp-2.0.0-8.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10065-1
Updated
2026-11-02
OSVSUSE-SU-2016:2661-1 No score

Security update for openslp

This update for openslp fixes two security issues and two bugs.

The following vulnerabilities were fixed:

  • CVE-2016-4912: A remote attacker could have crashed the server with a large number of packages (bsc#980722)
  • CVE-2016-7567: A remote attacker could cause a memory corruption having unspecified impact (bsc#1001600)

The following bugfix changes are included:

  • bsc#994989: Removed convenience code as changes bytes in the message buffer breaking the verification code
  • bsc#974655: Removed no longer needed slpd init file
Record
SUSE-SU-2016:2661-1
Updated
2026-11-02
OSVSUSE-SU-2018:0100-1 No score

Security update for openslp

This update for openslp fixes two security issues and two bugs.

The following vulnerabilities were fixed:

  • CVE-2016-4912: A remote attacker could have crashed the server with a large number of packages (bsc#980722)
  • CVE-2016-7567: A remote attacker could cause a memory corruption having unspecified impact (bsc#1001600)

The following bugfix changes are included:

  • bsc#994989: Removed convenience code as changes bytes in the message buffer breaking the verification code
  • bsc#974655: Removed no longer needed slpd init file
Record
SUSE-SU-2018:0100-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openslp
Azure Linux:3
before 2.0.0-26
2.0.0-26
openslp
Azure Linux:2
before 2.0.0-26
2.0.0-26
openslp
Mageia:5
before 2.0.0-5.2.mga5
2.0.0-5.2.mga5
openslp
SUSE:Linux Enterprise Desktop 12 SP1
before 2.0.0-17.1
2.0.0-17.1
openslp
SUSE:Linux Enterprise Software Development Kit 12 SP1
before 2.0.0-17.1
2.0.0-17.1
openslp
SUSE:Linux Enterprise Server 12 SP1
before 2.0.0-17.1
2.0.0-17.1
openslp
SUSE:Linux Enterprise Server for SAP Applications 12 SP1
before 2.0.0-17.1
2.0.0-17.1
openslp
SUSE:Linux Enterprise Desktop 12 SP2
before 2.0.0-18.2.1
2.0.0-18.2.1
openslp
SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2
before 2.0.0-18.2.1
2.0.0-18.2.1
openslp
SUSE:Linux Enterprise Software Development Kit 12 SP2
before 2.0.0-18.2.1
2.0.0-18.2.1
openslp
SUSE:Linux Enterprise Server 12 SP2
before 2.0.0-18.2.1
2.0.0-18.2.1
openslp
SUSE:Linux Enterprise Server for SAP Applications 12 SP2
before 2.0.0-18.2.1
2.0.0-18.2.1
openslp
openSUSE:Tumbleweed
before 2.0.0-8.1
2.0.0-8.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBOpenSLP 2.0.0 - Multiple Vulnerabilities2018-11-07

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-7567 is a critical vulnerability (CVSS 9.8) in Openslp, published October 20, 2016. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 12.4%, the 96th percentile. Fixed in openslp 2.0.0-26.

References

Show 13 moreShow less
MoveEnter Open