CVE-2008-2149
Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow...
Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.
Exploit likelihood
What each source reports
NVD Score used
7.5
Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.
- Record
CVE-2008-2149- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.
- Record
CVE-2008-2149- Updated
- 2026-11-02
EUVDEUVD-2008-2146 No score
Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.
- Record
EUVD-2008-2146- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4hrh-x42w-7jw8 No score
Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow...
Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.
- Record
GHSA-4hrh-x42w-7jw8- Weakness
- CWE-119
- Updated
- 2026-11-02
OSVAZL-37060 No score
CVE-2008-2149 affecting package wordnet for versions less than 3.0-43
Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.
- Record
AZL-37060- Updated
- 2026-11-05
OSVAZL-7422 No score
CVE-2008-2149 affecting package wordnet for versions less than 3.0-38
Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.
- Record
AZL-7422- Updated
- 2026-11-02
OSV No score
Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.
- Record
CVE-2008-2149- Updated
- 2026-11-02
OSVDEBIAN-CVE-2008-2149 No score
Stack-based buffer overflow in the searchwn function in Wordnet 2.0, 2.1, and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.
- Record
DEBIAN-CVE-2008-2149- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wordnetAzure Linux:3 |
before 3.0-43 | 3.0-43 |
wordnetAzure Linux:2 |
before 3.0-38 | 3.0-38 |
wordnetDebian:12 |
before 1:3.0-10 | 1:3.0-10 |
wordnetDebian:13 |
before 1:3.0-10 | 1:3.0-10 |
wordnetDebian:14 |
before 1:3.0-10 | 1:3.0-10 |
wordnetDebian:4.0 From an advisory covering 2 CVEs |
before 1:2.1-4+etch1, plus listed versions 1:2.1-4 |
1:2.1-4+etch1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| facts | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2008-2149 is a high vulnerability (CVSS 7.5) in Wordnet, published May 12, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.09%, the 90th percentile. Fixed in wordnet 3.0-43.
References
secunia.com/advisories/30242
mandriva.com/security/advisories?name=MDVSA-2008:182
bugs.gentoo.org/show_bug.cgi?id=211491
secunia.com/advisories/31654
secunia.com/advisories/32184
exchange.xforce.ibmcloud.com/vulnerabilities/42378