Every CVE Search/ Get API key

CVE-2022-35015

Advancecomp v2.3 was discovered to contain a heap buffer overflow via le_uint32_read at /lib...

5.5 MediumFix available

Advancecomp v2.3 was discovered to contain a heap buffer overflow via le_uint32_read at /lib/endianrw.h.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.47%Down 0.4 points since Aug 30, 2022
90%50%10%1%

What each source reports

NVD Score used 5.5

Advancecomp v2.3 was discovered to contain a heap buffer overflow via le_uint32_read at /lib/endianrw.h.

Record
CVE-2022-35015
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

Advancecomp v2.3 was discovered to contain a heap buffer overflow via le_uint32_read at /lib/endianrw.h.

Record
CVE-2022-35015
Updated
2026-11-02
EUVDEUVD-2022-37913 No score

Advancecomp v2.3 was discovered to contain a heap buffer overflow via le_uint32_read at /lib/endianrw.h.

Record
EUVD-2022-37913
Updated
2026-11-03
GitHub AdvisoriesGHSA-vrhv-32q9-93jj 5.5

Advancecomp v2.3 was discovered to contain a heap buffer overflow via le_uint32_read at /lib...

Advancecomp v2.3 was discovered to contain a heap buffer overflow via le_uint32_read at /lib/endianrw.h.

Record
GHSA-vrhv-32q9-93jj
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-787
Updated
2026-11-02
OSVALPINE-CVE-2022-35015 5.5

Advancecomp v2.3 was discovered to contain a heap buffer overflow via le_uint32_read at /lib/endianrw.h.

Record
ALPINE-CVE-2022-35015
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVAZL-43579 5.5

CVE-2022-35015 affecting package advancecomp 2.5-1

Advancecomp v2.3 was discovered to contain a heap buffer overflow via le_uint32_read at /lib/endianrw.h.

Record
AZL-43579
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVAZL-44367 5.5

CVE-2022-35015 affecting package advancecomp 2.6-1

Advancecomp v2.3 was discovered to contain a heap buffer overflow via le_uint32_read at /lib/endianrw.h.

Record
AZL-44367
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2022-35015 5.5

Advancecomp v2.3 was discovered to contain a heap buffer overflow via le_uint32_read at /lib/endianrw.h.

Record
DEBIAN-CVE-2022-35015
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVUBUNTU-CVE-2022-35015 5.5

Advancecomp v2.3 was discovered to contain a heap buffer overflow via le_uint32_read at /lib/endianrw.h.

Record
UBUNTU-CVE-2022-35015
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV No score

Advancecomp v2.3 was discovered to contain a heap buffer overflow via le_uint32_read at /lib/endianrw.h.

Record
CVE-2022-35015
Updated
2026-11-02
OSVMGASA-2022-0479 No score

Updated advancecomp packages fix security vulnerability

advancecomp has been updated to fix a number of bugs and security issues.

Record
MGASA-2022-0479
Updated
2026-11-02
OSVUSN-5838-1 No score

advancecomp vulnerabilities

It was discovered that AdvanceCOMP did not properly manage memory while performing read operations on MNG file. If a user were tricked into opening a specially crafted MNG file, a remote attacker could possibly use this issue to cause AdvanceCOMP to crash, resulting in a denial of service. (CVE-2022-35014, CVE-2022-35017, CVE-2022-35018, CVE-2022-35019, CVE-2022-35020)

It was discovered that AdvanceCOMP did not properly manage memory while performing read operations on ZIP file. If a user were tricked into opening a specially crafted ZIP file, a remote attacker could possibly use this issue to cause AdvanceCOMP to crash, resulting in a denial of service. (CVE-2022-35015, CVE-2022-35016)

Record
USN-5838-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
advancecomp
Alpine:v3.18
before 2.4-r0
2.4-r0
advancecomp
Alpine:v3.19
before 2.4-r0
2.4-r0
advancecomp
Alpine:v3.20
before 2.4-r0
2.4-r0
advancecomp
Alpine:v3.21
before 2.4-r0
2.4-r0
advancecomp
Alpine:v3.22
before 2.4-r0
2.4-r0
advancecomp
Alpine:v3.23
before 2.4-r0
2.4-r0
advancecomp
Alpine:v3.24
before 2.4-r0
2.4-r0
advancecomp
Azure Linux:2
through 2.5-1 None known
advancecomp
Azure Linux:3
through 2.6-1 None known
advancecomp
Debian:12
before 2.4-1
2.4-1
Show 7 moreShow less
Affected packages
PackageAffectedFixed
advancecomp
Debian:13
before 2.4-1
2.4-1
advancecomp
Debian:14
before 2.4-1
2.4-1
advancecomp
Mageia:8
before 2.4-1.mga8
2.4-1.mga8
advancecomp
Ubuntu:Pro:16.04:LTS
before 1.20-1ubuntu0.2+esm2, plus listed versions
1.19-11.20-11.20-1ubuntu0.11.20-1ubuntu0.21.20-1ubuntu0.2+esm1
1.20-1ubuntu0.2+esm2
advancecomp
Ubuntu:18.04:LTS
before 2.1-1ubuntu0.18.04.3, plus listed versions
2.0-12.1-12.1-1ubuntu0.18.04.12.1-1ubuntu0.18.04.2
2.1-1ubuntu0.18.04.3
advancecomp
Ubuntu:20.04:LTS
before 2.1-2.1ubuntu0.20.04.1, plus listed versions
2.1-2.12.1-2.1build1
2.1-2.1ubuntu0.20.04.1
advancecomp
Ubuntu:22.04:LTS
before 2.1-2.1ubuntu2.1, plus listed versions
2.1-2.1ubuntu12.1-2.1ubuntu2
2.1-2.1ubuntu2.1

History

History
RecordedChangedSources
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-35015 is a medium vulnerability (CVSS 5.5) in Advancemame Advancecomp, published August 29, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.47%, the 40th percentile. Fixed in advancecomp 2.4-r0.

References

Show 19 moreShow less
MoveEnter Open