Every CVE Search/ Get API key

CVE-2022-0436

Path Traversal in gruntjs/grunt

7.1 HighFix available

Path Traversal in GitHub repository gruntjs/grunt prior to 1.5.2.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

0.59%Down 0.3 points since Apr 13, 2022
90%50%10%1%

What each source reports

CVE List Score used 7.1

Path Traversal in gruntjs/grunt

Path Traversal in GitHub repository gruntjs/grunt prior to 1.5.2.

Record
CVE-2022-0436
CVSS 3.0
7.1 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-22
Updated
2026-11-02
EUVDEUVD-2022-1767 7.1

Path Traversal in GitHub repository gruntjs/grunt prior to 1.5.2.

Record
EUVD-2022-1767
CVSS 3.0
7.1 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-j383-35pm-c5h4 5.5

Path Traversal in Grunt

Grunt prior to version 1.5.2 is vulnerable to path traversal.

Record
GHSA-j383-35pm-c5h4
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
NVD 5.5

Path Traversal in GitHub repository gruntjs/grunt prior to 1.5.2.

Record
CVE-2022-0436
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 3.0
7.1 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
OSVAZL-45141 5.5

CVE-2022-0436 affecting package js-jquery 3.5.0-4

Path Traversal in GitHub repository gruntjs/grunt prior to 1.5.2.

Record
AZL-45141
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-05
OSV 7.1

Path Traversal in gruntjs/grunt

Path Traversal in GitHub repository gruntjs/grunt prior to 1.5.2.

Record
CVE-2022-0436
CVSS 3.0
7.1 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-22
Updated
2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2022-0436 5.5

Path Traversal in GitHub repository gruntjs/grunt prior to 1.5.2.

Record
DEBIAN-CVE-2022-0436
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-03
OSVGHSA-j383-35pm-c5h4 5.5

Path Traversal in Grunt

Grunt prior to version 1.5.2 is vulnerable to path traversal.

Record
GHSA-j383-35pm-c5h4
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
OSVOESA-2022-1638 5.5

nodejs-grunt security update

Grunt is the JavaScript task runner. Why use a task runner? In one word: automation. The less work you have to do when performing repetitive tasks like minification, compilation, unit testing, linting, etc, the easier your job becomes. After you've configured it, a task runner can do most of that mundane work for you with basically zero effort.

Security Fix(es): Path Traversal in GitHub repository gruntjs/grunt prior to 1.5.2.(CVE-2022-0436)

Record
OESA-2022-1638
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2022-0436 5.5

Path Traversal in GitHub repository gruntjs/grunt prior to 1.5.2.

Record
UBUNTU-CVE-2022-0436
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 3.0
7.1 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVUSN-5847-1 No score

grunt vulnerabilities

It was discovered that Grunt was not properly loading YAML files before parsing them. An attacker could possibly use this issue to execute arbitrary code. (CVE-2020-7729)

It was discovered that Grunt was not properly handling symbolic links when performing file copy operations. An attacker could possibly use this issue to expose sensitive information or execute arbitrary code. (CVE-2022-0436)

It was discovered that there was a race condition in the Grunt file copy function, which could lead to an arbitrary file write. An attacker could possibly use this issue to perform a local privilege escalation attack or to execute arbitrary code. (CVE-2022-1537)

Record
USN-5847-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
grunt
npm
before 1.5.2
1.5.2
js-jquery
Azure Linux:3
through 3.5.0-4 None known
grunt
Debian:12
before 1.5.2-2
1.5.2-2
grunt
Debian:13
before 1.5.2-2
1.5.2-2
grunt
Debian:14
before 1.5.2-2
1.5.2-2
grunt
Debian:10
before 1.0.1-8+deb10u3, plus listed versions
1.0.1-81.0.1-8+deb10u11.0.1-8+deb10u2
1.0.1-8+deb10u3
nodejs-grunt
openEuler:20.03-LTS-SP1
before 1.0.1-3.oe1
1.0.1-3.oe1
nodejs-grunt
openEuler:20.03-LTS-SP3
before 1.0.1-3.oe1
1.0.1-3.oe1
nodejs-grunt
openEuler:22.03-LTS
before 1.0.1-4.oe2203
1.0.1-4.oe2203
grunt
Ubuntu:Pro:18.04:LTS
before 1.0.1-8ubuntu0.1+esm1, plus listed versions
1.0.1-51.0.1-61.0.1-71.0.1-81.0.1-8ubuntu0.1
1.0.1-8ubuntu0.1+esm1
Show 5 moreShow less
Affected packages
PackageAffectedFixed
grunt
Ubuntu:Pro:20.04:LTS
before 1.0.4-2ubuntu0.1~esm1, plus listed versions
1.0.1-91.0.4-2
1.0.4-2ubuntu0.1~esm1
grunt
Ubuntu:Pro:22.04:LTS
before 1.4.1-2ubuntu0.1~esm1, plus listed versions
1.3.0-11.3.0-21.4.1-11.4.1-2
1.4.1-2ubuntu0.1~esm1
grunt
Ubuntu:Pro:18.04:LTS
From an advisory covering 3 CVEs
before 1.0.1-8ubuntu0.1+esm1, plus listed versions
1.0.1-51.0.1-61.0.1-71.0.1-81.0.1-8ubuntu0.1
1.0.1-8ubuntu0.1+esm1
grunt
Ubuntu:Pro:20.04:LTS
From an advisory covering 3 CVEs
before 1.0.4-2ubuntu0.1~esm1, plus listed versions
1.0.1-91.0.4-2
1.0.4-2ubuntu0.1~esm1
grunt
Ubuntu:Pro:22.04:LTS
From an advisory covering 3 CVEs
before 1.4.1-2ubuntu0.1~esm1, plus listed versions
1.3.0-11.3.0-21.4.1-11.4.1-2
1.4.1-2ubuntu0.1~esm1

History

History
RecordedChangedSources
affected
factsOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-0436 is a high vulnerability (CVSS 7.1) in Gruntjs Grunt, published April 12, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.59%, the 48th percentile. Fixed in grunt 1.5.2.

References

Show 11 moreShow less
MoveEnter Open