CVE-2024-42861
An issue in IEEE 802.1AS linuxptp v.4.2 and before allowing a remote attacker to cause a denial...
An issue in IEEE 802.1AS linuxptp v.4.2 and before allowing a remote attacker to cause a denial of service via a crafted Pdelay_Req message to the time synchronization function
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
An issue in IEEE 802.1AS linuxptp v.4.2 and before allowing a remote attacker to cause a denial of service via a crafted Pdelay_Req message to the time synchronization function
- Record
CVE-2024-42861- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
CVE List
7.5
An issue in IEEE 802.1AS linuxptp v.4.2 and before allowing a remote attacker to cause a denial of service via a crafted Pdelay_Req message to the time synchronization function
- Record
CVE-2024-42861- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
EUVDEUVD-2024-39814
7.5
An issue in IEEE 802.1AS linuxptp v.4.2 and before allowing a remote attacker to cause a denial of service via a crafted Pdelay_Req message to the time synchronization function
- Record
EUVD-2024-39814- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-xgfh-jv6x-46xv
7.5
An issue in IEEE 802.1AS linuxptp v.4.2 and before allowing a remote attacker to cause a denial...
An issue in IEEE 802.1AS linuxptp v.4.2 and before allowing a remote attacker to cause a denial of service via a crafted Pdelay_Req message to the time synchronization function
- Record
GHSA-xgfh-jv6x-46xv- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVAZL-49731
7.5
CVE-2024-42861 affecting package linuxptp for versions less than 3.1.1-1
An issue in IEEE 802.1AS linuxptp v.4.2 and before allowing a remote attacker to cause a denial of service via a crafted Pdelay_Req message to the time synchronization function
- Record
AZL-49731- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVAZL-49740
7.5
CVE-2024-42861 affecting package linuxptp for versions less than 3.1.1-1
An issue in IEEE 802.1AS linuxptp v.4.2 and before allowing a remote attacker to cause a denial of service via a crafted Pdelay_Req message to the time synchronization function
- Record
AZL-49740- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV
7.5
An issue in IEEE 802.1AS linuxptp v.4.2 and before allowing a remote attacker to cause a denial of service via a crafted Pdelay_Req message to the time synchronization function
- Record
CVE-2024-42861- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-42861
7.5
An issue in IEEE 802.1AS linuxptp v.4.2 and before allowing a remote attacker to cause a denial of service via a crafted Pdelay_Req message to the time synchronization function
- Record
DEBIAN-CVE-2024-42861- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-42861
7.5
An issue in IEEE 802.1AS linuxptp v.4.2 and before allowing a remote attacker to cause a denial of service via a crafted Pdelay_Req message to the time synchronization function
- Record
UBUNTU-CVE-2024-42861- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
linuxptpAzure Linux:2 |
before 3.1.1-1 | 3.1.1-1 |
linuxptpAzure Linux:3 |
before 3.1.1-1 | 3.1.1-1 |
linuxptpDebian:12 |
All versions, plus listed versions 3.1.1-44.0-14.2-14.2-24.4-1 |
None known |
linuxptpDebian:13 |
All versions, plus listed versions 4.2-14.2-24.4-1 |
None known |
linuxptpDebian:14 |
All versions, plus listed versions 4.2-14.2-24.4-1 |
None known |
linuxptpUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.5-11.5-21.6-11.6-1ubuntu0.1~esm1 |
None known |
linuxptpUbuntu:18.04:LTS |
All versions, plus listed versions 1.8-11.8-1ubuntu0.1 |
None known |
linuxptpUbuntu:20.04:LTS |
All versions, plus listed versions 1.9.2-11.9.2-1ubuntu0.1 |
None known |
linuxptpUbuntu:22.04:LTS |
All versions, plus listed versions 3.1-2.13.1.1-23.1.1-3 |
None known |
linuxptpUbuntu:24.04:LTS |
All versions, plus listed versions 4.0-14.0-1ubuntu14.0-1ubuntu1.1 |
None known |
linuxptpUbuntu:25.10 |
All versions, plus listed versions 4.2-1ubuntu14.2-1ubuntu2 |
None known |
linuxptpUbuntu:26.10 |
All versions, plus listed versions 4.4-0ubuntu1 |
None known |
linuxptpUbuntu:26.04:LTS |
All versions, plus listed versions 4.2-1ubuntu24.4-0ubuntu1 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | qiupy123/CVE-2024-42861 | 2024-09-21 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-42861 is a high vulnerability (CVSS 7.5) in Linuxptp Project Linuxptp, published September 23, 2024. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.56%, the 75th percentile. Fixed in linuxptp 3.1.1-1.