Every CVE Search/ Get API key

CVE-2025-0633

Heap Overflow in iniparser.c

5.1 MediumFix available

Heap-based Buffer Overflow vulnerability in iniparser_dumpsection_ini() in iniparser allows attacker to read out of bound memory

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

0.23%Up 0.2 points since Feb 20, 2025
90%50%10%1%

What each source reports

CVE List Score used 5.1

Heap Overflow in iniparser.c

Heap-based Buffer Overflow vulnerability in iniparser_dumpsection_ini() in iniparser allows attacker to read out of bound memory

Record
CVE-2025-0633
CVSS 4.0
5.1 MediumCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Weakness
CWE-122
Updated
2026-11-02
EUVDEUVD-2025-4745 5.1

Heap-based Buffer Overflow vulnerability in iniparser_dumpsection_ini() in iniparser allows attacker to read out of bound memory

Record
EUVD-2025-4745
CVSS 4.0
5.1 MediumCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-2599-v2c2-3fp3 5.1

Heap-based Buffer Overflow vulnerability in iniparser_dumpsection_ini() in iniparser allows...

Heap-based Buffer Overflow vulnerability in iniparser_dumpsection_ini() in iniparser allows attacker to read out of bound memory

Record
GHSA-2599-v2c2-3fp3
CVSS 4.0
5.1 MediumCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-122
Updated
2026-11-02
NVD 5.1

Heap-based Buffer Overflow vulnerability in iniparser_dumpsection_ini() in iniparser allows attacker to read out of bound memory

Record
CVE-2025-0633
CVSS 4.0
5.1 MediumCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-122
Updated
2026-11-02
OSV 5.1

Heap Overflow in iniparser.c

Heap-based Buffer Overflow vulnerability in iniparser_dumpsection_ini() in iniparser allows attacker to read out of bound memory

Record
CVE-2025-0633
CVSS 4.0
5.1 MediumCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Weakness
CWE-122
Updated
2026-11-02
OSVDEBIAN-CVE-2025-0633 5.1

Heap-based Buffer Overflow vulnerability in iniparser_dumpsection_ini() in iniparser allows attacker to read out of bound memory

Record
DEBIAN-CVE-2025-0633
CVSS 4.0
5.1 MediumCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02
Show 9 moreShow less
OSVOESA-2025-1277 4.0

iniparser security update

This modules offers parsing of ini files from the C level. See a complete documentation in HTML format, from this directory open the file html/index.html with any HTML-capable browser.

Security Fix(es):

Heap-based Buffer Overflow vulnerability in iniparser_dumpsection_ini() in iniparser allows attacker to read out of bound memory(CVE-2025-0633)

Record
OESA-2025-1277
CVSS 3.1
4.0 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2025-0633 5.1

Heap-based Buffer Overflow vulnerability in iniparser_dumpsection_ini() in iniparser allows attacker to read out of bound memory

Record
UBUNTU-CVE-2025-0633
CVSS 4.0
5.1 MediumCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Updated
2026-11-02
OSVAZL-56943 No score

CVE-2025-0633 affecting package iniparser 4.1-6

Heap-based Buffer Overflow vulnerability in iniparser_dumpsection_ini() in iniparser allows attacker to read out of bound memory

Record
AZL-56943
Updated
2026-11-02
OSVAZL-57019 No score

CVE-2025-0633 affecting package iniparser for versions less than 4.1-8

Heap-based Buffer Overflow vulnerability in iniparser_dumpsection_ini() in iniparser allows attacker to read out of bound memory

Record
AZL-57019
Updated
2026-11-05
OSVMGASA-2025-0077 No score

Updated iniparser packages fix security vulnerability

A heap-based buffer overflow vulnerability in iniparser_dumpsection_ini() in iniparser allows an attacker to read out-of-bounds memory. (CVE-2025-0633)

Record
MGASA-2025-0077
Updated
2026-11-02
OSVopenSUSE-SU-2025:14836-1 No score

libiniparser-devel-4.2.6-1.1 on GA media

These are all security issues fixed in the libiniparser-devel-4.2.6-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:14836-1
Updated
2026-11-02
OSVSUSE-SU-2025:0821-1 No score

Security update for iniparser

This update for iniparser fixes the following issues:

  • CVE-2025-0633: string copy into buffer without previous size validation leads to heap buffer overflow in iniparser_dumpsection_ini() of iniparser (bsc#1237377).
Record
SUSE-SU-2025:0821-1
Updated
2026-11-02
OSVSUSE-SU-2025:0845-1 No score

Security update for iniparser

This update for iniparser fixes the following issues:

  • CVE-2025-0633: string copy into buffer without previous size validation leads to heap buffer overflow in iniparser_dumpsection_ini() of iniparser (bsc#1237377).
Record
SUSE-SU-2025:0845-1
Updated
2026-11-02
OSVUSN-7286-1 No score

iniparser vulnerability

It was discovered that iniParser incorrectly handled certain files. An attacker could possibly use this issue to cause iniParser to crash, resulting in a denial of service.

Record
USN-7286-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
iniparser
Azure Linux:2
through 4.1-6 None known
iniparser
Azure Linux:3
before 4.1-8
4.1-8
iniparser
Debian:12
All versions, plus listed versions
4.1-64.1-74.2-14.2-1~exp14.2.1-1
Show 4 moreShow less
4.2.4-14.2.4-1~exp14.2.5-14.2.6-1
None known
iniparser
Debian:13
before 4.2.6-1
4.2.6-1
iniparser
Debian:14
before 4.2.6-1
4.2.6-1
iniparser
Mageia:9
before 4.1-4.1.mga9
4.1-4.1.mga9
iniparser
openEuler:22.03-LTS-SP3
before 4.1-6.oe2203sp3
4.1-6.oe2203sp3
iniparser
openEuler:22.03-LTS-SP4
before 4.1-6.oe2203sp4
4.1-6.oe2203sp4
iniparser
openEuler:24.03-LTS
before 4.1-6.oe2403sp1
4.1-6.oe2403sp1
iniparser
openEuler:24.03-LTS-SP1
before 4.1-6.oe2403sp1
4.1-6.oe2403sp1
Show 9 moreShow less
Affected packages
PackageAffectedFixed
iniparser
openEuler:20.03-LTS-SP4
before 4.1-5.oe2003sp4
4.1-5.oe2003sp4
iniparser
SUSE:Linux Enterprise Module for Basesystem 15 SP6
before 4.1-150500.4.8.1
4.1-150500.4.8.1
iniparser
openSUSE:Leap 15.6
before 4.1-150500.4.8.1
4.1-150500.4.8.1
iniparser
SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5
before 3.1.0.git20140619_c5beb80a-3.6.1
3.1.0.git20140619_c5beb80a-3.6.1
iniparser
Ubuntu:18.04:LTS
All versions, plus listed versions
4.1-14.1-2
None known
iniparser
Ubuntu:20.04:LTS
All versions, plus listed versions
4.1-4
None known
iniparser
Ubuntu:22.04:LTS
before 4.1-4ubuntu4.2, plus listed versions
4.1-4ubuntu34.1-4ubuntu44.1-4ubuntu4.1
4.1-4ubuntu4.2
iniparser
Ubuntu:24.04:LTS
before 4.1-7ubuntu0.1, plus listed versions
4.1-64.1-74.1-7build1
4.1-7ubuntu0.1
iniparser
openSUSE:Tumbleweed
before 4.2.6-1.1
4.2.6-1.1

History

History
RecordedChangedSources
factsOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-0633 is a medium vulnerability (CVSS 5.1) in Iniparser, published February 19, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.23%, the 13th percentile. Fixed in iniparser 4.1-8.

References

Show 11 moreShow less
MoveEnter Open