Every CVE Search/ Get API key

CVE-2025-29070

A heap buffer overflow vulnerability has been identified in thesmooth2() in cmsgamma.c in lcms2-2...

7.5 HighFix availableDisputed

A heap buffer overflow vulnerability has been identified in thesmooth2() in cmsgamma.c in lcms2-2.16 which allows a remote attacker to cause a denial of service. NOTE: the Supplier disputes this because "this is not exploitable as this function is never called on normal color management, is there only as a helper for low-level programming and investigation."

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.98%Up 0.9 points since Apr 2, 2025
90%50%10%1%

What each source reports

CVE List Score used 7.5

A heap buffer overflow vulnerability has been identified in thesmooth2() in cmsgamma.c in lcms2-2.16 which allows a remote attacker to cause a denial of service. NOTE: the Supplier disputes this because "this is not exploitable as this function is never called on normal color management, is there only as a helper for low-level programming and investigation."

Record
CVE-2025-29070
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-122
Updated
2026-11-02
EUVDEUVD-2025-9489 7.5

A heap buffer overflow vulnerability has been identified in thesmooth2() in cmsgamma.c in lcms2-2.16 which allows a remote attacker to cause a denial of service. NOTE: the Supplier disputes this because "this is not exploitable as this function is never called on normal color management, is there only as a helper for low-level programming and investigation."

Record
EUVD-2025-9489
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-qgv4-vprj-x2fq 7.5

A heap buffer overflow vulnerability has been identified in thesmooth2() in cmsgamma.c in lcms2-2...

A heap buffer overflow vulnerability has been identified in thesmooth2() in cmsgamma.c in lcms2-2.16 which allows a remote attacker to cause a denial of service.

Record
GHSA-qgv4-vprj-x2fq
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-122
Updated
2026-11-02
NVD 7.5

A heap buffer overflow vulnerability has been identified in thesmooth2() in cmsgamma.c in lcms2-2.16 which allows a remote attacker to cause a denial of service. NOTE: the Supplier disputes this because "this is not exploitable as this function is never called on normal color management, is there only as a helper for low-level programming and investigation."

Record
CVE-2025-29070
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-122
Updated
2026-11-02
OSV 7.5

A heap buffer overflow vulnerability has been identified in thesmooth2() in cmsgamma.c in lcms2-2.16 which allows a remote attacker to cause a denial of service. NOTE: the Supplier disputes this because "this is not exploitable as this function is never called on normal color management, is there only as a helper for low-level programming and investigation."

Record
CVE-2025-29070
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2025-29070 7.5

A heap buffer overflow vulnerability has been identified in thesmooth2() in cmsgamma.c in lcms2-2.16 which allows a remote attacker to cause a denial of service. NOTE: the Supplier disputes this because "this is not exploitable as this function is never called on normal color management, is there only as a helper for low-level programming and investigation."

Record
DEBIAN-CVE-2025-29070
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVAZL-59467 No score

CVE-2025-29070 affecting package openjpeg2 2.3.1-12

A heap buffer overflow vulnerability has been identified in thesmooth2() in cmsgamma.c in lcms2-2.16 which allows a remote attacker to cause a denial of service. NOTE: the Supplier disputes this because "this is not exploitable as this function is never called on normal color management, is there only as a helper for low-level programming and investigation."

Record
AZL-59467
Updated
2026-11-02
OSVAZL-61816 No score

CVE-2025-29070 affecting package openjpeg2 2.3.1-12

A heap buffer overflow vulnerability has been identified in thesmooth2() in cmsgamma.c in lcms2-2.16 which allows a remote attacker to cause a denial of service. NOTE: the Supplier disputes this because "this is not exploitable as this function is never called on normal color management, is there only as a helper for low-level programming and investigation."

Record
AZL-61816
Updated
2026-11-05
OSVROOT-OS-DEBIAN-12-CVE-2025-29070 No score

CVE-2025-29070 in lcms2 - Patched by Root

Root has patched CVE-2025-29070 in the lcms2 package for Root:Debian:12. Multiple fixed versions available.

Record
ROOT-OS-DEBIAN-12-CVE-2025-29070
Updated
2026-11-02

Affected packages

Affected packages
PackageAffectedFixed
openjpeg2
Azure Linux:2
through 2.3.1-12 None known
openjpeg2
Azure Linux:3
through 2.3.1-12 None known
lcms2
Debian:12
All versions, plus listed versions
2.14-22.14-2+deb12u12.16-12.16-22.17-12.17-1.12.19.1-1
None known
lcms2
Debian:13
All versions, plus listed versions
2.16-22.16-2+deb13u12.16-2+deb13u22.17-12.17-1.12.19.1-1
None known
lcms2
Debian:14
All versions, plus listed versions
2.16-22.17-12.17-1.12.19.1-1
None known
lcms2
Root:Debian:12
before 2.14-2+deb12u1.aikido.2
2.14-2+deb12u1.aikido.2
rootio-lcms2
Root:Debian:12
before 2.14-2+deb12u1.aikido.2
2.14-2+deb12u1.aikido.2

History

History
RecordedChangedSources
factsOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-29070 is a high vulnerability (CVSS 7.5) in lcms2, published April 1, 2025. Its validity is disputed. EPSS puts the chance of exploitation in the next 30 days at 0.98%, the 62nd percentile. Fixed in lcms2 2.14-2+deb12u1.aikido.2.

References

MoveEnter Open