CVE-2016-1585
AppArmor mount rules grant excessive permissions
CVE-2016-1585 is a low vulnerability (CVSS 3.9) in Apparmor, published April 22, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.03%, the 63rd percentile. Fixed in apparmor 3.1.7-r0.
In all versions of AppArmor mount rules are accidentally widened when compiled.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
3.9
AppArmor mount rules grant excessive permissions
In all versions of AppArmor mount rules are accidentally widened when compiled.
- Record
CVE-2016-1585- CVSS 3.0
- 3.9 Low
CVSS:3.0/AV:L/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
EUVDEUVD-2016-2680
3.9
In all versions of AppArmor mount rules are accidentally widened when compiled.
- Record
EUVD-2016-2680- CVSS 3.0
- 3.9 Low
CVSS:3.0/AV:L/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-gpv3-8hmx-cqqf
9.8
In all versions of AppArmor mount rules are accidentally widened when compiled.
In all versions of AppArmor mount rules are accidentally widened when compiled.
- Record
GHSA-gpv3-8hmx-cqqf- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
NVD
9.8
In all versions of AppArmor mount rules are accidentally widened when compiled.
- Record
CVE-2016-1585- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 3.9 Low
CVSS:3.0/AV:L/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
OSVALPINE-CVE-2016-1585
9.8
In all versions of AppArmor mount rules are accidentally widened when compiled.
- Record
ALPINE-CVE-2016-1585- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVAZL-6306
9.8
CVE-2016-1585 affecting package apparmor for versions less than 2.13-16
In all versions of AppArmor mount rules are accidentally widened when compiled.
- Record
AZL-6306- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 7 moreShow less
OSVBELL-CVE-2016-1585
9.8
- Record
BELL-CVE-2016-1585- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
9.8
In all versions of AppArmor mount rules are accidentally widened when compiled.
- Record
CVE-2016-1585- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-1585
9.8
In all versions of AppArmor mount rules are accidentally widened when compiled.
- Record
DEBIAN-CVE-2016-1585- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-1585
9.8
In all versions of AppArmor mount rules are accidentally widened when compiled.
- Record
UBUNTU-CVE-2016-1585- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 3.9 Low
CVSS:3.0/AV:L/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:12971-1 No score
apache2-mod_apparmor-3.1.4-1.1 on GA media
These are all security issues fixed in the apache2-mod_apparmor-3.1.4-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:12971-1- Updated
- 2026-11-02
OSVROOT-OS-DEBIAN-12-CVE-2016-1585 No score
CVE-2016-1585 in apparmor - Patched by Root
Root has patched CVE-2016-1585 in the apparmor package for Root:Debian:12. Multiple fixed versions available.
- Record
ROOT-OS-DEBIAN-12-CVE-2016-1585- Updated
- 2026-11-02
OSVUSN-7035-1 No score
apparmor vulnerability
It was discovered that the AppArmor policy compiler incorrectly generated looser restrictions than expected for rules allowing mount operations. A local attacker could possibly use this to bypass AppArmor restrictions in applications where some mount operations were permitted.
- Record
USN-7035-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
apparmorAlpine:v3.17 |
3.0.0 up to 3.1.7-r0 | 3.1.7-r0 |
apparmorAzure Linux:2 |
before 2.13-16 | 2.13-16 |
apparmorAlpaquita:23 |
3.1.2-r2 up to 3.1.7-r0 | 3.1.7-r0 |
apparmorAlpaquita:stream |
3.1.3-r0 up to 3.1.6-r0 | 3.1.6-r0 |
apparmorDebian:12 |
All versions, plus listed versions 3.0.12-13.0.13-13.0.13-23.0.8-33.1.7-1 Show 26 moreShow less3.1.7-23.1.7-33.1.7-44.1.0-14.1.0~beta5-14.1.0~beta5-24.1.0~beta5-34.1.0~beta5-44.1.0~beta5-54.1.0~beta5-64.1.3-14.1.6-24.1.6-34.1.7-14.1.7-24.1.7-34.1.7-44.1.7-54.1.7-64.1.8-14.1.8-25.0.1-15.0.2-15.0.2-25.0.2-35.0.2-4 |
None known |
apparmorDebian:13 |
before 3.0.12-1 | 3.0.12-1 |
apparmorDebian:14 |
before 3.0.12-1 | 3.0.12-1 |
apparmorRoot:Debian:12 |
before 3.0.8-3.root.io.1 | 3.0.8-3.root.io.13.0.8-3.aikido.2 |
rootio-apparmorRoot:Debian:12 |
before 3.0.8-3.root.io.1 | 3.0.8-3.root.io.13.0.8-3.aikido.2 |
apparmorUbuntu:14.04:LTS |
All versions, plus listed versions 2.8.0-0ubuntu312.8.0-0ubuntu322.8.0-0ubuntu332.8.0-0ubuntu342.8.0-0ubuntu35 Show 13 moreShow less2.8.0-0ubuntu372.8.0-0ubuntu382.8.95~2430-0ubuntu12.8.95~2430-0ubuntu22.8.95~2430-0ubuntu32.8.95~2430-0ubuntu52.8.95~2430-0ubuntu5.12.8.95~2430-0ubuntu5.22.8.95~2430-0ubuntu5.32.10.95-0ubuntu2.5~14.04.12.10.95-0ubuntu2.6~14.04.12.10.95-0ubuntu2.6~14.04.32.10.95-0ubuntu2.6~14.04.4 |
None known |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
apparmorUbuntu:16.04:LTS |
All versions, plus listed versions 2.10-0ubuntu62.10-0ubuntu72.10-0ubuntu82.10-0ubuntu102.10-0ubuntu11 Show 14 moreShow less2.10-0ubuntu122.10-3ubuntu12.10-3ubuntu22.10.95-0ubuntu12.10.95-0ubuntu22.10.95-0ubuntu2.22.10.95-0ubuntu2.52.10.95-0ubuntu2.62.10.95-0ubuntu2.72.10.95-0ubuntu2.82.10.95-0ubuntu2.92.10.95-0ubuntu2.102.10.95-0ubuntu2.112.10.95-0ubuntu2.12 |
None known |
apparmorUbuntu:18.04:LTS |
All versions, plus listed versions 2.11.0-2ubuntu172.11.0-2ubuntu182.11.0-2ubuntu192.12-4ubuntu12.12-4ubuntu2 Show 5 moreShow less2.12-4ubuntu32.12-4ubuntu42.12-4ubuntu52.12-4ubuntu5.12.12-4ubuntu5.3 |
None known |
apparmorUbuntu:20.04:LTS |
before 2.13.3-7ubuntu5.4, plus listed versions 2.13.3-5ubuntu12.13.3-5ubuntu22.13.3-5ubuntu52.13.3-7ubuntu12.13.3-7ubuntu2 Show 7 moreShow less2.13.3-7ubuntu32.13.3-7ubuntu42.13.3-7ubuntu52.13.3-7ubuntu5.12.13.3-7ubuntu5.22.13.3-7ubuntu5.32.13.3-7ubuntu5.3build2 |
2.13.3-7ubuntu5.4 |
apparmorUbuntu:22.04:LTS |
before 3.0.4-2ubuntu2.4, plus listed versions 3.0.3-0ubuntu13.0.3-0ubuntu23.0.3-0ubuntu33.0.3-0ubuntu43.0.3-0ubuntu5 Show 7 moreShow less3.0.4-1ubuntu13.0.4-2ubuntu13.0.4-2ubuntu23.0.4-2ubuntu2.13.0.4-2ubuntu2.23.0.4-2ubuntu2.33.0.4-2ubuntu2.3build2 |
3.0.4-2ubuntu2.4 |
apparmoropenSUSE:Tumbleweed |
before 3.1.4-1.1 | 3.1.4-1.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases, published | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
bugs.launchpad.net/apparmor/+bug/1597017
lists.apache.org/thread.html/rf9fa47ab66495c78bb4120b0754dd9531ca2ff0430f6685ac9b07772%40%3Cdev.mina.apache.org%3E
nvd.nist.gov/vuln/detail/CVE-2016-1585
lists.apache.org/thread.html/rf9fa47ab66495c78bb4120b0754dd9531ca2ff0430f6685ac9b07772@%3Cdev.mina.apache.org%3E
github.com/advisories/GHSA-gpv3-8hmx-cqqf
security.alpinelinux.org/vuln/CVE-2016-1585
Show 10 moreShow less
docs.bell-sw.com/security/cves/CVE-2016-1585
docs.bell-sw.com/security/advisories/BELL-SA-2024-15
security-tracker.debian.org/tracker/CVE-2016-1585
ubuntu.com/security/CVE-2016-1585
gitlab.com/apparmor/apparmor/-/merge_requests/333
gitlab.com/apparmor/apparmor/-/merge_requests/1048
gitlab.com/apparmor/apparmor/-/merge_requests/1054
cve.org/CVERecord?id=CVE-2016-1585
ubuntu.com/security/notices/USN-7035-1
suse.com/security/cve/CVE-2016-1585