CVE-2012-6687
FastCGI (aka fcgi and libfcgi) 2.4.0 allows remote attackers to cause a denial of service ...
FastCGI (aka fcgi and libfcgi) 2.4.0 allows remote attackers to cause a denial of service (segmentation fault and crash) via a large number of connections.
Exploit likelihood
What each source reports
NVD Score used
5.0
FastCGI (aka fcgi and libfcgi) 2.4.0 allows remote attackers to cause a denial of service (segmentation fault and crash) via a large number of connections.
- Record
CVE-2012-6687- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
FastCGI (aka fcgi and libfcgi) 2.4.0 allows remote attackers to cause a denial of service (segmentation fault and crash) via a large number of connections.
- Record
CVE-2012-6687- Updated
- 2026-11-02
EUVDEUVD-2012-6529 No score
FastCGI (aka fcgi and libfcgi) 2.4.0 allows remote attackers to cause a denial of service (segmentation fault and crash) via a large number of connections.
- Record
EUVD-2012-6529- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-v5rv-9c87-6gww No score
FastCGI (aka fcgi and libfcgi) 2.4.0 allows remote attackers to cause a denial of service ...
FastCGI (aka fcgi and libfcgi) 2.4.0 allows remote attackers to cause a denial of service (segmentation fault and crash) via a large number of connections.
- Record
GHSA-v5rv-9c87-6gww- Weakness
- CWE-20
- Updated
- 2026-11-02
OSVAZL-34685 No score
CVE-2012-6687 affecting package fcgi for versions less than 2.4.0-7
FastCGI (aka fcgi and libfcgi) 2.4.0 allows remote attackers to cause a denial of service (segmentation fault and crash) via a large number of connections.
- Record
AZL-34685- Updated
- 2026-11-02
OSVAZL-6418 No score
CVE-2012-6687 affecting package fcgi for versions less than 2.4.0-7
FastCGI (aka fcgi and libfcgi) 2.4.0 allows remote attackers to cause a denial of service (segmentation fault and crash) via a large number of connections.
- Record
AZL-6418- Updated
- 2026-11-02
Show 6 moreShow less
OSV No score
FastCGI (aka fcgi and libfcgi) 2.4.0 allows remote attackers to cause a denial of service (segmentation fault and crash) via a large number of connections.
- Record
CVE-2012-6687- Updated
- 2026-11-02
OSVDEBIAN-CVE-2012-6687 No score
FastCGI (aka fcgi and libfcgi) 2.4.0 allows remote attackers to cause a denial of service (segmentation fault and crash) via a large number of connections.
- Record
DEBIAN-CVE-2012-6687- Updated
- 2026-11-02
OSVMGASA-2015-0184 No score
Updated fcgi packages fix CVE-2012-6687
Updated fcgi packages fix security vulnerability:
FCGI does not perform range checks for file descriptors before use of the FD_SET macro. This FD_SET macro could allow for more than 1024 total file descriptors to be monitored in the closing state. This may allow remote attackers to cause a denial of service (stack memory corruption, and infinite loop or daemon crash) by opening many socket connections to the host and crashing the service (CVE-2012-6687).
- Record
MGASA-2015-0184- Updated
- 2026-11-02
OSVMGASA-2016-0089 No score
Updated perl-FCGI packages fix CVE-2012-6687
Updated fcgi packages fix security vulnerability:
FCGI does not perform range checks for file descriptors before use of the FD_SET macro. This FD_SET macro could allow for more than 1024 total file descriptors to be monitored in the closing state. This may allow remote attackers to cause a denial of service (stack memory corruption, and infinite loop or daemon crash) by opening many socket connections to the host and crashing the service (CVE-2012-6687).
- Record
MGASA-2016-0089- Updated
- 2026-11-02
OSVOESA-2025-1041 No score
perl-FCGI security update
FastCGI Perl bingdings.
Security Fix(es):
(CVE-2012-6687)
- Record
OESA-2025-1041- Updated
- 2026-11-02
OSVUBUNTU-CVE-2012-6687 No score
FastCGI (aka fcgi and libfcgi) 2.4.0 allows remote attackers to cause a denial of service (segmentation fault and crash) via a large number of connections.
- Record
UBUNTU-CVE-2012-6687- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
fcgiAzure Linux:3 |
before 2.4.0-7 | 2.4.0-7 |
fcgiAzure Linux:2 |
before 2.4.0-7 | 2.4.0-7 |
libfcgiDebian:12 |
before 2.4.0-8.3 | 2.4.0-8.3 |
libfcgiDebian:13 |
before 2.4.0-8.3 | 2.4.0-8.3 |
libfcgiDebian:14 |
before 2.4.0-8.3 | 2.4.0-8.3 |
libfcgi-perlDebian:12 |
before 0.78-2 | 0.78-2 |
libfcgi-perlDebian:13 |
before 0.78-2 | 0.78-2 |
libfcgi-perlDebian:14 |
before 0.78-2 | 0.78-2 |
libfcgiDebian:6.0 |
before 2.4.0-8+deb6u1, plus listed versions 2.4.0-8 |
2.4.0-8+deb6u1 |
libfcgi-perlDebian:6.0 |
before 0.71-1+squeeze1+deb6u1, plus listed versions 0.71-10.71-1+squeeze1 |
0.71-1+squeeze1+deb6u1 |
Show 7 moreShow less
| Package | Affected | Fixed |
|---|---|---|
fcgiMageia:4 |
before 2.4.0-15.1.mga4 | 2.4.0-15.1.mga4 |
perl-FCGIMageia:5 |
before 0.770.0-4.1.mga5 | 0.770.0-4.1.mga5 |
perl-FCGIopenEuler:20.03-LTS-SP4 |
before 0.78-13.oe2003sp4 | 0.78-13.oe2003sp4 |
perl-FCGIopenEuler:24.03-LTS |
before 0.82-3.oe2403sp1 | 0.82-3.oe2403sp1 |
perl-FCGIopenEuler:22.03-LTS-SP4 |
before 0.78-13.oe2203sp4 | 0.78-13.oe2203sp4 |
perl-FCGIopenEuler:24.03-LTS-SP1 |
before 0.82-3.oe2403sp1 | 0.82-3.oe2403sp1 |
perl-FCGIopenEuler:22.03-LTS-SP3 |
before 0.78-13.oe2203sp3 | 0.78-13.oe2203sp3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2012-6687 is a medium vulnerability (CVSS 5.0) in Fastcgi Fcgi, published February 19, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.09%, the 93rd percentile. Fixed in fcgi 2.4.0-7.
References
bugzilla.redhat.com/show_bug.cgi?id=1189958
bugs.launchpad.net/ubuntu/+source/libfcgi/+bug/933417
advisories.mageia.org/MGASA-2015-0184.html
openwall.com/lists/oss-security/2015/02/07/4
exchange.xforce.ibmcloud.com/vulnerabilities/100696
bugs.debian.org/cgi-bin/bugreport.cgi?bug=681591
Show 12 moreShow less
openwall.com/lists/oss-security/2015/02/06/4
nvd.nist.gov/vuln/detail/CVE-2012-6687
github.com/advisories/GHSA-v5rv-9c87-6gww
security-tracker.debian.org/tracker/CVE-2012-6687
bugs.mageia.org/show_bug.cgi?id=15808
lists.fedoraproject.org/pipermail/package-announce/2015-April/156731.html
advisories.mageia.org/MGASA-2016-0089.html
bugs.mageia.org/show_bug.cgi?id=17823
lwn.net/Alerts/677312
openeuler.org/zh/security/security-bulletins/detail?id=openEuler-SA-2025-1041
ubuntu.com/security/CVE-2012-6687
cve.org/CVERecord?id=CVE-2012-6687