CVE-2020-24742
An issue has been fixed in Qt versions 5.14.0 where QPluginLoader attempts to load plugins...
An issue has been fixed in Qt versions 5.14.0 where QPluginLoader attempts to load plugins relative to the working directory, allowing attackers to execute arbitrary code via crafted files.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
An issue has been fixed in Qt versions 5.14.0 where QPluginLoader attempts to load plugins relative to the working directory, allowing attackers to execute arbitrary code via crafted files.
- Record
CVE-2020-24742- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
An issue has been fixed in Qt versions 5.14.0 where QPluginLoader attempts to load plugins relative to the working directory, allowing attackers to execute arbitrary code via crafted files.
- Record
CVE-2020-24742- Updated
- 2026-11-02
EUVDEUVD-2020-17453 No score
An issue has been fixed in Qt versions 5.14.0 where QPluginLoader attempts to load plugins relative to the working directory, allowing attackers to execute arbitrary code via crafted files.
- Record
EUVD-2020-17453- Updated
- 2026-11-02
GitHub AdvisoriesGHSA-r23c-fjj8-522c
7.8
An issue has been fixed in Qt versions 5.14.0 where QPluginLoader attempts to load plugins...
An issue has been fixed in Qt versions 5.14.0 where QPluginLoader attempts to load plugins relative to the working directory, allowing attackers to execute arbitrary code via crafted files.
- Record
GHSA-r23c-fjj8-522c- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVAZL-6837
7.8
CVE-2020-24742 affecting package qt5-qtsvg for versions less than 5.12.11-3
An issue has been fixed in Qt versions 5.14.0 where QPluginLoader attempts to load plugins relative to the working directory, allowing attackers to execute arbitrary code via crafted files.
- Record
AZL-6837- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
7.8
An issue has been fixed in Qt versions 5.14.0 where QPluginLoader attempts to load plugins relative to the working directory, allowing attackers to execute arbitrary code via crafted files.
- Record
CVE-2020-24742- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-24742
7.8
An issue has been fixed in Qt versions 5.14.0 where QPluginLoader attempts to load plugins relative to the working directory, allowing attackers to execute arbitrary code via crafted files.
- Record
DEBIAN-CVE-2020-24742- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-24742
7.8
An issue has been fixed in Qt versions 5.14.0 where QPluginLoader attempts to load plugins relative to the working directory, allowing attackers to execute arbitrary code via crafted files.
- Record
UBUNTU-CVE-2020-24742- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
qt5-qtsvgAzure Linux:2 |
before 5.12.11-3 | 5.12.11-3 |
qtbase-opensource-srcDebian:12 |
before 5.12.5+dfsg-8 | 5.12.5+dfsg-8 |
qtbase-opensource-srcDebian:13 |
before 5.12.5+dfsg-8 | 5.12.5+dfsg-8 |
qtbase-opensource-srcDebian:14 |
before 5.12.5+dfsg-8 | 5.12.5+dfsg-8 |
qtbase-opensource-src-glesDebian:12 |
before 5.14.2+dfsg-3 | 5.14.2+dfsg-3 |
qtbase-opensource-src-glesDebian:13 |
before 5.14.2+dfsg-3 | 5.14.2+dfsg-3 |
qtbase-opensource-src-glesDebian:14 |
before 5.14.2+dfsg-3 | 5.14.2+dfsg-3 |
qtbase-opensource-srcDebian:9 From an advisory covering 2 CVEs |
before 5.7.1+dfsg-3+deb9u2, plus listed versions 5.7.1+dfsg-35.7.1+dfsg-3+deb9u1 |
5.7.1+dfsg-3+deb9u2 |
qtbase-opensource-srcDebian:10 From an advisory covering 2 CVEs |
before 5.11.3+dfsg1-1+deb10u3, plus listed versions 5.11.3+dfsg1-15.11.3+dfsg1-1+deb10u15.11.3+dfsg1-1+deb10u2 |
5.11.3+dfsg1-1+deb10u3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-24742 is a high vulnerability (CVSS 7.8) in Qt, published February 3, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.17%, the 67th percentile. Fixed in qt5-qtsvg 5.12.11-3.