CVE-2025-6554
Type confusion in V8 in Google Chrome prior to 138.0.7204.96 allowed a remote attacker to perform...
Type confusion in V8 in Google Chrome prior to 138.0.7204.96 allowed a remote attacker to perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
8.1
Type confusion in V8 in Google Chrome prior to 138.0.7204.96 allowed a remote attacker to perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)
- Record
CVE-2025-6554- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-843
- Updated
- 2026-11-02
EUVDEUVD-2025-19675
8.1
Type confusion in V8 in Google Chrome prior to 138.0.7204.96 allowed a remote attacker to perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)
- Record
EUVD-2025-19675- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-mj9c-f5v6-7665
8.1
Type confusion in V8 in Google Chrome prior to 138.0.7204.96 allowed a remote attacker to perform...
Type confusion in V8 in Google Chrome prior to 138.0.7204.96 allowed a remote attacker to perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)
- Record
GHSA-mj9c-f5v6-7665- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-843
- Updated
- 2026-11-02
CISA KEV No score
Google Chromium V8 Type Confusion Vulnerability
Google Chromium V8 contains a type confusion vulnerability that could allow a remote attacker to perform arbitrary read/write via a crafted HTML page. This vulnerability could affect multiple web browsers that utilize Chromium, including, but not limited to, Google Chrome, Microsoft Edge, and Opera.
- Record
CVE-2025-6554- Weakness
- CWE-843
- Updated
- 2026-11-02
NVD
8.1
Type confusion in V8 in Google Chrome prior to 138.0.7204.96 allowed a remote attacker to perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)
- Record
CVE-2025-6554- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-843
- Updated
- 2026-11-02
OSVALPINE-CVE-2025-6554
8.1
Type confusion in V8 in Google Chrome prior to 138.0.7204.96 allowed a remote attacker to perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)
- Record
ALPINE-CVE-2025-6554- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Updated
- 2026-11-03
Show 4 moreShow less
OSV
8.1
Type confusion in V8 in Google Chrome prior to 138.0.7204.96 allowed a remote attacker to perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)
- Record
CVE-2025-6554- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-6554
8.1
Type confusion in V8 in Google Chrome prior to 138.0.7204.96 allowed a remote attacker to perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)
- Record
DEBIAN-CVE-2025-6554- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
OSVAZL-76320 No score
CVE-2025-6554 affecting package nodejs24 24.13.0-3
Type confusion in V8 in Google Chrome prior to 138.0.7204.96 allowed a remote attacker to perform arbitrary read/write via a crafted HTML page. (Chromium security severity: High)
- Record
AZL-76320- Updated
- 2026-11-02
OSVopenSUSE-SU-2025:15210-1 No score
chromedriver-138.0.7204.96-1.1 on GA media
These are all security issues fixed in the chromedriver-138.0.7204.96-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2025:15210-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
qt6-qtwebengineAlpine:v3.22 |
before 6.8.3-r1 | 6.8.3-r1 |
qt6-qtwebengineAlpine:v3.23 |
before 6.9.1-r3 | 6.9.1-r3 |
qt6-qtwebengineAlpine:v3.24 |
before 6.9.1-r3 | 6.9.1-r3 |
nodejs24Azure Linux:3 |
through 24.13.0-3 | None known |
chromiumDebian:12 |
before 138.0.7204.92-1~deb12u1, plus listed versions 113.0.5672.126-1114.0.5735.106-1114.0.5735.106-1~deb11u1114.0.5735.106-1~deb12u1114.0.5735.133-1 Show 45 moreShow less114.0.5735.133-1~deb11u1114.0.5735.133-1~deb12u1114.0.5735.198-1114.0.5735.198-1~deb11u1114.0.5735.198-1~deb12u1114.0.5735.90-1114.0.5735.90-2114.0.5735.90-2~deb11u1114.0.5735.90-2~deb12u1115.0.5790.102-1115.0.5790.102-2115.0.5790.170-1115.0.5790.170-1~deb11u1115.0.5790.170-1~deb12u1115.0.5790.98-1115.0.5790.98-1~deb11u1115.0.5790.98-1~deb12u1115.0.5790.98-2116.0.5845.110-1116.0.5845.110-1~deb11u1116.0.5845.110-1~deb12u1116.0.5845.110-2116.0.5845.140-1116.0.5845.140-1~deb11u1116.0.5845.140-1~deb12u1116.0.5845.180-1116.0.5845.180-1~deb11u1116.0.5845.180-1~deb12u1116.0.5845.96-1116.0.5845.96-1~deb11u1116.0.5845.96-1~deb12u1116.0.5845.96-2117.0.5938.132-1117.0.5938.132-1~deb11u1117.0.5938.132-1~deb12u1117.0.5938.132-2117.0.5938.149-1117.0.5938.149-1~deb11u1117.0.5938.149-1~deb12u1117.0.5938.62-1117.0.5938.62-1~deb11u1117.0.5938.62-1~deb12u1117.0.5938.92-1118.0.5993.117-1118.0.5993.117-1~deb11u1 |
138.0.7204.92-1~deb12u1 |
chromiumDebian:13 |
before 138.0.7204.92-1 | 138.0.7204.92-1 |
chromiumDebian:14 |
before 138.0.7204.92-1 | 138.0.7204.92-1 |
chromiumopenSUSE:Tumbleweed From an advisory covering 18 CVEs |
before 138.0.7204.96-1.1 | 138.0.7204.96-1.1 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | gmh5225/CVE-2025-6554 | 2025-07-05 |
| PoC in GitHub | gmh5225/CVE-2025-6554-2 | 2025-07-05 |
| PoC in GitHub | PwnToday/CVE-2025-6554 | 2025-07-07 |
| PoC in GitHub | ghostn4444/POC-CVE-2025-6554 | 2025-07-09 |
| PoC in GitHub | mistymntncop/CVE-2025-6554 | 2025-10-05 |
| PoC in GitHub | jopraveen/CVE-2025-6554 | 2025-10-14 |
| PoC in GitHub | Muhammednihalmp/Google-chrome-zero-day | 2025-11-09 |
| PoC in GitHub | aklnjakln/CVE-2025-6554 | 2025-11-25 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| exploitation | ||
| affected, aliases, exploits, references | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, CISA KEV, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-6554 is a high vulnerability (CVSS 8.1) in Google Chrome, published June 30, 2025. CISA lists it as known to be exploited, since July 2, 2025. EUVD reports exploitation since July 2, 2025. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 14.1%, the 96th percentile. Fixed in qt6-qtwebengine 6.8.3-r1.
References
chromereleases.googleblog.com/2025/06/stable-channel-update-for-desktop_30.html
issues.chromium.org/issues/427663123
cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-6554
nvd.nist.gov/vuln/detail/CVE-2025-6554
github.com/advisories/GHSA-mj9c-f5v6-7665
security.alpinelinux.org/vuln/CVE-2025-6554
Show 19 moreShow less
security-tracker.debian.org/tracker/CVE-2025-6554
suse.com/security/cve/CVE-2025-5063
suse.com/security/cve/CVE-2025-5064
suse.com/security/cve/CVE-2025-5065
suse.com/security/cve/CVE-2025-5066
suse.com/security/cve/CVE-2025-5067
suse.com/security/cve/CVE-2025-5068
suse.com/security/cve/CVE-2025-5280
suse.com/security/cve/CVE-2025-5281
suse.com/security/cve/CVE-2025-5283
suse.com/security/cve/CVE-2025-5419
suse.com/security/cve/CVE-2025-5958
suse.com/security/cve/CVE-2025-5959
suse.com/security/cve/CVE-2025-6191
suse.com/security/cve/CVE-2025-6192
suse.com/security/cve/CVE-2025-6554
suse.com/security/cve/CVE-2025-6555
suse.com/security/cve/CVE-2025-6556
suse.com/security/cve/CVE-2025-6557
Left out here: 178 versions. The JSON record has them.