CVE-2022-26635
PHP-Memcached v2.2.0 and below contains an improper NULL termination which allows attackers to...
PHP-Memcached v2.2.0 and below contains an improper NULL termination which allows attackers to execute CLRF injection. Note: Third parties have disputed this as not affecting PHP-Memcached directly.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
PHP-Memcached v2.2.0 and below contains an improper NULL termination which allows attackers to execute CLRF injection. Note: Third parties have disputed this as not affecting PHP-Memcached directly.
- Record
CVE-2022-26635- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
PHP-Memcached v2.2.0 and below contains an improper NULL termination which allows attackers to execute CLRF injection. Note: Third parties have disputed this as not affecting PHP-Memcached directly.
- Record
CVE-2022-26635- Updated
- 2026-11-02
EUVDEUVD-2022-31189 No score
PHP-Memcached v2.2.0 and below contains an improper NULL termination which allows attackers to execute CLRF injection. Note: Third parties have disputed this as not affecting PHP-Memcached directly.
- Record
EUVD-2022-31189- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hph6-79wj-qqmw
9.8
PHP-Memcached v2.2.0 and below contains an improper NULL termination which allows attackers to...
PHP-Memcached v2.2.0 and below contains an improper NULL termination which allows attackers to execute CLRF injection.
- Record
GHSA-hph6-79wj-qqmw- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVALPINE-CVE-2022-26635
9.8
PHP-Memcached v2.2.0 and below contains an improper NULL termination which allows attackers to execute CLRF injection. Note: Third parties have disputed this as not affecting PHP-Memcached directly.
- Record
ALPINE-CVE-2022-26635- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVAZL-9342
9.8
CVE-2022-26635 affecting package memcached for versions less than 1.6.22-1
PHP-Memcached v2.2.0 and below contains an improper NULL termination which allows attackers to execute CLRF injection. Note: Third parties have disputed this as not affecting PHP-Memcached directly.
- Record
AZL-9342- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV No score
PHP-Memcached v2.2.0 and below contains an improper NULL termination which allows attackers to execute CLRF injection. Note: Third parties have disputed this as not affecting PHP-Memcached directly.
- Record
CVE-2022-26635- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
memcachedAzure Linux:2 |
before 1.6.22-1 | 1.6.22-1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-26635 is a critical vulnerability (CVSS 9.8) in Php Memcached, published April 5, 2022. Its validity is disputed. EPSS puts the chance of exploitation in the next 30 days at 21.4%, the 97th percentile. Fixed in memcached 1.6.22-1.
References
xhzeem.me/posts/Php5-memcached-Injection-Bypass/read
github.com/php-memcached-dev/php-memcached/issues/519
nvd.nist.gov/vuln/detail/CVE-2022-26635
github.com/advisories/GHSA-hph6-79wj-qqmw
security.alpinelinux.org/vuln/CVE-2022-26635
github.com/CVEProject/cvelistV5/tree/main/cves/2022/26xxx/CVE-2022-26635.json