Every CVE Search/ Get API key

CVE-2006-2289

Buffer overflow in avahi-core in Avahi before 0.6.10 allows local users to execute arbitrary code...

2.1 LowFix available

Buffer overflow in avahi-core in Avahi before 0.6.10 allows local users to execute arbitrary code via unknown vectors.

Exploit likelihood

0.48%Down 1.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.1

Buffer overflow in avahi-core in Avahi before 0.6.10 allows local users to execute arbitrary code via unknown vectors.

Record
CVE-2006-2289
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Buffer overflow in avahi-core in Avahi before 0.6.10 allows local users to execute arbitrary code via unknown vectors.

Record
CVE-2006-2289
Updated
2026-11-02
EUVDEUVD-2006-2290 No score

Buffer overflow in avahi-core in Avahi before 0.6.10 allows local users to execute arbitrary code via unknown vectors.

Record
EUVD-2006-2290
Updated
2026-11-03
GitHub AdvisoriesGHSA-wcpr-m747-77wq No score

Buffer overflow in avahi-core in Avahi before 0.6.10 allows local users to execute arbitrary code...

Buffer overflow in avahi-core in Avahi before 0.6.10 allows local users to execute arbitrary code via unknown vectors.

Record
GHSA-wcpr-m747-77wq
Updated
2026-11-02
OSVBELL-CVE-2006-2289 2.1

CVE-2006-2289 does not affect BellSoft software

Record
BELL-CVE-2006-2289
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:P/A:N
Updated
2026-11-02
OSV No score

Buffer overflow in avahi-core in Avahi before 0.6.10 allows local users to execute arbitrary code via unknown vectors.

Record
CVE-2006-2289
Updated
2026-11-02
OSVDEBIAN-CVE-2006-2289 No score

Buffer overflow in avahi-core in Avahi before 0.6.10 allows local users to execute arbitrary code via unknown vectors.

Record
DEBIAN-CVE-2006-2289
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
avahi
Debian:12
before 0.6.10-1
0.6.10-1
avahi
Debian:13
before 0.6.10-1
0.6.10-1
avahi
Debian:14
before 0.6.10-1
0.6.10-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-2289 is a low vulnerability (CVSS 2.1) in Avahi, published May 9, 2006. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.48%, the 41st percentile. Fixed in avahi 0.6.10-1.

References

Show 5 moreShow less
MoveEnter Open