CVE-2009-5081
The (1) config.guess, (2) contrib/groffer/perl/groffer.pl, and (3) contrib/groffer/perl/roff2.pl...
The (1) config.guess, (2) contrib/groffer/perl/groffer.pl, and (3) contrib/groffer/perl/roff2.pl scripts in GNU troff (aka groff) 1.21 and earlier use an insufficient number of X characters in the template argument to the tempfile function, which makes it easier for local users to overwrite arbitrary files via a symlink attack on a temporary file, a different vulnerability than CVE-2004-0969.
Exploit likelihood
What each source reports
NVD Score used
3.3
The (1) config.guess, (2) contrib/groffer/perl/groffer.pl, and (3) contrib/groffer/perl/roff2.pl scripts in GNU troff (aka groff) 1.21 and earlier use an insufficient number of X characters in the template argument to the tempfile function, which makes it easier for local users to overwrite arbitrary files via a symlink attack on a temporary file, a different vulnerability than CVE-2004-0969.
- Record
CVE-2009-5081- CVSS 2.0
- 3.3 Low
AV:L/AC:M/Au:N/C:N/I:P/A:P - Weakness
- CWE-59
- Updated
- 2026-11-02
CVE List No score
The (1) config.guess, (2) contrib/groffer/perl/groffer.pl, and (3) contrib/groffer/perl/roff2.pl scripts in GNU troff (aka groff) 1.21 and earlier use an insufficient number of X characters in the template argument to the tempfile function, which makes it easier for local users to overwrite arbitrary files via a symlink attack on a temporary file, a different vulnerability than CVE-2004-0969.
- Record
CVE-2009-5081- Updated
- 2026-11-02
EUVDEUVD-2009-5036 No score
The (1) config.guess, (2) contrib/groffer/perl/groffer.pl, and (3) contrib/groffer/perl/roff2.pl scripts in GNU troff (aka groff) 1.21 and earlier use an insufficient number of X characters in the template argument to the tempfile function, which makes it easier for local users to overwrite arbitrary files via a symlink attack on a temporary file, a different vulnerability than CVE-2004-0969.
- Record
EUVD-2009-5036- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8mmw-rg27-gmpp No score
The (1) config.guess, (2) contrib/groffer/perl/groffer.pl, and (3) contrib/groffer/perl/roff2.pl...
The (1) config.guess, (2) contrib/groffer/perl/groffer.pl, and (3) contrib/groffer/perl/roff2.pl scripts in GNU troff (aka groff) 1.21 and earlier use an insufficient number of X characters in the template argument to the tempfile function, which makes it easier for local users to overwrite arbitrary files via a symlink attack on a temporary file, a different vulnerability than CVE-2004-0969.
- Record
GHSA-8mmw-rg27-gmpp- Weakness
- CWE-59
- Updated
- 2026-11-02
OSVBELL-CVE-2009-5081
3.3
CVE-2009-5081 does not affect BellSoft software
- Record
BELL-CVE-2009-5081- CVSS 2.0
- 3.3 Low
AV:L/AC:M/Au:N/C:N/I:P/A:P - Updated
- 2026-11-02
OSV No score
The (1) config.guess, (2) contrib/groffer/perl/groffer.pl, and (3) contrib/groffer/perl/roff2.pl scripts in GNU troff (aka groff) 1.21 and earlier use an insufficient number of X characters in the template argument to the tempfile function, which makes it easier for local users to overwrite arbitrary files via a symlink attack on a temporary file, a different vulnerability than CVE-2004-0969.
- Record
CVE-2009-5081- Updated
- 2026-11-02
OSVDEBIAN-CVE-2009-5081 No score
The (1) config.guess, (2) contrib/groffer/perl/groffer.pl, and (3) contrib/groffer/perl/roff2.pl scripts in GNU troff (aka groff) 1.21 and earlier use an insufficient number of X characters in the template argument to the tempfile function, which makes it easier for local users to overwrite arbitrary files via a symlink attack on a temporary file, a different vulnerability than CVE-2004-0969.
- Record
DEBIAN-CVE-2009-5081- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10031-1 No score
groff-1.22.3-2.5 on GA media
These are all security issues fixed in the groff-1.22.3-2.5 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10031-1- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-5081 is a low vulnerability (CVSS 3.3) in Gnu Groff, published June 30, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.29%, the 22nd percentile. Fixed in groff 1.20.1-5.
References
openwall.com/lists/oss-security/2009/08/14/4
openwall.com/lists/oss-security/2009/08/14/5
cvsweb.openwall.com/cgi/cvsweb.cgi/Owl/packages/groff/groff-1.20.1-owl-tmp.diff.diff?r1=1.1%3Br2=1.2%3Bf=h
cvsweb.openwall.com/cgi/cvsweb.cgi/Owl/packages/groff/groff-1.20.1-owl-tmp.diff
mandriva.com/security/advisories?name=MDVSA-2013:086
nvd.nist.gov/vuln/detail/CVE-2009-5081
Show 7 moreShow less
cvsweb.openwall.com/cgi/cvsweb.cgi/Owl/packages/groff/groff-1.20.1-owl-tmp.diff.diff?r1=1.1;r2=1.2;f=h
github.com/advisories/GHSA-8mmw-rg27-gmpp
docs.bell-sw.com/security/cves/CVE-2009-5081
security-tracker.debian.org/tracker/CVE-2009-5081
suse.com/security/cve/CVE-2009-5044
suse.com/security/cve/CVE-2009-5080
suse.com/security/cve/CVE-2009-5081