Every CVE Search/ Get API key

CVE-2011-3149

The _expand_arg function in the pam_env module (modules/pam_env/pam_env.c) in Linux-PAM (aka pam)...

2.1 LowFix available

CVE-2011-3149 is a low vulnerability (CVSS 2.1) in Linux-pam, published October 24, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.53%, the 45th percentile. Fixed in pam 1.1.3-5.

The _expand_arg function in the pam_env module (modules/pam_env/pam_env.c) in Linux-PAM (aka pam) before 1.1.5 does not properly handle when environment variable expansion can overflow, which allows local users to cause a denial of service (CPU consumption).

Exploit likelihood

0.53%Down 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.1

The _expand_arg function in the pam_env module (modules/pam_env/pam_env.c) in Linux-PAM (aka pam) before 1.1.5 does not properly handle when environment variable expansion can overflow, which allows local users to cause a denial of service (CPU consumption).

Record
CVE-2011-3149
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

The _expand_arg function in the pam_env module (modules/pam_env/pam_env.c) in Linux-PAM (aka pam) before 1.1.5 does not properly handle when environment variable expansion can overflow, which allows local users to cause a denial of service (CPU consumption).

Record
CVE-2011-3149
Updated
2026-11-02
EUVDEUVD-2011-3116 No score

The _expand_arg function in the pam_env module (modules/pam_env/pam_env.c) in Linux-PAM (aka pam) before 1.1.5 does not properly handle when environment variable expansion can overflow, which allows local users to cause a denial of service (CPU consumption).

Record
EUVD-2011-3116
Updated
2026-11-03
GitHub AdvisoriesGHSA-5wc7-486v-w943 No score

The _expand_arg function in the pam_env module (modules/pam_env/pam_env.c) in Linux-PAM (aka pam)...

The _expand_arg function in the pam_env module (modules/pam_env/pam_env.c) in Linux-PAM (aka pam) before 1.1.5 does not properly handle when environment variable expansion can overflow, which allows local users to cause a denial of service (CPU consumption).

Record
GHSA-5wc7-486v-w943
Weakness
CWE-119
Updated
2026-11-02
OSVBELL-CVE-2011-3149 2.1

CVE-2011-3149 does not affect BellSoft software

Record
BELL-CVE-2011-3149
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
OSV No score

The _expand_arg function in the pam_env module (modules/pam_env/pam_env.c) in Linux-PAM (aka pam) before 1.1.5 does not properly handle when environment variable expansion can overflow, which allows local users to cause a denial of service (CPU consumption).

Record
CVE-2011-3149
Updated
2026-11-02
OSVDEBIAN-CVE-2011-3149 No score

The _expand_arg function in the pam_env module (modules/pam_env/pam_env.c) in Linux-PAM (aka pam) before 1.1.5 does not properly handle when environment variable expansion can overflow, which allows local users to cause a denial of service (CPU consumption).

Record
DEBIAN-CVE-2011-3149
Updated
2026-11-02
OSVopenSUSE-SU-2024:10405-1 No score

pam-1.3.0-3.4 on GA media

These are all security issues fixed in the pam-1.3.0-3.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10405-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pam
Debian:12
before 1.1.3-5
1.1.3-5
pam
Debian:13
before 1.1.3-5
1.1.3-5
pam
Debian:14
before 1.1.3-5
1.1.3-5
pam
Debian:6.0
before 1.1.1-6.1+squeeze1, plus listed versions
1.1.1-6.1
1.1.1-6.1+squeeze1
pam
Red Hat:enterprise_linux:6::client
before 0:1.1.1-13.el6
0:1.1.1-13.el6
pam-debuginfo
Red Hat:enterprise_linux:6::client
before 0:1.1.1-13.el6
0:1.1.1-13.el6
pam-devel
Red Hat:enterprise_linux:6::client
before 0:1.1.1-13.el6
0:1.1.1-13.el6
pam
Red Hat:enterprise_linux:6::computenode
before 0:1.1.1-13.el6
0:1.1.1-13.el6
pam-debuginfo
Red Hat:enterprise_linux:6::computenode
before 0:1.1.1-13.el6
0:1.1.1-13.el6
pam-devel
Red Hat:enterprise_linux:6::computenode
before 0:1.1.1-13.el6
0:1.1.1-13.el6
Show 7 moreShow less
Affected packages
PackageAffectedFixed
pam
Red Hat:enterprise_linux:6::server
before 0:1.1.1-13.el6
0:1.1.1-13.el6
pam-debuginfo
Red Hat:enterprise_linux:6::server
before 0:1.1.1-13.el6
0:1.1.1-13.el6
pam-devel
Red Hat:enterprise_linux:6::server
before 0:1.1.1-13.el6
0:1.1.1-13.el6
pam
Red Hat:enterprise_linux:6::workstation
before 0:1.1.1-13.el6
0:1.1.1-13.el6
pam-debuginfo
Red Hat:enterprise_linux:6::workstation
before 0:1.1.1-13.el6
0:1.1.1-13.el6
pam-devel
Red Hat:enterprise_linux:6::workstation
before 0:1.1.1-13.el6
0:1.1.1-13.el6
pam
openSUSE:Tumbleweed
before 1.3.0-3.4
1.3.0-3.4

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 30 moreShow less
MoveEnter Open