Every CVE Search/ Get API key

CVE-2014-9426

** DISPUTED ** The apprentice_load function in libmagic/apprentice.c in the Fileinfo component in...

7.5 HighDisputed

The apprentice_load function in libmagic/apprentice.c in the Fileinfo component in PHP through 5.6.4 attempts to perform a free operation on a stack-based character array, which allows remote attackers to cause a denial of service (memory corruption or application crash) or possibly have unspecified other impact via unknown vectors. NOTE: this is disputed by the vendor because the standard erealloc behavior makes the free operation unreachable

Exploit likelihood

2.14%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

CVE List 7.3

The apprentice_load function in libmagic/apprentice.c in the Fileinfo component in PHP through 5.6.4 attempts to perform a free operation on a stack-based character array, which allows remote attackers to cause a denial of service (memory corruption or application crash) or possibly have unspecified other impact via unknown vectors. NOTE: this is disputed by the vendor because the standard erealloc behavior makes the free operation unreachable

Record
CVE-2014-9426
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
EUVDEUVD-2014-9247 7.3

The apprentice_load function in libmagic/apprentice.c in the Fileinfo component in PHP through 5.6.4 attempts to perform a free operation on a stack-based character array, which allows remote attackers to cause a denial of service (memory corruption or application crash) or possibly have unspecified other impact via unknown vectors. NOTE: this is disputed by the vendor because the standard erealloc behavior makes the free operation unreachable

Record
EUVD-2014-9247
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-hcpv-8j4p-29jp 7.3

** DISPUTED ** The apprentice_load function in libmagic/apprentice.c in the Fileinfo component in...

** DISPUTED ** The apprentice_load function in libmagic/apprentice.c in the Fileinfo component in PHP through 5.6.4 attempts to perform a free operation on a stack-based character array, which allows remote attackers to cause a denial of service (memory corruption or application crash) or possibly have unspecified other impact via unknown vectors. NOTE: this is disputed by the vendor because the standard erealloc behavior makes the free operation unreachable.

Record
GHSA-hcpv-8j4p-29jp
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
NVD 7.3

The apprentice_load function in libmagic/apprentice.c in the Fileinfo component in PHP through 5.6.4 attempts to perform a free operation on a stack-based character array, which allows remote attackers to cause a denial of service (memory corruption or application crash) or possibly have unspecified other impact via unknown vectors. NOTE: this is disputed by the vendor because the standard erealloc behavior makes the free operation unreachable

Record
CVE-2014-9426
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-17
Updated
2026-11-02
OSVBELL-CVE-2014-9426 7.3

CVE-2014-9426 does not affect BellSoft software

Record
BELL-CVE-2014-9426
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
OSVopenSUSE-SU-2024:10290-1 No score

apache2-mod_php7-7.0.14-1.4 on GA media

These are all security issues fixed in the apache2-mod_php7-7.0.14-1.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10290-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10344-1 No score

apache2-mod_php5-5.6.28-1.1 on GA media

These are all security issues fixed in the apache2-mod_php5-5.6.28-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10344-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11169-1 No score

php8-8.0.11-1.1 on GA media

These are all security issues fixed in the php8-8.0.11-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11169-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php7
openSUSE:Tumbleweed
From an advisory covering 70 CVEs
before 7.0.14-1.4
7.0.14-1.4
php5
openSUSE:Tumbleweed
From an advisory covering 71 CVEs
before 5.6.28-1.1
5.6.28-1.1
php8
openSUSE:Tumbleweed
From an advisory covering 97 CVEs
before 8.0.11-1.1
8.0.11-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-9426 is a high vulnerability (CVSS 7.5) in Php, published December 31, 2014. Its validity is disputed. EPSS puts the chance of exploitation in the next 30 days at 2.14%, the 82nd percentile.

References

Show 118 moreShow less
MoveEnter Open