Every CVE Search/ Get API key

CVE-2016-4979

The Apache HTTP Server 2.4.18 through 2.4.20, when mod_http2 and mod_ssl are enabled, does not...

7.5 HighFix available

The Apache HTTP Server 2.4.18 through 2.4.20, when mod_http2 and mod_ssl are enabled, does not properly recognize the "SSLVerifyClient require" directive for HTTP/2 request authorization, which allows remote attackers to bypass intended access restrictions by leveraging the ability to send multiple requests over a single connection and aborting a renegotiation.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

18.8%Up 11.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The Apache HTTP Server 2.4.18 through 2.4.20, when mod_http2 and mod_ssl are enabled, does not properly recognize the "SSLVerifyClient require" directive for HTTP/2 request authorization, which allows remote attackers to bypass intended access restrictions by leveraging the ability to send multiple requests over a single connection and aborting a renegotiation.

Record
CVE-2016-4979
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-284
Updated
2026-11-02
CVE List No score

The Apache HTTP Server 2.4.18 through 2.4.20, when mod_http2 and mod_ssl are enabled, does not properly recognize the "SSLVerifyClient require" directive for HTTP/2 request authorization, which allows remote attackers to bypass intended access restrictions by leveraging the ability to send multiple requests over a single connection and aborting a renegotiation.

Record
CVE-2016-4979
Updated
2026-11-02
EUVDEUVD-2016-5947 No score

The Apache HTTP Server 2.4.18 through 2.4.20, when mod_http2 and mod_ssl are enabled, does not properly recognize the "SSLVerifyClient require" directive for HTTP/2 request authorization, which allows remote attackers to bypass intended access restrictions by leveraging the ability to send multiple requests over a single connection and aborting a renegotiation.

Record
EUVD-2016-5947
Updated
2026-11-03
GitHub AdvisoriesGHSA-r48c-7gpg-9q4x 7.5

The Apache HTTP Server 2.4.18 through 2.4.20, when mod_http2 and mod_ssl are enabled, does not...

The Apache HTTP Server 2.4.18 through 2.4.20, when mod_http2 and mod_ssl are enabled, does not properly recognize the "SSLVerifyClient require" directive for HTTP/2 request authorization, which allows remote attackers to bypass intended access restrictions by leveraging the ability to send multiple requests over a single connection and aborting a renegotiation.

Record
GHSA-r48c-7gpg-9q4x
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-284
Updated
2026-11-02
OSVBELL-CVE-2016-4979 7.5

CVE-2016-4979 does not affect BellSoft software

Record
BELL-CVE-2016-4979
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSV 7.5

The Apache HTTP Server 2.4.18 through 2.4.20, when mod_http2 and mod_ssl are enabled, does not properly recognize the "SSLVerifyClient require" directive for HTTP/2 request authorization, which allows remote attackers to bypass intended access restrictions by leveraging the ability to send multiple requests over a single connection and aborting a renegotiation.

Record
CVE-2016-4979
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2016-4979 7.5

The Apache HTTP Server 2.4.18 through 2.4.20, when mod_http2 and mod_ssl are enabled, does not properly recognize the "SSLVerifyClient require" directive for HTTP/2 request authorization, which allows remote attackers to bypass intended access restrictions by leveraging the ability to send multiple requests over a single connection and aborting a renegotiation.

Record
DEBIAN-CVE-2016-4979
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVRHSA-2016:1420 9.1

Red Hat Security Advisory: httpd24-httpd security update

Record
RHSA-2016:1420
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVopenSUSE-SU-2024:10268-1 No score

apache2-2.4.23-4.1 on GA media

These are all security issues fixed in the apache2-2.4.23-4.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10268-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apache2
Debian:12
before 2.4.23-1
2.4.23-1
apache2
Debian:13
before 2.4.23-1
2.4.23-1
apache2
Debian:14
before 2.4.23-1
2.4.23-1
httpd24-httpd
Red Hat:rhel_software_collections:2::el6
From an advisory covering 2 CVEs
before 0:2.4.18-11.el6
0:2.4.18-11.el6
httpd24-httpd-debuginfo
Red Hat:rhel_software_collections:2::el6
From an advisory covering 2 CVEs
before 0:2.4.18-11.el6
0:2.4.18-11.el6
httpd24-httpd-devel
Red Hat:rhel_software_collections:2::el6
From an advisory covering 2 CVEs
before 0:2.4.18-11.el6
0:2.4.18-11.el6
httpd24-httpd-manual
Red Hat:rhel_software_collections:2::el6
From an advisory covering 2 CVEs
before 0:2.4.18-11.el6
0:2.4.18-11.el6
httpd24-httpd-tools
Red Hat:rhel_software_collections:2::el6
From an advisory covering 2 CVEs
before 0:2.4.18-11.el6
0:2.4.18-11.el6
httpd24-mod_ldap
Red Hat:rhel_software_collections:2::el6
From an advisory covering 2 CVEs
before 0:2.4.18-11.el6
0:2.4.18-11.el6
httpd24-mod_proxy_html
Red Hat:rhel_software_collections:2::el6
From an advisory covering 2 CVEs
before 1:2.4.18-11.el6
1:2.4.18-11.el6
Show 12 moreShow less
Affected packages
PackageAffectedFixed
httpd24-mod_session
Red Hat:rhel_software_collections:2::el6
From an advisory covering 2 CVEs
before 0:2.4.18-11.el6
0:2.4.18-11.el6
httpd24-mod_ssl
Red Hat:rhel_software_collections:2::el6
From an advisory covering 2 CVEs
before 1:2.4.18-11.el6
1:2.4.18-11.el6
httpd24-httpd
Red Hat:rhel_software_collections:2::el7
From an advisory covering 2 CVEs
before 0:2.4.18-11.el7
0:2.4.18-11.el7
httpd24-httpd-debuginfo
Red Hat:rhel_software_collections:2::el7
From an advisory covering 2 CVEs
before 0:2.4.18-11.el7
0:2.4.18-11.el7
httpd24-httpd-devel
Red Hat:rhel_software_collections:2::el7
From an advisory covering 2 CVEs
before 0:2.4.18-11.el7
0:2.4.18-11.el7
httpd24-httpd-manual
Red Hat:rhel_software_collections:2::el7
From an advisory covering 2 CVEs
before 0:2.4.18-11.el7
0:2.4.18-11.el7
httpd24-httpd-tools
Red Hat:rhel_software_collections:2::el7
From an advisory covering 2 CVEs
before 0:2.4.18-11.el7
0:2.4.18-11.el7
httpd24-mod_ldap
Red Hat:rhel_software_collections:2::el7
From an advisory covering 2 CVEs
before 0:2.4.18-11.el7
0:2.4.18-11.el7
httpd24-mod_proxy_html
Red Hat:rhel_software_collections:2::el7
From an advisory covering 2 CVEs
before 1:2.4.18-11.el7
1:2.4.18-11.el7
httpd24-mod_session
Red Hat:rhel_software_collections:2::el7
From an advisory covering 2 CVEs
before 0:2.4.18-11.el7
0:2.4.18-11.el7
httpd24-mod_ssl
Red Hat:rhel_software_collections:2::el7
From an advisory covering 2 CVEs
before 1:2.4.18-11.el7
1:2.4.18-11.el7
apache2
openSUSE:Tumbleweed
From an advisory covering 48 CVEs
before 2.4.23-4.1
2.4.23-4.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-4979 is a high vulnerability (CVSS 7.5) in Apache Http Server, published July 6, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 18.8%, the 97th percentile. Fixed in apache2 2.4.23-1.

References

Show 96 moreShow less
MoveEnter Open