Every CVE Search/ Get API key

CVE-2025-0509

Signing Checks Bypass

7.3 HighFix available

A security issue was found in Sparkle before version 2.6.4. An attacker can replace an existing signed update with another payload, bypassing Sparkle’s (Ed)DSA signing checks.

Attack profile

How easy it is to exploit

Attack vector
Adjacent network
Complexity
High
Privileges needed
High
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.90%Up 0.9 points since Feb 5, 2025
90%50%10%1%

What each source reports

CVE List Score used 7.3

Signing Checks Bypass

A security issue was found in Sparkle before version 2.6.4. An attacker can replace an existing signed update with another payload, bypassing Sparkle’s (Ed)DSA signing checks.

Record
CVE-2025-0509
CVSS 3.1
7.3 HighCVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-552
Updated
2026-11-02
EUVDEUVD-2025-0232 7.3

A security issue was found in Sparkle before version 2.6.4. An attacker can replace an existing signed update with another payload, bypassing Sparkle’s (Ed)DSA signing checks.

Record
EUVD-2025-0232
CVSS 3.1
7.3 HighCVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-wc9m-r3v6-9p5h 7.3

Sparkle Signing Checks Bypass

A security issue was found in Sparkle before version 2.6.4. An attacker can replace an existing signed update with another payload, bypassing Sparkle’s (Ed)DSA signing checks.

Record
GHSA-wc9m-r3v6-9p5h
CVSS 3.1
7.3 HighCVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-552
Updated
2026-11-02
NVD 7.3

A security issue was found in Sparkle before version 2.6.4. An attacker can replace an existing signed update with another payload, bypassing Sparkle’s (Ed)DSA signing checks.

Record
CVE-2025-0509
CVSS 3.1
7.3 HighCVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
CVSS 3.1
6.8 MediumCVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-552
Updated
2026-11-02
OSV 7.3

Signing Checks Bypass

A security issue was found in Sparkle before version 2.6.4. An attacker can replace an existing signed update with another payload, bypassing Sparkle’s (Ed)DSA signing checks.

Record
CVE-2025-0509
CVSS 3.1
7.3 HighCVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-552
Updated
2026-11-02
OSVGHSA-wc9m-r3v6-9p5h 7.3

Sparkle Signing Checks Bypass

A security issue was found in Sparkle before version 2.6.4. An attacker can replace an existing signed update with another payload, bypassing Sparkle’s (Ed)DSA signing checks.

Record
GHSA-wc9m-r3v6-9p5h
CVSS 3.1
7.3 HighCVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-552
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2025-0509 7.3

A security issue was found in Sparkle before version 2.6.4. An attacker can replace an existing signed update with another payload, bypassing Sparkle’s (Ed)DSA signing checks.

Record
UBUNTU-CVE-2025-0509
CVSS 3.1
7.3 HighCVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
CVSS 3.1
6.8 MediumCVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBIT-java-2025-0509 No score

Signing Checks Bypass

A security issue was found in Sparkle before version 2.6.4. An attacker can replace an existing signed update with another payload, bypassing Sparkle’s (Ed)DSA signing checks.

Record
BIT-java-2025-0509
Updated
2026-11-02
OSVBIT-java-min-2025-0509 No score

Signing Checks Bypass

A security issue was found in Sparkle before version 2.6.4. An attacker can replace an existing signed update with another payload, bypassing Sparkle’s (Ed)DSA signing checks.

Record
BIT-java-min-2025-0509
Updated
2026-11-02
OSVBIT-jre-2025-0509 No score

Signing Checks Bypass

A security issue was found in Sparkle before version 2.6.4. An attacker can replace an existing signed update with another payload, bypassing Sparkle’s (Ed)DSA signing checks.

Record
BIT-jre-2025-0509
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/sparkle-project/Sparkle
SwiftURL
through 2.6.3
2.6.4
java
Bitnami
before 1.8.0, 1.9.0 up to 8.0.441
1.8.08.0.441
java-min
Bitnami
before 1.8.0, 1.9.0 up to 8.0.441
1.8.08.0.441
jre
Bitnami
before 1.8.0, 1.9.0 up to 8.0.441
1.8.08.0.441
github.com/sparkle-project/Sparkle
SwiftURL
before 2.6.4
2.6.4
openjdk-9
Ubuntu:16.04:LTS
All versions, plus listed versions
9~b88-19~b101-2ubuntu29~b102-19~b113-0ubuntu19~b114-0ubuntu1
None known
openjdk-13
Ubuntu:20.04:LTS
All versions, plus listed versions
13+33-113.0.1+9-213.0.2+8-113.0.2+8-213.0.3+3-1ubuntu213.0.4+8-1~20.0413.0.7+5-0ubuntu1~20.04
None known
openjdk-16
Ubuntu:20.04:LTS
All versions, plus listed versions
16.0.1+9-1~20.04
None known
openjdk-18
Ubuntu:22.04:LTS
All versions, plus listed versions
18~15ea-418~20ea-118~32ea-118~36ea-118.0.2+9-2~22.04
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-0509 is a high vulnerability (CVSS 7.3) in Sparkle Project Sparkle, published February 4, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.90%, the 59th percentile. Fixed in github.com/sparkle-project/Sparkle 2.6.4.

References

MoveEnter Open