Every CVE Search/ Get API key

CVE-2023-32558

The use of the deprecated API `process.binding()` can bypass the permission model through path...

7.5 HighFix available

The use of the deprecated API process.binding() can bypass the permission model through path traversal.

This vulnerability affects all users using the experimental permission model in Node.js 20.x.

Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.74%Up 1.7 points since Sep 12, 2023
90%50%10%1%

What each source reports

NVD Score used 7.5

The use of the deprecated API process.binding() can bypass the permission model through path traversal.

This vulnerability affects all users using the experimental permission model in Node.js 20.x.

Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

Record
CVE-2023-32558
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-22
Updated
2026-11-03
CVE List No score

The use of the deprecated API process.binding() can bypass the permission model through path traversal.

This vulnerability affects all users using the experimental permission model in Node.js 20.x.

Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

Record
CVE-2023-32558
Updated
2026-11-03
EUVDEUVD-2023-36802 No score

The use of the deprecated API process.binding() can bypass the permission model through path traversal.

This vulnerability affects all users using the experimental permission model in Node.js 20.x.

Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

Record
EUVD-2023-36802
Updated
2026-11-03
GitHub AdvisoriesGHSA-h9p4-9jqg-j34h 7.5

The use of the deprecated API `process.binding()` can bypass the permission model through path...

The use of the deprecated API process.binding() can bypass the permission model through path traversal.

This vulnerability affects all users using the experimental permission model in Node.js 20.x.

Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

Record
GHSA-h9p4-9jqg-j34h
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-22
Updated
2026-11-03
OSVBIT-node-2023-32558 No score

The use of the deprecated API process.binding() can bypass the permission model through path traversal.

This vulnerability affects all users using the experimental permission model in Node.js 20.x.

Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

Record
BIT-node-2023-32558
Updated
2026-11-02
OSVBIT-node-min-2023-32558 No score

The use of the deprecated API process.binding() can bypass the permission model through path traversal.

This vulnerability affects all users using the experimental permission model in Node.js 20.x.

Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

Record
BIT-node-min-2023-32558
Updated
2026-11-02
OSV No score

The use of the deprecated API process.binding() can bypass the permission model through path traversal.

This vulnerability affects all users using the experimental permission model in Node.js 20.x.

Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

Record
CVE-2023-32558
Updated
2026-11-04
OSVopenSUSE-SU-2024:13117-1 No score

corepack20-20.5.1-1.1 on GA media

These are all security issues fixed in the corepack20-20.5.1-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:13117-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
node
Bitnami
20.0.0 up to 20.5.1
20.5.1
node-min
Bitnami
20.0.0 up to 20.5.1
20.5.1
nodejs20
openSUSE:Tumbleweed
From an advisory covering 7 CVEs
before 20.5.1-1.1
20.5.1-1.1

History

History
RecordedChangedSources
affectedOSV
factsGitHub Advisories, NVD, OSV
productsEUVD
referencesCVE List, GitHub Advisories
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-32558 is a high vulnerability (CVSS 7.5) in Nodejs Node, published September 12, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.74%, the 77th percentile. Fixed in node 20.5.1.

References

Show 6 moreShow less
MoveEnter Open