CVE-2002-0659
The ASN1 library in OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, allows remote...
The ASN1 library in OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, allows remote attackers to cause a denial of service via invalid encodings.
Exploit likelihood
What each source reports
NVD Score used
5.0
The ASN1 library in OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, allows remote attackers to cause a denial of service via invalid encodings.
- Record
CVE-2002-0659- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Updated
- 2026-11-02
CVE List No score
The ASN1 library in OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, allows remote attackers to cause a denial of service via invalid encodings.
- Record
CVE-2002-0659- Updated
- 2026-11-02
EUVDEUVD-2002-0653 No score
The ASN1 library in OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, allows remote attackers to cause a denial of service via invalid encodings.
- Record
EUVD-2002-0653- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3x2f-268g-8hg7 No score
The ASN1 library in OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, allows remote...
The ASN1 library in OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, allows remote attackers to cause a denial of service via invalid encodings.
- Record
GHSA-3x2f-268g-8hg7- Updated
- 2026-11-02
OSV No score
The ASN1 library in OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, allows remote attackers to cause a denial of service via invalid encodings.
- Record
CVE-2002-0659- Updated
- 2026-11-02
OSVDEBIAN-CVE-2002-0659 No score
The ASN1 library in OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, allows remote attackers to cause a denial of service via invalid encodings.
- Record
DEBIAN-CVE-2002-0659- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
opensslDebian:12 |
before 0.9.6e-1 | 0.9.6e-1 |
opensslDebian:13 |
before 0.9.6e-1 | 0.9.6e-1 |
opensslDebian:14 |
before 0.9.6e-1 | 0.9.6e-1 |
openssl094Debian:3.0 |
before 0.9.4-6.woody.0, plus listed versions 0.9.4-60.9.4-6.potato.3 |
0.9.4-6.woody.0 |
openssl095Debian:3.0 |
before 0.9.5a-6.woody.0 | 0.9.5a-6.woody.0 |
opensslDebian:3.0 |
before 0.9.6c-2.woody.0 | 0.9.6c-2.woody.0 |
openssl094Debian:3.0 |
before 0.9.4-6.woody.1, plus listed versions 0.9.4-60.9.4-6.potato.3 |
0.9.4-6.woody.1 |
openssl095Debian:3.0 |
before 0.9.5a-6.woody.1 | 0.9.5a-6.woody.1 |
opensslDebian:3.0 |
before 0.9.6c-2.woody.1 | 0.9.6c-2.woody.1 |
openssl094Debian:3.0 |
before 0.9.4-6.woody.2, plus listed versions 0.9.4-60.9.4-6.potato.3 |
0.9.4-6.woody.2 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | OpenSSL - ASN.1 Parsing | 2003-10-09 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2002-0659 is a medium vulnerability (CVSS 5.0) in Openssl, published July 30, 2002. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 36.2%, the 98th percentile. Fixed in openssl 0.9.6e-1.