Every CVE Search/ Get API key

CVE-2002-0655

OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, does not properly handle ASCII...

7.5 HighFix available

CVE-2002-0655 is a high vulnerability (CVSS 7.5) in Openssl, published July 30, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 8.17%, the 94th percentile. Fixed in openssl 0.9.6e-1.

OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, does not properly handle ASCII representations of integers on 64 bit platforms, which could allow attackers to cause a denial of service and possibly execute arbitrary code.

Exploit likelihood

8.17%Up 3.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, does not properly handle ASCII representations of integers on 64 bit platforms, which could allow attackers to cause a denial of service and possibly execute arbitrary code.

Record
CVE-2002-0655
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, does not properly handle ASCII representations of integers on 64 bit platforms, which could allow attackers to cause a denial of service and possibly execute arbitrary code.

Record
CVE-2002-0655
Updated
2026-11-02
EUVDEUVD-2002-0649 No score

OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, does not properly handle ASCII representations of integers on 64 bit platforms, which could allow attackers to cause a denial of service and possibly execute arbitrary code.

Record
EUVD-2002-0649
Updated
2026-11-03
GitHub AdvisoriesGHSA-qqh8-wx7x-qgh9 No score

OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, does not properly handle ASCII...

OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, does not properly handle ASCII representations of integers on 64 bit platforms, which could allow attackers to cause a denial of service and possibly execute arbitrary code.

Record
GHSA-qqh8-wx7x-qgh9
Updated
2026-11-02
OSV No score

OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, does not properly handle ASCII representations of integers on 64 bit platforms, which could allow attackers to cause a denial of service and possibly execute arbitrary code.

Record
CVE-2002-0655
Updated
2026-11-02
OSVDEBIAN-CVE-2002-0655 No score

OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, does not properly handle ASCII representations of integers on 64 bit platforms, which could allow attackers to cause a denial of service and possibly execute arbitrary code.

Record
DEBIAN-CVE-2002-0655
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openssl
Debian:12
before 0.9.6e-1
0.9.6e-1
openssl
Debian:13
before 0.9.6e-1
0.9.6e-1
openssl
Debian:14
before 0.9.6e-1
0.9.6e-1
openssl094
Debian:3.0
before 0.9.4-6.woody.0, plus listed versions
0.9.4-60.9.4-6.potato.3
0.9.4-6.woody.0
openssl095
Debian:3.0
before 0.9.5a-6.woody.0
0.9.5a-6.woody.0
openssl
Debian:3.0
before 0.9.6c-2.woody.0
0.9.6c-2.woody.0
openssl094
Debian:3.0
before 0.9.4-6.woody.1, plus listed versions
0.9.4-60.9.4-6.potato.3
0.9.4-6.woody.1
openssl095
Debian:3.0
before 0.9.5a-6.woody.1
0.9.5a-6.woody.1
openssl
Debian:3.0
before 0.9.6c-2.woody.1
0.9.6c-2.woody.1
openssl094
Debian:3.0
before 0.9.4-6.woody.2, plus listed versions
0.9.4-60.9.4-6.potato.3
0.9.4-6.woody.2

History

History
WhenChangedSources
2026-11-03affected
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open