Every CVE Search/ Get API key

CVE-2002-0986

The mail function in PHP 4.x to 4.2.2 does not filter ASCII control characters from its arguments...

5.0 MediumFix available

The mail function in PHP 4.x to 4.2.2 does not filter ASCII control characters from its arguments, which could allow remote attackers to modify mail message content, including mail headers, and possibly use PHP as a "spam proxy."

Exploit likelihood

4.70%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The mail function in PHP 4.x to 4.2.2 does not filter ASCII control characters from its arguments, which could allow remote attackers to modify mail message content, including mail headers, and possibly use PHP as a "spam proxy."

Record
CVE-2002-0986
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

The mail function in PHP 4.x to 4.2.2 does not filter ASCII control characters from its arguments, which could allow remote attackers to modify mail message content, including mail headers, and possibly use PHP as a "spam proxy."

Record
CVE-2002-0986
Updated
2026-11-02
EUVDEUVD-2002-0975 No score

The mail function in PHP 4.x to 4.2.2 does not filter ASCII control characters from its arguments, which could allow remote attackers to modify mail message content, including mail headers, and possibly use PHP as a "spam proxy."

Record
EUVD-2002-0975
Updated
2026-11-03
GitHub AdvisoriesGHSA-xchw-jqmw-jcvc No score

The mail function in PHP 4.x to 4.2.2 does not filter ASCII control characters from its arguments...

The mail function in PHP 4.x to 4.2.2 does not filter ASCII control characters from its arguments, which could allow remote attackers to modify mail message content, including mail headers, and possibly use PHP as a "spam proxy."

Record
GHSA-xchw-jqmw-jcvc
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php3
Debian:3.0
before 3.0.18-23.1woody1
3.0.18-23.1woody1
php4
Debian:3.0
before 4.1.2-5
4.1.2-5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2002-0986 is a medium vulnerability (CVSS 5.0) in Php, published September 18, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.70%, the 91st percentile. Fixed in php3 3.0.18-23.1woody1.

References

Show 12 moreShow less
MoveEnter Open