Every CVE Search/ Get API key

CVE-2002-0985

Argument injection vulnerability in the mail function for PHP 4.x to 4.2.2 may allow attackers to...

7.5 HighFix available

Argument injection vulnerability in the mail function for PHP 4.x to 4.2.2 may allow attackers to bypass safe mode restrictions and modify command line arguments to the MTA (e.g. sendmail) in the 5th argument to mail(), altering MTA behavior and possibly executing commands.

Exploit likelihood

2.95%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Argument injection vulnerability in the mail function for PHP 4.x to 4.2.2 may allow attackers to bypass safe mode restrictions and modify command line arguments to the MTA (e.g. sendmail) in the 5th argument to mail(), altering MTA behavior and possibly executing commands.

Record
CVE-2002-0985
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-88
Updated
2026-11-02
CVE List No score

Argument injection vulnerability in the mail function for PHP 4.x to 4.2.2 may allow attackers to bypass safe mode restrictions and modify command line arguments to the MTA (e.g. sendmail) in the 5th argument to mail(), altering MTA behavior and possibly executing commands.

Record
CVE-2002-0985
Updated
2026-11-02
EUVDEUVD-2002-0974 No score

Argument injection vulnerability in the mail function for PHP 4.x to 4.2.2 may allow attackers to bypass safe mode restrictions and modify command line arguments to the MTA (e.g. sendmail) in the 5th argument to mail(), altering MTA behavior and possibly executing commands.

Record
EUVD-2002-0974
Updated
2026-11-03
GitHub AdvisoriesGHSA-39rv-383r-32wp No score

Argument injection vulnerability in the mail function for PHP 4.x to 4.2.2 may allow attackers to...

Argument injection vulnerability in the mail function for PHP 4.x to 4.2.2 may allow attackers to bypass safe mode restrictions and modify command line arguments to the MTA (e.g. sendmail) in the 5th argument to mail(), altering MTA behavior and possibly executing commands.

Record
GHSA-39rv-383r-32wp
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php3
Debian:3.0
before 3.0.18-23.1woody1
3.0.18-23.1woody1
php4
Debian:3.0
before 4.1.2-5
4.1.2-5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2002-0985 is a high vulnerability (CVSS 7.5) in Php, published September 18, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.95%, the 87th percentile. Fixed in php3 3.0.18-23.1woody1.

References

Show 10 moreShow less
MoveEnter Open