CVE-2002-1394
Apache Tomcat Source Code Disclosure
Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default servlet, allows remote attackers to read source code for server files or bypass certain protections, a variant of CAN-2002-1148.
Exploit likelihood
What each source reports
NVD Score used
7.5
Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default servlet, allows remote attackers to read source code for server files or bypass certain protections, a variant of CAN-2002-1148.
- Record
CVE-2002-1394- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default servlet, allows remote attackers to read source code for server files or bypass certain protections, a variant of CAN-2002-1148.
- Record
CVE-2002-1394- Updated
- 2026-11-02
EUVDEUVD-2022-1681 No score
Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default servlet, allows remote attackers to read source code for server files or bypass certain protections, a variant of CAN-2002-1148.
- Record
EUVD-2022-1681- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8v5p-2cpv-c2x6 No score
Apache Tomcat Source Code Disclosure
Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default servlet, allows remote attackers to read source code for server files or bypass certain protections, a variant of CAN-2002-1148.
- Record
GHSA-8v5p-2cpv-c2x6- Weakness
- CWE-200
- Updated
- 2026-11-02
OSVGHSA-8v5p-2cpv-c2x6 No score
Apache Tomcat Source Code Disclosure
Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default servlet, allows remote attackers to read source code for server files or bypass certain protections, a variant of CAN-2002-1148.
- Record
GHSA-8v5p-2cpv-c2x6- Weakness
- CWE-200
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.tomcat:tomcatMaven |
through 4.0.5 | 4.0.6 |
tomcat4Debian:3.0 |
before 4.0.3-3woody2 | 4.0.3-3woody2 |
org.apache.tomcat:tomcatMaven |
before 4.0.6 | 4.0.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2002-1394 is a high vulnerability (CVSS 7.5) in Apache Tomcat, published January 9, 2003. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.85%, the 93rd percentile. Fixed in org.apache.tomcat:tomcat 4.0.6.
References
marc.info?l=bugtraq&m=103470282514938&w=2
marc.info?l=tomcat-dev&m=103417249325526&w=2
debian.org/security/2003/dsa-225
redhat.com/support/errata/RHSA-2003-075.html
securityfocus.com/bid/6562
issues.apache.org/bugzilla/show_bug.cgi?id=13365
Show 14 moreShow less
redhat.com/support/errata/RHSA-2003-082.html
exchange.xforce.ibmcloud.com/vulnerabilities/10376
lists.apache.org/thread.html/29dc6c2b625789e70a9c4756b5a327e6547273ff8bde7e0327af48c5%40%3Cdev.tomcat.apache.org%3E
lists.apache.org/thread.html/c62b0e3a7bf23342352a5810c640a94b6db69957c5c19db507004d74%40%3Cdev.tomcat.apache.org%3E
lists.apache.org/thread.html/rb71997f506c6cc8b530dd845c084995a9878098846c7b4eacfae8db3%40%3Cdev.tomcat.apache.org%3E
nvd.nist.gov/vuln/detail/CVE-2002-1394
archive.apache.org/dist/tomcat/tomcat-4/archive/v4.0.6/README.html
lists.apache.org/thread.html/29dc6c2b625789e70a9c4756b5a327e6547273ff8bde7e0327af48c5@%3Cdev.tomcat.apache.org%3E
lists.apache.org/thread.html/rb71997f506c6cc8b530dd845c084995a9878098846c7b4eacfae8db3@%3Cdev.tomcat.apache.org%3E
web.archive.org/web/20030412075128/http://rhn.redhat.com/errata/RHSA-2003-075.html
web.archive.org/web/20030705143220/http://www.securityfocus.com/bid/6562
web.archive.org/web/20041024213235/http://rhn.redhat.com/errata/RHSA-2003-082.html
web.archive.org/web/20070430073829/http://www.debian.org/security/2003/dsa-225
github.com/advisories/GHSA-8v5p-2cpv-c2x6