Every CVE Search/ Get API key

CVE-2002-1394

Apache Tomcat Source Code Disclosure

7.5 HighFix available

Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default servlet, allows remote attackers to read source code for server files or bypass certain protections, a variant of CAN-2002-1148.

Exploit likelihood

5.85%Up 2.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default servlet, allows remote attackers to read source code for server files or bypass certain protections, a variant of CAN-2002-1148.

Record
CVE-2002-1394
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default servlet, allows remote attackers to read source code for server files or bypass certain protections, a variant of CAN-2002-1148.

Record
CVE-2002-1394
Updated
2026-11-02
EUVDEUVD-2022-1681 No score

Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default servlet, allows remote attackers to read source code for server files or bypass certain protections, a variant of CAN-2002-1148.

Record
EUVD-2022-1681
Updated
2026-11-03
GitHub AdvisoriesGHSA-8v5p-2cpv-c2x6 No score

Apache Tomcat Source Code Disclosure

Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default servlet, allows remote attackers to read source code for server files or bypass certain protections, a variant of CAN-2002-1148.

Record
GHSA-8v5p-2cpv-c2x6
Weakness
CWE-200
Updated
2026-11-02
OSVGHSA-8v5p-2cpv-c2x6 No score

Apache Tomcat Source Code Disclosure

Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default servlet, allows remote attackers to read source code for server files or bypass certain protections, a variant of CAN-2002-1148.

Record
GHSA-8v5p-2cpv-c2x6
Weakness
CWE-200
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.tomcat:tomcat
Maven
through 4.0.5
4.0.6
tomcat4
Debian:3.0
before 4.0.3-3woody2
4.0.3-3woody2
org.apache.tomcat:tomcat
Maven
before 4.0.6
4.0.6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2002-1394 is a high vulnerability (CVSS 7.5) in Apache Tomcat, published January 9, 2003. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.85%, the 93rd percentile. Fixed in org.apache.tomcat:tomcat 4.0.6.

References

Show 14 moreShow less
MoveEnter Open