Every CVE Search/ Get API key

CVE-2003-0099

Multiple buffer overflows in apcupsd before 3.8.6, and 3.10.x before 3.10.5, may allow attackers...

7.2 HighFix available

Multiple buffer overflows in apcupsd before 3.8.6, and 3.10.x before 3.10.5, may allow attackers to cause a denial of service or execute arbitrary code, related to usage of the vsprintf function.

Exploit likelihood

0.55%Down 1.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.2

Multiple buffer overflows in apcupsd before 3.8.6, and 3.10.x before 3.10.5, may allow attackers to cause a denial of service or execute arbitrary code, related to usage of the vsprintf function.

Record
CVE-2003-0099
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

Multiple buffer overflows in apcupsd before 3.8.6, and 3.10.x before 3.10.5, may allow attackers to cause a denial of service or execute arbitrary code, related to usage of the vsprintf function.

Record
CVE-2003-0099
Updated
2026-11-02
EUVDEUVD-2003-0095 No score

Multiple buffer overflows in apcupsd before 3.8.6, and 3.10.x before 3.10.5, may allow attackers to cause a denial of service or execute arbitrary code, related to usage of the vsprintf function.

Record
EUVD-2003-0095
Updated
2026-11-03
GitHub AdvisoriesGHSA-26pm-xqvm-vjf3 No score

Multiple buffer overflows in apcupsd before 3.8.6, and 3.10.x before 3.10.5, may allow attackers...

Multiple buffer overflows in apcupsd before 3.8.6, and 3.10.x before 3.10.5, may allow attackers to cause a denial of service or execute arbitrary code, related to usage of the vsprintf function.

Record
GHSA-26pm-xqvm-vjf3
Updated
2026-11-02
OSV No score

Multiple buffer overflows in apcupsd before 3.8.6, and 3.10.x before 3.10.5, may allow attackers to cause a denial of service or execute arbitrary code, related to usage of the vsprintf function.

Record
CVE-2003-0099
Updated
2026-11-02
OSVDEBIAN-CVE-2003-0099 No score

Multiple buffer overflows in apcupsd before 3.8.6, and 3.10.x before 3.10.5, may allow attackers to cause a denial of service or execute arbitrary code, related to usage of the vsprintf function.

Record
DEBIAN-CVE-2003-0099
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apcupsd
Debian:12
before 3.8.5-1.2
3.8.5-1.2
apcupsd
Debian:13
before 3.8.5-1.2
3.8.5-1.2
apcupsd
Debian:14
before 3.8.5-1.2
3.8.5-1.2
apcupsd
Debian:3.0
before 3.8.5-1.1.1
3.8.5-1.1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2003-0099 is a high vulnerability (CVSS 7.2) in Apc Apcupsd, published February 26, 2003. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.55%, the 46th percentile. Fixed in apcupsd 3.8.5-1.2.

References

Show 5 moreShow less
MoveEnter Open