CVE-2003-0201
Buffer overflow in the call_trans2open function in trans2.c for Samba 2.2.x before 2.2.8a, 2.0.10...
CVE-2003-0201 is a high vulnerability (CVSS 10.0) in Samba, published April 7, 2003. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 84.6%, the 99th percentile. Fixed in samba 3.0.
Buffer overflow in the call_trans2open function in trans2.c for Samba 2.2.x before 2.2.8a, 2.0.10 and earlier 2.0.x versions, and Samba-TNG before 0.3.2, allows remote attackers to execute arbitrary code.
Exploit likelihood
What each source reports
NVD Score used
10.0
Buffer overflow in the call_trans2open function in trans2.c for Samba 2.2.x before 2.2.8a, 2.0.10 and earlier 2.0.x versions, and Samba-TNG before 0.3.2, allows remote attackers to execute arbitrary code.
- Record
CVE-2003-0201- CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Updated
- 2026-11-02
CVE List No score
Buffer overflow in the call_trans2open function in trans2.c for Samba 2.2.x before 2.2.8a, 2.0.10 and earlier 2.0.x versions, and Samba-TNG before 0.3.2, allows remote attackers to execute arbitrary code.
- Record
CVE-2003-0201- Updated
- 2026-11-02
EUVDEUVD-2003-0196 No score
Buffer overflow in the call_trans2open function in trans2.c for Samba 2.2.x before 2.2.8a, 2.0.10 and earlier 2.0.x versions, and Samba-TNG before 0.3.2, allows remote attackers to execute arbitrary code.
- Record
EUVD-2003-0196- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6mm7-g5cc-wpx6 No score
Buffer overflow in the call_trans2open function in trans2.c for Samba 2.2.x before 2.2.8a, 2.0.10...
Buffer overflow in the call_trans2open function in trans2.c for Samba 2.2.x before 2.2.8a, 2.0.10 and earlier 2.0.x versions, and Samba-TNG before 0.3.2, allows remote attackers to execute arbitrary code.
- Record
GHSA-6mm7-g5cc-wpx6- Updated
- 2026-11-02
OSV No score
Buffer overflow in the call_trans2open function in trans2.c for Samba 2.2.x before 2.2.8a, 2.0.10 and earlier 2.0.x versions, and Samba-TNG before 0.3.2, allows remote attackers to execute arbitrary code.
- Record
CVE-2003-0201- Updated
- 2026-11-02
OSVDEBIAN-CVE-2003-0201 No score
Buffer overflow in the call_trans2open function in trans2.c for Samba 2.2.x before 2.2.8a, 2.0.10 and earlier 2.0.x versions, and Samba-TNG before 0.3.2, allows remote attackers to execute arbitrary code.
- Record
DEBIAN-CVE-2003-0201- Updated
- 2026-11-02
Affected products
Affected packages
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Samba < 2.2.8 (Linux/BSD) - Remote Code Execution | 2003-04-10 |
| Exploit-DB | Samba 2.2.8 (Solaris SPARC) - 'trans2open' Remote Overflow (Metasploit) | 2010-06-21 |
| Exploit-DB | Samba 2.2.8 (Linux x86) - 'trans2open' Remote Overflow (Metasploit) | 2010-07-14 |
| Exploit-DB | Samba 2.2.8 (OSX/PPC) - 'trans2open' Remote Overflow (Metasploit) | 2010-06-21 |
| Exploit-DB | Samba 2.2.8 (BSD x86) - 'trans2open' Remote Overflow (Metasploit) | 2010-06-17 |
| Exploit-DB | Samba 2.2.x - 'call_trans2open' Remote Buffer Overflow (1) | 2003-04-11 |
| Exploit-DB | Samba 2.2.x - 'call_trans2open' Remote Buffer Overflow (2) | 2003-04-07 |
| Exploit-DB | Samba 2.2.x - 'call_trans2open' Remote Buffer Overflow (3) | 2003-05-12 |
| Exploit-DB | Samba 2.2.x - 'call_trans2open' Remote Buffer Overflow (4) | 2003-04-07 |
| Exploit-DB | Samba 2.2.8 - Brute Force Method Remote Command Execution | 2003-07-13 |
Show 9 moreShow less
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Samba 2.2.x - Remote Buffer Overflow | 2003-04-07 |
| Exploit-DB | Samba 2.2.0 < 2.2.8 (OSX) - trans2open Overflow (Metasploit) | 2003-04-07 |
| Metasploit | Samba trans2open Overflow (*BSD x86) | 2003-04-07 |
| Metasploit | Samba trans2open Overflow (Linux x86) | 2003-04-07 |
| Metasploit | Samba trans2open Overflow (Mac OS X PPC) | 2003-04-07 |
| Metasploit | Samba trans2open Overflow (Solaris SPARC) | 2003-04-07 |
| PoC in GitHub | KernelPan1k/trans2open-CVE-2003-0201 | 2021-04-12 |
| PoC in GitHub | americooo/pentest-writeups | 2026-06-16 |
| PoC in GitHub | deepakkcybersec-eng/Kioptrix-Level1-Vulnerability-Analysis | 2025-12-24 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV, PoC in GitHub |
References
distro.conectiva.com.br/atualizacoes?id=a&anuncio=000624
marc.info?l=bugtraq&m=104981682014565&w=2
novell.com/linux/security/advisories/2003_025_samba.html
securityfocus.com/bid/7294
digitaldefense.net/labs/advisories/DDI-1013.txt
marc.info?l=bugtraq&m=104972664226781&w=2
Show 11 moreShow less
debian.org/security/2003/dsa-280
marc.info?l=bugtraq&m=104994564212488&w=2
kb.cert.org/vuls/id/267873
mandriva.com/security/advisories?name=MDKSA-2003:044
redhat.com/support/errata/RHSA-2003-137.html
marc.info?l=bugtraq&m=104974612519064&w=2
oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A567
oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A2163
nvd.nist.gov/vuln/detail/CVE-2003-0201
github.com/advisories/GHSA-6mm7-g5cc-wpx6
security-tracker.debian.org/tracker/CVE-2003-0201