CVE-2003-0204
KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via ...
KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via (1) PostScript (PS) or (2) PDF files, related to missing -dPARANOIDSAFER and -dSAFER arguments when using the kghostview Ghostscript viewer.
Exploit likelihood
What each source reports
NVD Score used
7.5
KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via (1) PostScript (PS) or (2) PDF files, related to missing -dPARANOIDSAFER and -dSAFER arguments when using the kghostview Ghostscript viewer.
- Record
CVE-2003-0204- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via (1) PostScript (PS) or (2) PDF files, related to missing -dPARANOIDSAFER and -dSAFER arguments when using the kghostview Ghostscript viewer.
- Record
CVE-2003-0204- Updated
- 2026-11-02
EUVDEUVD-2003-0199 No score
KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via (1) PostScript (PS) or (2) PDF files, related to missing -dPARANOIDSAFER and -dSAFER arguments when using the kghostview Ghostscript viewer.
- Record
EUVD-2003-0199- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-crvp-f24v-6fh3 No score
KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via ...
KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via (1) PostScript (PS) or (2) PDF files, related to missing -dPARANOIDSAFER and -dSAFER arguments when using the kghostview Ghostscript viewer.
- Record
GHSA-crvp-f24v-6fh3- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
kdegraphicsDebian:3.0 |
before 3.8.10-1.2 | 3.8.10-1.2 |
kdebaseDebian:3.0 |
before 4:2.2.2-13.woody.7 | 4:2.2.2-13.woody.7 |
kdebaseDebian:3.0 |
before 2.2.2-14.4 | 2.2.2-14.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2003-0204 is a high vulnerability (CVSS 7.5) in Kde, published April 12, 2003. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.03%, the 90th percentile. Fixed in kdegraphics 3.8.10-1.2.
References
marc.info?l=bugtraq&m=105017403010459&w=2
mandriva.com/security/advisories?name=MDKSA-2003:049
distro.conectiva.com.br/atualizacoes?id=a&anuncio=000668
debian.org/security/2003/dsa-296
bugs.kde.org/show_bug.cgi?id=53343
marc.info?l=bugtraq&m=105034222521369&w=2
Show 10 moreShow less
distro.conectiva.com.br/atualizacoes?id=a&anuncio=000747
kde.org/info/security/advisory-20030409-1.txt
redhat.com/support/errata/RHSA-2003-002.html
bugs.kde.org/show_bug.cgi?id=56808
marc.info?l=bugtraq&m=105001557020141&w=2
debian.org/security/2003/dsa-284
debian.org/security/2003/dsa-293
marc.info?l=bugtraq&m=105012994719099&w=2
nvd.nist.gov/vuln/detail/CVE-2003-0204
github.com/advisories/GHSA-crvp-f24v-6fh3