Every CVE Search/ Get API key

CVE-2003-0204

KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via ...

7.5 HighFix available

KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via (1) PostScript (PS) or (2) PDF files, related to missing -dPARANOIDSAFER and -dSAFER arguments when using the kghostview Ghostscript viewer.

Exploit likelihood

4.03%Up 1.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via (1) PostScript (PS) or (2) PDF files, related to missing -dPARANOIDSAFER and -dSAFER arguments when using the kghostview Ghostscript viewer.

Record
CVE-2003-0204
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via (1) PostScript (PS) or (2) PDF files, related to missing -dPARANOIDSAFER and -dSAFER arguments when using the kghostview Ghostscript viewer.

Record
CVE-2003-0204
Updated
2026-11-02
EUVDEUVD-2003-0199 No score

KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via (1) PostScript (PS) or (2) PDF files, related to missing -dPARANOIDSAFER and -dSAFER arguments when using the kghostview Ghostscript viewer.

Record
EUVD-2003-0199
Updated
2026-11-03
GitHub AdvisoriesGHSA-crvp-f24v-6fh3 No score

KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via ...

KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via (1) PostScript (PS) or (2) PDF files, related to missing -dPARANOIDSAFER and -dSAFER arguments when using the kghostview Ghostscript viewer.

Record
GHSA-crvp-f24v-6fh3
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
kdegraphics
Debian:3.0
before 3.8.10-1.2
3.8.10-1.2
kdebase
Debian:3.0
before 4:2.2.2-13.woody.7
4:2.2.2-13.woody.7
kdebase
Debian:3.0
before 2.2.2-14.4
2.2.2-14.4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2003-0204 is a high vulnerability (CVSS 7.5) in Kde, published April 12, 2003. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.03%, the 90th percentile. Fixed in kdegraphics 3.8.10-1.2.

References

Show 10 moreShow less
MoveEnter Open