Every CVE Search/ Get API key

CVE-2003-0442

Cross-site scripting (XSS) vulnerability in the transparent SID support capability for PHP before...

4.3 MediumPublic exploitFix available

CVE-2003-0442 is a medium vulnerability (CVSS 4.3) in Php, published June 20, 2003. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 6.98%, the 94th percentile. Fixed in php4 4:4.1.2-6woody3.

Cross-site scripting (XSS) vulnerability in the transparent SID support capability for PHP before 4.3.2 (session.use_trans_sid) allows remote attackers to insert arbitrary script via the PHPSESSID parameter.

Exploit likelihood

6.98%Down 5.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the transparent SID support capability for PHP before 4.3.2 (session.use_trans_sid) allows remote attackers to insert arbitrary script via the PHPSESSID parameter.

Record
CVE-2003-0442
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the transparent SID support capability for PHP before 4.3.2 (session.use_trans_sid) allows remote attackers to insert arbitrary script via the PHPSESSID parameter.

Record
CVE-2003-0442
Updated
2026-11-02
EUVDEUVD-2003-0436 No score

Cross-site scripting (XSS) vulnerability in the transparent SID support capability for PHP before 4.3.2 (session.use_trans_sid) allows remote attackers to insert arbitrary script via the PHPSESSID parameter.

Record
EUVD-2003-0436
Updated
2026-11-03
GitHub AdvisoriesGHSA-xx7m-rfgv-w2gg No score

Cross-site scripting (XSS) vulnerability in the transparent SID support capability for PHP before...

Cross-site scripting (XSS) vulnerability in the transparent SID support capability for PHP before 4.3.2 (session.use_trans_sid) allows remote attackers to insert arbitrary script via the PHPSESSID parameter.

Record
GHSA-xx7m-rfgv-w2gg
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php4
Debian:3.0
before 4:4.1.2-6woody3
4:4.1.2-6woody3

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBPHP 4.x - Transparent Session ID Cross-Site Scripting2003-05-30

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

References

Show 10 moreShow less
MoveEnter Open