CVE-2003-0442
Cross-site scripting (XSS) vulnerability in the transparent SID support capability for PHP before...
CVE-2003-0442 is a medium vulnerability (CVSS 4.3) in Php, published June 20, 2003. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 6.98%, the 94th percentile. Fixed in php4 4:4.1.2-6woody3.
Cross-site scripting (XSS) vulnerability in the transparent SID support capability for PHP before 4.3.2 (session.use_trans_sid) allows remote attackers to insert arbitrary script via the PHPSESSID parameter.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in the transparent SID support capability for PHP before 4.3.2 (session.use_trans_sid) allows remote attackers to insert arbitrary script via the PHPSESSID parameter.
- Record
CVE-2003-0442- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the transparent SID support capability for PHP before 4.3.2 (session.use_trans_sid) allows remote attackers to insert arbitrary script via the PHPSESSID parameter.
- Record
CVE-2003-0442- Updated
- 2026-11-02
EUVDEUVD-2003-0436 No score
Cross-site scripting (XSS) vulnerability in the transparent SID support capability for PHP before 4.3.2 (session.use_trans_sid) allows remote attackers to insert arbitrary script via the PHPSESSID parameter.
- Record
EUVD-2003-0436- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xx7m-rfgv-w2gg No score
Cross-site scripting (XSS) vulnerability in the transparent SID support capability for PHP before...
Cross-site scripting (XSS) vulnerability in the transparent SID support capability for PHP before 4.3.2 (session.use_trans_sid) allows remote attackers to insert arbitrary script via the PHPSESSID parameter.
- Record
GHSA-xx7m-rfgv-w2gg- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
php4Debian:3.0 |
before 4:4.1.2-6woody3 | 4:4.1.2-6woody3 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | PHP 4.x - Transparent Session ID Cross-Site Scripting | 2003-05-30 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
References
mandriva.com/security/advisories?name=MDKSA-2003:082
securitytracker.com/id?1008653
securityfocus.com/bid/7761
distro.conectiva.com.br/atualizacoes?id=a&anuncio=000691
shh.thathost.com/secadv/2003-05-11-php.txt
debian.org/security/2003/dsa-351
Show 10 moreShow less
exchange.xforce.ibmcloud.com/vulnerabilities/12259
marc.info?l=bugtraq&m=105760591228031&w=2
turbolinux.co.jp/security/2003/TLSA-2003-47j.txt
oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A485
marc.info?l=bugtraq&m=105449314612963&w=2
osvdb.org/4758
ciac.org/ciac/bulletins/n-112.shtml
redhat.com/support/errata/RHSA-2003-204.html
nvd.nist.gov/vuln/detail/CVE-2003-0442
github.com/advisories/GHSA-xx7m-rfgv-w2gg