Every CVE Search/ Get API key

CVE-2005-0639

Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code...

7.5 HighFix available

CVE-2005-0639 is a high vulnerability (CVSS 7.5) in Xli, published March 2, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.82%, the 86th percentile. Fixed in xli 1.17.0-17.

Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.

Exploit likelihood

2.82%Down 3.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.

Record
CVE-2005-0639
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.

Record
CVE-2005-0639
Updated
2026-11-02
EUVDEUVD-2005-0640 No score

Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.

Record
EUVD-2005-0640
Updated
2026-11-03
GitHub AdvisoriesGHSA-xjf2-8w34-fqm8 No score

Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code...

Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.

Record
GHSA-xjf2-8w34-fqm8
Updated
2026-11-02
OSV No score

Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.

Record
CVE-2005-0639
Updated
2026-11-02
OSVDEBIAN-CVE-2005-0639 No score

Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.

Record
DEBIAN-CVE-2005-0639
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xli
Debian:12
before 1.17.0-17
1.17.0-17
xli
Debian:13
before 1.17.0-17
1.17.0-17
xli
Debian:14
before 1.17.0-17
1.17.0-17
xloadimage
Debian:12
before 4.1-14.2
4.1-14.2
xloadimage
Debian:13
before 4.1-14.2
4.1-14.2
xloadimage
Debian:14
before 4.1-14.2
4.1-14.2
xloadimage
Debian:3.0
before 4.1-10woody1, plus listed versions
4.1-10
4.1-10woody1
xli
Debian:3.0
before 1.17.0-11woody1, plus listed versions
1.17.0-11
1.17.0-11woody1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open