CVE-2005-0639
Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code...
CVE-2005-0639 is a high vulnerability (CVSS 7.5) in Xli, published March 2, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.82%, the 86th percentile. Fixed in xli 1.17.0-17.
Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.
Exploit likelihood
What each source reports
NVD Score used
7.5
Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.
- Record
CVE-2005-0639- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.
- Record
CVE-2005-0639- Updated
- 2026-11-02
EUVDEUVD-2005-0640 No score
Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.
- Record
EUVD-2005-0640- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xjf2-8w34-fqm8 No score
Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code...
Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.
- Record
GHSA-xjf2-8w34-fqm8- Updated
- 2026-11-02
OSV No score
Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.
- Record
CVE-2005-0639- Updated
- 2026-11-02
OSVDEBIAN-CVE-2005-0639 No score
Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.
- Record
DEBIAN-CVE-2005-0639- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
xliDebian:12 |
before 1.17.0-17 | 1.17.0-17 |
xliDebian:13 |
before 1.17.0-17 | 1.17.0-17 |
xliDebian:14 |
before 1.17.0-17 | 1.17.0-17 |
xloadimageDebian:12 |
before 4.1-14.2 | 4.1-14.2 |
xloadimageDebian:13 |
before 4.1-14.2 | 4.1-14.2 |
xloadimageDebian:14 |
before 4.1-14.2 | 4.1-14.2 |
xloadimageDebian:3.0 |
before 4.1-10woody1, plus listed versions 4.1-10 |
4.1-10woody1 |
xliDebian:3.0 |
before 1.17.0-11woody1, plus listed versions 1.17.0-11 |
1.17.0-11woody1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |