CVE-2005-0870
Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is...
Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.
Exploit likelihood
What each source reports
NVD Score used
4.3
Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.
- Record
CVE-2005-0870- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Updated
- 2026-11-02
CVE List No score
Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.
- Record
CVE-2005-0870- Updated
- 2026-11-02
EUVDEUVD-2005-0871 No score
Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.
- Record
EUVD-2005-0871- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m488-92rv-23cc No score
Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is...
Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.
- Record
GHSA-m488-92rv-23cc- Updated
- 2026-11-02
OSV No score
Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.
- Record
CVE-2005-0870- Updated
- 2026-11-02
OSVDEBIAN-CVE-2005-0870 No score
Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.
- Record
DEBIAN-CVE-2005-0870- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
phpsysinfoDebian:12 |
before 2.3-7 | 2.3-7 |
phpsysinfoDebian:13 |
before 2.3-7 | 2.3-7 |
phpsysinfoDebian:14 |
before 2.3-7 | 2.3-7 |
phpsysinfoDebian:3.0 |
before 2.0-3woody2, plus listed versions 2.0-3woody1 |
2.0-3woody2 |
phpsysinfoDebian:3.0 |
before 2.0-3woody3, plus listed versions 2.0-3woody12.0-3woody2 |
2.0-3woody3 |
phpsysinfoDebian:3.1 |
before 2.3-4sarge1, plus listed versions 2.3-4 |
2.3-4sarge1 |
phpgroupwareDebian:3.0 |
before 0.9.14-0.RC3.2.woody5, plus listed versions 0.9.14-0.RC3.2.woody30.9.14-0.RC3.2.woody4 |
0.9.14-0.RC3.2.woody5 |
phpgroupwareDebian:3.1 |
before 0.9.16.005-3.sarge4, plus listed versions 0.9.16.005-30.9.16.005-3.sarge00.9.16.005-3.sarge10.9.16.005-3.sarge20.9.16.005-3.sarge3 |
0.9.16.005-3.sarge4 |
egroupwareDebian:3.1 |
before 1.0.0.007-2.dfsg-2sarge4, plus listed versions 1.0.0.007-2.dfsg-21.0.0.007-2.dfsg-2sarge11.0.0.007-2.dfsg-2sarge21.0.0.007-2.dfsg-2sarge3 |
1.0.0.007-2.dfsg-2sarge4 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | PHPSysInfo 2.0/2.3 - 'sensor_program' Cross-Site Scripting | 2005-03-23 |
| Exploit-DB | PHPSysInfo 2.0/2.3 - 'system_footer.php' Cross-Site Scripting | 2005-03-23 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2005-0870 is a medium vulnerability (CVSS 4.3) in Phpsysinfo, published March 26, 2005. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 3.72%, the 89th percentile. Fixed in phpsysinfo 2.3-7.
References
secunia.com/advisories/17616
mandriva.com/security/advisories?name=MDKSA-2005:212
securityfocus.com/bid/15414
secunia.com/advisories/14690
debian.org/security/2005/dsa-898
marc.info?l=bugtraq&m=111161017209422&w=2
Show 11 moreShow less
exchange.xforce.ibmcloud.com/vulnerabilities/19807
securityfocus.com/archive/1/416543
bugs.debian.org/cgi-bin/bugreport.cgi?bug=301118
securityfocus.com/bid/12887
debian.org/security/2005/dsa-897
debian.org/security/2005/dsa-724
debian.org/security/2005/dsa-899
secunia.com/advisories/17643
nvd.nist.gov/vuln/detail/CVE-2005-0870
github.com/advisories/GHSA-m488-92rv-23cc
security-tracker.debian.org/tracker/CVE-2005-0870