Every CVE Search/ Get API key

CVE-2005-0870

Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is...

4.3 MediumPublic exploitFix available

Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.

Exploit likelihood

3.72%Down 1.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.

Record
CVE-2005-0870
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.

Record
CVE-2005-0870
Updated
2026-11-02
EUVDEUVD-2005-0871 No score

Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.

Record
EUVD-2005-0871
Updated
2026-11-03
GitHub AdvisoriesGHSA-m488-92rv-23cc No score

Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is...

Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.

Record
GHSA-m488-92rv-23cc
Updated
2026-11-02
OSV No score

Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.

Record
CVE-2005-0870
Updated
2026-11-02
OSVDEBIAN-CVE-2005-0870 No score

Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.

Record
DEBIAN-CVE-2005-0870
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpsysinfo
Debian:12
before 2.3-7
2.3-7
phpsysinfo
Debian:13
before 2.3-7
2.3-7
phpsysinfo
Debian:14
before 2.3-7
2.3-7
phpsysinfo
Debian:3.0
before 2.0-3woody2, plus listed versions
2.0-3woody1
2.0-3woody2
phpsysinfo
Debian:3.0
From an advisory covering 3 CVEs
before 2.0-3woody3, plus listed versions
2.0-3woody12.0-3woody2
2.0-3woody3
phpsysinfo
Debian:3.1
From an advisory covering 3 CVEs
before 2.3-4sarge1, plus listed versions
2.3-4
2.3-4sarge1
phpgroupware
Debian:3.0
From an advisory covering 3 CVEs
before 0.9.14-0.RC3.2.woody5, plus listed versions
0.9.14-0.RC3.2.woody30.9.14-0.RC3.2.woody4
0.9.14-0.RC3.2.woody5
phpgroupware
Debian:3.1
From an advisory covering 3 CVEs
before 0.9.16.005-3.sarge4, plus listed versions
0.9.16.005-30.9.16.005-3.sarge00.9.16.005-3.sarge10.9.16.005-3.sarge20.9.16.005-3.sarge3
0.9.16.005-3.sarge4
egroupware
Debian:3.1
From an advisory covering 4 CVEs
before 1.0.0.007-2.dfsg-2sarge4, plus listed versions
1.0.0.007-2.dfsg-21.0.0.007-2.dfsg-2sarge11.0.0.007-2.dfsg-2sarge21.0.0.007-2.dfsg-2sarge3
1.0.0.007-2.dfsg-2sarge4

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-0870 is a medium vulnerability (CVSS 4.3) in Phpsysinfo, published March 26, 2005. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 3.72%, the 89th percentile. Fixed in phpsysinfo 2.3-7.

References

Show 11 moreShow less
MoveEnter Open