Every CVE Search/ Get API key

CVE-2005-2396

Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers...

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers to inject arbitrary web script or HTML via a parameter to the page move template.

Exploit likelihood

2.04%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers to inject arbitrary web script or HTML via a parameter to the page move template.

Record
CVE-2005-2396
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers to inject arbitrary web script or HTML via a parameter to the page move template.

Record
CVE-2005-2396
Updated
2026-11-02
EUVDEUVD-2005-2397 No score

Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers to inject arbitrary web script or HTML via a parameter to the page move template.

Record
EUVD-2005-2397
Updated
2026-11-03
GitHub AdvisoriesGHSA-34m5-x2xp-x8mh No score

Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers...

Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers to inject arbitrary web script or HTML via a parameter to the page move template.

Record
GHSA-34m5-x2xp-x8mh
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers to inject arbitrary web script or HTML via a parameter to the page move template.

Record
CVE-2005-2396
Updated
2026-11-02
OSVDEBIAN-CVE-2005-2396 No score

Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers to inject arbitrary web script or HTML via a parameter to the page move template.

Record
DEBIAN-CVE-2005-2396
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mediawiki
Debian:12
before 1.4.9
1.4.9
mediawiki
Debian:13
before 1.4.9
1.4.9
mediawiki
Debian:14
before 1.4.9
1.4.9

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-2396 is a medium vulnerability (CVSS 4.3) in Mediawiki, published July 27, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.04%, the 81st percentile. Fixed in mediawiki 1.4.9.

References

MoveEnter Open