CVE-2005-2396
Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers...
Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers to inject arbitrary web script or HTML via a parameter to the page move template.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers to inject arbitrary web script or HTML via a parameter to the page move template.
- Record
CVE-2005-2396- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers to inject arbitrary web script or HTML via a parameter to the page move template.
- Record
CVE-2005-2396- Updated
- 2026-11-02
EUVDEUVD-2005-2397 No score
Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers to inject arbitrary web script or HTML via a parameter to the page move template.
- Record
EUVD-2005-2397- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-34m5-x2xp-x8mh No score
Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers...
Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers to inject arbitrary web script or HTML via a parameter to the page move template.
- Record
GHSA-34m5-x2xp-x8mh- Updated
- 2026-11-02
OSV No score
Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers to inject arbitrary web script or HTML via a parameter to the page move template.
- Record
CVE-2005-2396- Updated
- 2026-11-02
OSVDEBIAN-CVE-2005-2396 No score
Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers to inject arbitrary web script or HTML via a parameter to the page move template.
- Record
DEBIAN-CVE-2005-2396- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2005-2396 is a medium vulnerability (CVSS 4.3) in Mediawiki, published July 27, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.04%, the 81st percentile. Fixed in mediawiki 1.4.9.
References
exchange.xforce.ibmcloud.com/vulnerabilities/21491
osvdb.org/17763
secunia.com/advisories/15950
securityfocus.com/bid/14327
security.gentoo.org/glsa/glsa-200507-18.xml
secunia.com/advisories/16130
nvd.nist.gov/vuln/detail/CVE-2005-2396
github.com/advisories/GHSA-34m5-x2xp-x8mh
security-tracker.debian.org/tracker/CVE-2005-2396