Every CVE Search/ Get API key

CVE-2005-2471

pstopnm in netpbm does not properly use the "-dSAFER" option when calling Ghostscript to convert...

7.5 HighFix available

pstopnm in netpbm does not properly use the "-dSAFER" option when calling Ghostscript to convert a PostScript file into a (1) PBM, (2) PGM, or (3) PNM file, which allows external user-assisted attackers to execute arbitrary commands.

Exploit likelihood

3.74%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

pstopnm in netpbm does not properly use the "-dSAFER" option when calling Ghostscript to convert a PostScript file into a (1) PBM, (2) PGM, or (3) PNM file, which allows external user-assisted attackers to execute arbitrary commands.

Record
CVE-2005-2471
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

pstopnm in netpbm does not properly use the "-dSAFER" option when calling Ghostscript to convert a PostScript file into a (1) PBM, (2) PGM, or (3) PNM file, which allows external user-assisted attackers to execute arbitrary commands.

Record
CVE-2005-2471
Updated
2026-11-02
EUVDEUVD-2005-2472 No score

pstopnm in netpbm does not properly use the "-dSAFER" option when calling Ghostscript to convert a PostScript file into a (1) PBM, (2) PGM, or (3) PNM file, which allows external user-assisted attackers to execute arbitrary commands.

Record
EUVD-2005-2472
Updated
2026-11-03
GitHub AdvisoriesGHSA-9hfq-3c4w-mxr2 No score

pstopnm in netpbm does not properly use the "-dSAFER" option when calling Ghostscript to convert...

pstopnm in netpbm does not properly use the "-dSAFER" option when calling Ghostscript to convert a PostScript file into a (1) PBM, (2) PGM, or (3) PNM file, which allows external user-assisted attackers to execute arbitrary commands.

Record
GHSA-9hfq-3c4w-mxr2
Updated
2026-11-02
OSV No score

pstopnm in netpbm does not properly use the "-dSAFER" option when calling Ghostscript to convert a PostScript file into a (1) PBM, (2) PGM, or (3) PNM file, which allows external user-assisted attackers to execute arbitrary commands.

Record
CVE-2005-2471
Updated
2026-11-02
OSVDEBIAN-CVE-2005-2471 No score

pstopnm in netpbm does not properly use the "-dSAFER" option when calling Ghostscript to convert a PostScript file into a (1) PBM, (2) PGM, or (3) PNM file, which allows external user-assisted attackers to execute arbitrary commands.

Record
DEBIAN-CVE-2005-2471
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
netpbm-free
Debian:12
before 2:10.0-9
2:10.0-9
netpbm-free
Debian:13
before 2:10.0-9
2:10.0-9
netpbm-free
Debian:14
before 2:10.0-9
2:10.0-9
netpbm-free
Debian:3.0
before 2:9.20-8.6, plus listed versions
2:9.20-8.42:9.20-8.5
2:9.20-8.6
netpbm-free
Debian:3.1
before 2:10.0-8sarge3, plus listed versions
2:10.0-82:10.0-8sarge12:10.0-8sarge2
2:10.0-8sarge3
netpbm
Red Hat:enterprise_linux:3::as
before 0:9.24-11.30.2
0:9.24-11.30.2
netpbm-debuginfo
Red Hat:enterprise_linux:3::as
before 0:9.24-11.30.2
0:9.24-11.30.2
netpbm-devel
Red Hat:enterprise_linux:3::as
before 0:9.24-11.30.2
0:9.24-11.30.2
netpbm-progs
Red Hat:enterprise_linux:3::as
before 0:9.24-11.30.2
0:9.24-11.30.2
netpbm
Red Hat:enterprise_linux:3::desktop
before 0:9.24-11.30.2
0:9.24-11.30.2
Show 27 moreShow less
Affected packages
PackageAffectedFixed
netpbm-debuginfo
Red Hat:enterprise_linux:3::desktop
before 0:9.24-11.30.2
0:9.24-11.30.2
netpbm-devel
Red Hat:enterprise_linux:3::desktop
before 0:9.24-11.30.2
0:9.24-11.30.2
netpbm-progs
Red Hat:enterprise_linux:3::desktop
before 0:9.24-11.30.2
0:9.24-11.30.2
netpbm
Red Hat:enterprise_linux:3::es
before 0:9.24-11.30.2
0:9.24-11.30.2
netpbm-debuginfo
Red Hat:enterprise_linux:3::es
before 0:9.24-11.30.2
0:9.24-11.30.2
netpbm-devel
Red Hat:enterprise_linux:3::es
before 0:9.24-11.30.2
0:9.24-11.30.2
netpbm-progs
Red Hat:enterprise_linux:3::es
before 0:9.24-11.30.2
0:9.24-11.30.2
netpbm
Red Hat:enterprise_linux:3::ws
before 0:9.24-11.30.2
0:9.24-11.30.2
netpbm-debuginfo
Red Hat:enterprise_linux:3::ws
before 0:9.24-11.30.2
0:9.24-11.30.2
netpbm-devel
Red Hat:enterprise_linux:3::ws
before 0:9.24-11.30.2
0:9.24-11.30.2
netpbm-progs
Red Hat:enterprise_linux:3::ws
before 0:9.24-11.30.2
0:9.24-11.30.2
netpbm
Red Hat:enterprise_linux:4::as
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1
netpbm-debuginfo
Red Hat:enterprise_linux:4::as
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1
netpbm-devel
Red Hat:enterprise_linux:4::as
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1
netpbm-progs
Red Hat:enterprise_linux:4::as
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1
netpbm
Red Hat:enterprise_linux:4::desktop
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1
netpbm-debuginfo
Red Hat:enterprise_linux:4::desktop
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1
netpbm-devel
Red Hat:enterprise_linux:4::desktop
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1
netpbm-progs
Red Hat:enterprise_linux:4::desktop
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1
netpbm
Red Hat:enterprise_linux:4::es
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1
netpbm-debuginfo
Red Hat:enterprise_linux:4::es
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1
netpbm-devel
Red Hat:enterprise_linux:4::es
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1
netpbm-progs
Red Hat:enterprise_linux:4::es
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1
netpbm
Red Hat:enterprise_linux:4::ws
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1
netpbm-debuginfo
Red Hat:enterprise_linux:4::ws
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1
netpbm-devel
Red Hat:enterprise_linux:4::ws
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1
netpbm-progs
Red Hat:enterprise_linux:4::ws
before 0:10.25-2.EL4.1
0:10.25-2.EL4.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-2471 is a high vulnerability (CVSS 7.5) in Netpbm, published August 5, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.74%, the 89th percentile. Fixed in netpbm-free 2:10.0-9.

References

Show 17 moreShow less
MoveEnter Open