Every CVE Search/ Get API key

CVE-2005-2536

pstotext before 1.8g does not properly use the "-dSAFER" option when calling Ghostscript to...

7.5 HighFix available

pstotext before 1.8g does not properly use the "-dSAFER" option when calling Ghostscript to extract plain text from PostScript and PDF files, which allows remote attackers to execute arbitrary commands via a malicious PostScript file.

Exploit likelihood

2.34%Up 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

pstotext before 1.8g does not properly use the "-dSAFER" option when calling Ghostscript to extract plain text from PostScript and PDF files, which allows remote attackers to execute arbitrary commands via a malicious PostScript file.

Record
CVE-2005-2536
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

pstotext before 1.8g does not properly use the "-dSAFER" option when calling Ghostscript to extract plain text from PostScript and PDF files, which allows remote attackers to execute arbitrary commands via a malicious PostScript file.

Record
CVE-2005-2536
Updated
2026-11-02
EUVDEUVD-2005-2537 No score

pstotext before 1.8g does not properly use the "-dSAFER" option when calling Ghostscript to extract plain text from PostScript and PDF files, which allows remote attackers to execute arbitrary commands via a malicious PostScript file.

Record
EUVD-2005-2537
Updated
2026-11-03
GitHub AdvisoriesGHSA-rgwq-9vqf-cvgq No score

pstotext before 1.8g does not properly use the "-dSAFER" option when calling Ghostscript to...

pstotext before 1.8g does not properly use the "-dSAFER" option when calling Ghostscript to extract plain text from PostScript and PDF files, which allows remote attackers to execute arbitrary commands via a malicious PostScript file.

Record
GHSA-rgwq-9vqf-cvgq
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pstotext
Debian:3.0
before 1.8g-5woody1, plus listed versions
1.8g-5
1.8g-5woody1
pstotext
Debian:3.1
before 1.9-1sarge1, plus listed versions
1.9-1
1.9-1sarge1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-2536 is a high vulnerability (CVSS 7.5) in Pstotext, published August 10, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.34%, the 83rd percentile. Fixed in pstotext 1.8g-5woody1.

References

MoveEnter Open