Every CVE Search/ Get API key

CVE-2005-2558

Stack-based buffer overflow in the init_syms function in MySQL 4.0 before 4.0.25, 4.1 before 4.1...

4.6 MediumFix available

Stack-based buffer overflow in the init_syms function in MySQL 4.0 before 4.0.25, 4.1 before 4.1.13, and 5.0 before 5.0.7-beta allows remote authenticated users who can create user-defined functions to execute arbitrary code via a long function_name field.

Exploit likelihood

2.33%Down 6.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.6

Stack-based buffer overflow in the init_syms function in MySQL 4.0 before 4.0.25, 4.1 before 4.1.13, and 5.0 before 5.0.7-beta allows remote authenticated users who can create user-defined functions to execute arbitrary code via a long function_name field.

Record
CVE-2005-2558
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Stack-based buffer overflow in the init_syms function in MySQL 4.0 before 4.0.25, 4.1 before 4.1.13, and 5.0 before 5.0.7-beta allows remote authenticated users who can create user-defined functions to execute arbitrary code via a long function_name field.

Record
CVE-2005-2558
Updated
2026-11-02
EUVDEUVD-2005-2559 No score

Stack-based buffer overflow in the init_syms function in MySQL 4.0 before 4.0.25, 4.1 before 4.1.13, and 5.0 before 5.0.7-beta allows remote authenticated users who can create user-defined functions to execute arbitrary code via a long function_name field.

Record
EUVD-2005-2559
Updated
2026-11-03
GitHub AdvisoriesGHSA-qxmx-9x27-fp8j No score

Stack-based buffer overflow in the init_syms function in MySQL 4.0 before 4.0.25, 4.1 before 4.1...

Stack-based buffer overflow in the init_syms function in MySQL 4.0 before 4.0.25, 4.1 before 4.1.13, and 5.0 before 5.0.7-beta allows remote authenticated users who can create user-defined functions to execute arbitrary code via a long function_name field.

Record
GHSA-qxmx-9x27-fp8j
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mysql
Debian:3.0
before 3.23.49-8.14, plus listed versions
3.23.49-8.103.23.49-8.113.23.49-8.133.23.49-8.83.23.49-8.9
3.23.49-8.14
mysql-dfsg-4.1
Debian:3.1
before 4.1.11a-4sarge2, plus listed versions
4.1.11a-44.1.11a-4sarge1
4.1.11a-4sarge2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-2558 is a medium vulnerability (CVSS 4.6) in Mysql, published August 16, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.33%, the 83rd percentile. Fixed in mysql 3.23.49-8.14.

References

Show 14 moreShow less
MoveEnter Open