Every CVE Search/ Get API key

CVE-2005-3418

Multiple cross-site scripting (XSS) vulnerabilities in phpBB 2.0.17 and earlier allow remote...

4.3 MediumFix available

Multiple cross-site scripting (XSS) vulnerabilities in phpBB 2.0.17 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) error_msg parameter to usercp_register.php, (2) forward_page parameter to login.php, and (3) list_cat parameter to search.php, which are not initialized as variables.

Exploit likelihood

1.84%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Multiple cross-site scripting (XSS) vulnerabilities in phpBB 2.0.17 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) error_msg parameter to usercp_register.php, (2) forward_page parameter to login.php, and (3) list_cat parameter to search.php, which are not initialized as variables.

Record
CVE-2005-3418
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in phpBB 2.0.17 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) error_msg parameter to usercp_register.php, (2) forward_page parameter to login.php, and (3) list_cat parameter to search.php, which are not initialized as variables.

Record
CVE-2005-3418
Updated
2026-11-02
EUVDEUVD-2005-3417 No score

Multiple cross-site scripting (XSS) vulnerabilities in phpBB 2.0.17 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) error_msg parameter to usercp_register.php, (2) forward_page parameter to login.php, and (3) list_cat parameter to search.php, which are not initialized as variables.

Record
EUVD-2005-3417
Updated
2026-11-03
GitHub AdvisoriesGHSA-f86m-4hjx-mgqr No score

Multiple cross-site scripting (XSS) vulnerabilities in phpBB 2.0.17 and earlier allow remote...

Multiple cross-site scripting (XSS) vulnerabilities in phpBB 2.0.17 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) error_msg parameter to usercp_register.php, (2) forward_page parameter to login.php, and (3) list_cat parameter to search.php, which are not initialized as variables.

Record
GHSA-f86m-4hjx-mgqr
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpbb2
Debian:3.1
before 2.0.13+1-6sarge2, plus listed versions
2.0.13+1-62.0.13+1-6sarge1
2.0.13+1-6sarge2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-3418 is a medium vulnerability (CVSS 4.3) in Phpbb Group Phpbb, published November 1, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.84%, the 79th percentile. Fixed in phpbb2 2.0.13+1-6sarge2.

References

Show 8 moreShow less
MoveEnter Open