Every CVE Search/ Get API key

CVE-2005-3751

HTTP request smuggling vulnerability in Pound before 1.9.4 allows remote attackers to poison web...

4.3 MediumFix available

HTTP request smuggling vulnerability in Pound before 1.9.4 allows remote attackers to poison web caches, bypass web application firewall protection, and conduct XSS attacks via an HTTP request with conflicting Content-length and Transfer-encoding headers.

Exploit likelihood

1.47%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

HTTP request smuggling vulnerability in Pound before 1.9.4 allows remote attackers to poison web caches, bypass web application firewall protection, and conduct XSS attacks via an HTTP request with conflicting Content-length and Transfer-encoding headers.

Record
CVE-2005-3751
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

HTTP request smuggling vulnerability in Pound before 1.9.4 allows remote attackers to poison web caches, bypass web application firewall protection, and conduct XSS attacks via an HTTP request with conflicting Content-length and Transfer-encoding headers.

Record
CVE-2005-3751
Updated
2026-11-02
EUVDEUVD-2005-3746 No score

HTTP request smuggling vulnerability in Pound before 1.9.4 allows remote attackers to poison web caches, bypass web application firewall protection, and conduct XSS attacks via an HTTP request with conflicting Content-length and Transfer-encoding headers.

Record
EUVD-2005-3746
Updated
2026-11-03
GitHub AdvisoriesGHSA-5349-pqgh-vm4f No score

HTTP request smuggling vulnerability in Pound before 1.9.4 allows remote attackers to poison web...

HTTP request smuggling vulnerability in Pound before 1.9.4 allows remote attackers to poison web caches, bypass web application firewall protection, and conduct XSS attacks via an HTTP request with conflicting Content-length and Transfer-encoding headers.

Record
GHSA-5349-pqgh-vm4f
Updated
2026-11-02
OSV No score

HTTP request smuggling vulnerability in Pound before 1.9.4 allows remote attackers to poison web caches, bypass web application firewall protection, and conduct XSS attacks via an HTTP request with conflicting Content-length and Transfer-encoding headers.

Record
CVE-2005-3751
Updated
2026-11-02
OSVDEBIAN-CVE-2005-3751 No score

HTTP request smuggling vulnerability in Pound before 1.9.4 allows remote attackers to poison web caches, bypass web application firewall protection, and conduct XSS attacks via an HTTP request with conflicting Content-length and Transfer-encoding headers.

Record
DEBIAN-CVE-2005-3751
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pound
Debian:13
before 1.9.4-1
1.9.4-1
pound
Debian:14
before 1.9.4-1
1.9.4-1
pound
Debian:3.1
From an advisory covering 2 CVEs
before 1.8.2-1sarge1, plus listed versions
1.8.2-1
1.8.2-1sarge1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2005-3751 is a medium vulnerability (CVSS 4.3) in Apsis Pound, published November 22, 2005. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.47%, the 73rd percentile. Fixed in pound 1.9.4-1.

References

Show 5 moreShow less
MoveEnter Open